aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..1ecbcfd
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,27 @@
+## Process this file with automake to produce Makefile.in
+
+## Created by Anjuta
+
+AM_CPPFLAGS = \
+ -DPACKAGE_LOCALE_DIR=\""$(localedir)"\" \
+ -DPACKAGE_SRC_DIR=\""$(srcdir)"\" \
+ "$(POPPLER_CFLAGS)" \
+ -DPACKAGE_DATA_DIR=\""$(pkgdatadir)"\"
+
+AM_CFLAGS =\
+ -Wall\
+ -g
+
+bin_PROGRAMS = pdf2gerber
+
+pdf2gerber_SOURCES = \
+ main.cc \
+ gerber-output-dev.cc \
+ gerber-output-dev.h
+
+pdf2gerber_LDFLAGS =
+
+pdf2gerber_LDADD = \
+ $(POPPLER_LIBS)
+
+