aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Barksdale <amatus@amat.us>2019-01-01 17:57:24 -0600
committerDavid Barksdale <amatus@amat.us>2019-01-01 17:57:24 -0600
commite05d90be8cf4b5e2144253ee839832565045abe6 (patch)
tree30fc211115776a7d6fa86a6ed000a2a1e0053a28 /src/Makefile.am
Initial commit before things get crazyHEADmaster
This seems to be interpreting everything in some pdf files I have generated from McCAD (via printing to postscript) except for text. The scale also needs to be considered.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..1ecbcfd
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,27 @@
+## Process this file with automake to produce Makefile.in
+
+## Created by Anjuta
+
+AM_CPPFLAGS = \
+ -DPACKAGE_LOCALE_DIR=\""$(localedir)"\" \
+ -DPACKAGE_SRC_DIR=\""$(srcdir)"\" \
+ "$(POPPLER_CFLAGS)" \
+ -DPACKAGE_DATA_DIR=\""$(pkgdatadir)"\"
+
+AM_CFLAGS =\
+ -Wall\
+ -g
+
+bin_PROGRAMS = pdf2gerber
+
+pdf2gerber_SOURCES = \
+ main.cc \
+ gerber-output-dev.cc \
+ gerber-output-dev.h
+
+pdf2gerber_LDFLAGS =
+
+pdf2gerber_LDADD = \
+ $(POPPLER_LIBS)
+
+