aboutsummaryrefslogtreecommitdiff
path: root/src/target/Makefile.am
diff options
context:
space:
mode:
authorAdrian Burns <adrian.burns@intel.com>2014-02-06 17:11:15 +0000
committerAndreas Fritiofson <andreas.fritiofson@gmail.com>2014-02-11 13:07:29 +0000
commit1338cf60b91c582fa4b27d5226ab4374117be415 (patch)
tree1dbf81001fe7a650372b88c7c979c62b121d47f5 /src/target/Makefile.am
parent005d85d56cfed72326f73e93eae105840b21645d (diff)
quark_x10xx: add new target quark_x10xx
Intel Quark X10xx SoC debug support added Lakemont version 1 (LMT1) is the x86 core in Quark X10xx SoC Generic x86 32-bit code is in x86_32_common.c/h Change-Id: If2bf77275cd0277a82558cd9895b4c66155cf368 Signed-off-by: adrian.burns@intel.com Reviewed-on: http://openocd.zylin.com/1829 Tested-by: jenkins Reviewed-by: Andreas Fritiofson <andreas.fritiofson@gmail.com>
Diffstat (limited to 'src/target/Makefile.am')
-rw-r--r--src/target/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/target/Makefile.am b/src/target/Makefile.am
index 4d9ea418..159f0fa4 100644
--- a/src/target/Makefile.am
+++ b/src/target/Makefile.am
@@ -35,6 +35,7 @@ libtarget_la_SOURCES = \
$(AVR32_SRC) \
$(MIPS32_SRC) \
$(NDS32_SRC) \
+ $(INTEL_IA32_SRC) \
avrt.c \
dsp563xx.c \
dsp563xx_once.c \
@@ -124,6 +125,10 @@ NDS32_SRC = \
nds32_v3m.c \
nds32_aice.c
+INTEL_IA32_SRC = \
+ quark_x10xx.c \
+ lakemont.c \
+ x86_32_common.c
noinst_HEADERS = \
algorithm.h \
@@ -191,7 +196,9 @@ noinst_HEADERS = \
nds32_v3_common.h \
nds32_v3.h \
nds32_v3m.h \
- nds32_aice.h
+ nds32_aice.h \
+ lakemont.h \
+ x86_32_common.h
ocddatadir = $(pkglibdir)
nobase_dist_ocddata_DATA =