aboutsummaryrefslogtreecommitdiff
path: root/src/jtag/drivers/Makefile.am
diff options
context:
space:
mode:
authorOleksij Rempel <linux@rempel-privat.de>2020-02-03 19:44:40 +0100
committerOleksij Rempel <linux@rempel-privat.de>2020-03-03 06:48:43 +0000
commit8abe91cff960709ffd3ebbb9eb1dcf710dd83c1f (patch)
treeb309510f1f52a130f865cd103693a4f46cacbfe5 /src/jtag/drivers/Makefile.am
parenta01474bb4c4c43a2d10781668efa26e6774364ed (diff)
remove libusb0_common support
Supporting two libusb versions provides additional development challenges without additional advantage. In most cases we need to patch libusb0_common and libusb1_common without real ability to test libusb0_common. Change-Id: Icbb19c6809b14533fe2acf7a877377b3be4cbd61 Signed-off-by: Oleksij Rempel <linux@rempel-privat.de> Reviewed-on: http://openocd.zylin.com/5432 Tested-by: jenkins
Diffstat (limited to 'src/jtag/drivers/Makefile.am')
-rw-r--r--src/jtag/drivers/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/jtag/drivers/Makefile.am b/src/jtag/drivers/Makefile.am
index 7fbcd584..47b19470 100644
--- a/src/jtag/drivers/Makefile.am
+++ b/src/jtag/drivers/Makefile.am
@@ -31,9 +31,6 @@ if USE_LIBUSB0
DRIVERFILES += %D%/usb_common.c
%C%_libocdjtagdrivers_la_CPPFLAGS += $(LIBUSB0_CFLAGS)
%C%_libocdjtagdrivers_la_LIBADD += $(LIBUSB0_LIBS)
-if !USE_LIBUSB1
-DRIVERFILES += %D%/libusb0_common.c
-endif
endif
if USE_LIBFTDI
@@ -171,7 +168,6 @@ DRIVERHEADERS = \
%D%/bitbang.h \
%D%/bitq.h \
%D%/jtag_usb_common.h \
- %D%/libusb0_common.h \
%D%/libusb1_common.h \
%D%/libusb_common.h \
%D%/minidriver_imp.h \