Age | Commit message (Expand) | Author |
2013-01-02 | Rename VMCore directory to IR. | Chandler Carruth |
2012-12-30 | Remove Function::getParamAttributes and use the AttributeSet accessor methods... | Bill Wendling |
2012-12-19 | Refactor isIntrinsic() to be quicker, and change classof() (and thus, isa<Int... | Michael Ilseman |
2012-12-19 | Rename the 'Attributes' class to 'Attribute'. It's going to represent a singl... | Bill Wendling |
2012-12-17 | Removed trailing whitespace | Michael Ilseman |
2012-12-07 | s/AttrListPtr/AttributeSet/g to better label what this class is going to be i... | Bill Wendling |
2012-12-03 | Use the new script to sort the includes of every file under lib. | Chandler Carruth |
2012-10-15 | Attributes Rewrite | Bill Wendling |
2012-10-14 | Remove the bitwise assignment OR operator from the Attributes class. Replace ... | Bill Wendling |
2012-10-14 | Remove the bitwise NOT operator from the Attributes class. Replace it with th... | Bill Wendling |
2012-10-09 | Create enums for the different attributes. | Bill Wendling |
2012-09-26 | Query the parameter attributes directly instead of using the Attribute symbols. | Bill Wendling |
2012-05-27 | move some code around so that Verifier.cpp can get access to the intrinsic in... | Chris Lattner |
2012-05-27 | enhance the intrinsic info table to encode what *kind* of Any argument | Chris Lattner |
2012-05-23 | Fixed typo in r156905. | Patrik Hägglund |
2012-05-23 | small refinement to r157218 to save a tiny amount of table size in the common | Chris Lattner |
2012-05-21 | Added address space qualifier to intrinsic PointerType arguments. | Pete Cooper |
2012-05-17 | enhance the intrinsic info stuff to emit encodings that don't fit in 32-bits ... | Chris Lattner |
2012-05-17 | Fix compile error. | Manuel Klimek |
2012-05-17 | Genericize the intrinsics descriptor decoding a bit to make room | Chris Lattner |
2012-05-17 | finish encoding all of the interesting details of intrinsics. Now intrinsics | Chris Lattner |
2012-05-17 | strengthen the intrinsic descriptor stuff to be able to handle sin, cos and o... | Chris Lattner |
2012-05-16 | Significantly reduce the compiled size of Functions.cpp by turning a big blob... | Chris Lattner |
2012-05-12 | Teach Function::hasAddressTaken that BlockAddress doesn't really take | Jay Foad |
2012-03-01 | Emit the "is an intrinsic overloaded" table as a bitfield. | Benjamin Kramer |
2011-12-20 | Unweaken vtables as per http://llvm.org/docs/CodingStandards.html#ll_virtual_... | David Blaikie |
2011-10-20 | Refactor code from inlining and globalopt that checks whether a function defi... | Eli Friedman |
2011-10-17 | Use a SmallVector for intrinsic argument types. | Benjamin Kramer |
2011-10-17 | Correct over-zealous removal of hack. | Bill Wendling |
2011-10-17 | Now that we have the ReturnsTwice function attribute, this method is | Bill Wendling |
2011-10-14 | constify array itself, don't iterate multiple times. | Chris Lattner |
2011-10-05 | Check for the returns_twice attribute in callsFunctionThatReturnsTwice. This | Rafael Espindola |
2011-07-18 | land David Blaikie's patch to de-constify Type, with a few tweaks. | Chris Lattner |
2011-07-14 | Change Intrinsic::getDeclaration and friends to take an ArrayRef. | Benjamin Kramer |
2011-07-12 | Second attempt at de-constifying LLVM Types in FunctionType::get(), | Jay Foad |
2011-07-12 | Revert r134893 and r134888 (and related patches in other trees). It was causing | Bill Wendling |
2011-07-11 | De-constify Types in FunctionType::get(). | Jay Foad |
2011-07-09 | Land the long talked about "type system rewrite" patch. This | Chris Lattner |
2011-06-17 | Fix typo in comment. | Jay Foad |
2011-05-22 | add a helper method to get the byval alignment of an argument. | Chris Lattner |
2011-05-16 | Don't do tail calls in a function that call setjmp. The stack might be | Rafael Espindola |
2011-04-26 | Another example of a static table that wasn't marked static. | Duncan Sands |
2011-04-25 | mark a large static table static. Pointed out by Michael Ilseman! | Chris Lattner |
2010-12-07 | Remove the code from Function::dropAllReferences which replaced | Dan Gohman |
2010-11-29 | Merge System into Support. | Michael J. Spencer |
2010-04-01 | Introduce ImmutableCallSite, useful for contexts where no mutation | Gabor Greif |
2010-03-25 | rename use_const_iterator to const_use_iterator for consistency's sake | Gabor Greif |
2010-03-24 | Finally land the InvokeInst operand reordering. | Gabor Greif |
2010-03-23 | add assert in argpromotion, which cannot trigger | Gabor Greif |
2010-02-16 | Introduce isOpaqueTy and use it rather than isa<OpaqueType>. Also, move some | Duncan Sands |