Age | Commit message (Expand) | Author |
2009-08-22 | Rename TargetAsmInfo (and its subclasses) to MCAsmInfo. | Chris Lattner |
2009-08-12 | Change TargetAsmInfo to be constructed via TargetRegistry from a Target+Triple | Chris Lattner |
2009-08-02 | move dwarf debug info section selection stuff from TAI to | Chris Lattner |
2009-08-02 | xcore TAI doesn't need TM. | Chris Lattner |
2009-08-02 | remove TargetAsmInfo::TM, which is now dead. The basic TAI class now | Chris Lattner |
2009-08-01 | Remove "JumpTableDataSection" from TAI, instead, have AsmPrinter | Chris Lattner |
2009-08-01 | REmove dead fields of TAI. | Chris Lattner |
2009-07-28 | Rip all of the global variable lowering logic out of TargetAsmInfo. Since | Chris Lattner |
2009-07-27 | Eliminate getNamed/getUnnamedSection, adding a new and unified getOrCreateSec... | Chris Lattner |
2009-07-27 | Eliminate SectionFlags, just embed a SectionKind into Section | Chris Lattner |
2009-07-25 | this is (unfortunately) several changes mixed together: | Chris Lattner |
2009-07-22 | remove SectionFlags::Small: it is only used on Xcore, and we'll find | Chris Lattner |
2009-07-22 | Thread local globals don't require special handling by the linker and so can | Richard Osborne |
2009-07-21 | remove the last bits of SectionFlagsForGlobal. There is some flag here that | Chris Lattner |
2009-07-21 | don't mask out the small flag and then reapply it later. | Chris Lattner |
2009-07-21 | if Xcore doesn't support TLS, it doesn't have to worry about thread local LLV... | Chris Lattner |
2009-07-21 | remove the Xcore implementation of SelectSectionForGlobal. While you have | Chris Lattner |
2009-07-21 | Remove the XCore custom implementation of MergeableConstSection, relying on | Chris Lattner |
2009-07-21 | Remove some overridden functions in XCoreTargetAsmInfo that are | Chris Lattner |
2009-06-19 | Move up dwarf writer initialization in common AsmPrinter class. | Devang Patel |
2009-06-18 | simplify macro debug info directive handling. | Chris Lattner |
2009-05-09 | Rename PaddedSize to AllocSize, in the hope that this | Duncan Sands |
2009-03-07 | Introduce new linkage types linkonce_odr, weak_odr, common_odr | Duncan Sands |
2009-01-12 | Rename getABITypeSize to getTypePaddedSize, as | Duncan Sands |
2008-11-07 | Add XCore backend. | Richard Osborne |