Age | Commit message (Expand) | Author |
2013-03-22 | Remove ABI-duplicated call instruction patterns. | Ulrich Weigand |
2012-03-31 | Fix dynamic linking on PPC64. | Hal Finkel |
2011-12-15 | Ensure that the nop that should follow a bl call in PPC64 ELF actually does | Hal Finkel |
2011-12-02 | remove unneeded FIXME comment | Hal Finkel |
2011-12-02 | update PPC 940 hazard rec. to function in postRA mode | Hal Finkel |
2011-10-17 | Add PPC 440 scheduler and some associated tests | Hal Finkel |
2011-06-28 | - Rename TargetInstrDesc, TargetOperandInfo to MCInstrDesc and MCOperandInfo and | Evan Cheng |
2011-06-03 | Fix wrong usages of CTR/MCTR where CTR8/MCTR8 was meant. | Roman Divacky |
2010-12-24 | Various bits of framework needed for precise machine-level selection | Andrew Trick |
2010-12-24 | whitespace | Andrew Trick |
2010-12-23 | flags -> glue for selectiondag | Chris Lattner |
2010-06-08 | Reapply r105521, this time appending "LLU" to 64 bit | Bruno Cardoso Lopes |
2010-06-05 | revert r105521, which is breaking the buildbots with stuff like this: | Chris Lattner |
2010-06-05 | Initial AVX support for some instructions. No patterns matched | Bruno Cardoso Lopes |
2010-02-27 | remove a bogus pattern, which had the same pattern as STDU | Chris Lattner |
2010-02-10 | Fix "the the" and similar typos. | Dan Gohman |
2009-08-23 | eliminate the last DOUTs from the targets. | Chris Lattner |
2009-07-14 | llvm_unreachable->llvm_unreachable(0), LLVM_UNREACHABLE->llvm_unreachable. | Torok Edwin |
2009-07-11 | assert(0) -> LLVM_UNREACHABLE. | Torok Edwin |
2009-07-03 | Refactor ABI code in the PowerPC backend. | Tilmann Scheller |
2009-01-16 | Initial hazard recognizer support in post-pass scheduling. This includes | Dan Gohman |
2009-01-15 | Generalize the HazardRecognizer interface so that it can be used | Dan Gohman |
2008-12-03 | Add a sanity-check to tablegen to catch the case where isSimpleLoad | Dan Gohman |
2008-09-12 | Rename ConstantSDNode::getValue to getZExtValue, for consistency | Dan Gohman |
2008-07-27 | Rename SDOperand to SDValue. | Dan Gohman |
2008-07-17 | Add a new function, ReplaceAllUsesOfValuesWith, which handles bulk | Dan Gohman |
2008-01-07 | rename TargetInstrDescriptor -> TargetInstrDesc. | Chris Lattner |
2008-01-07 | use predicate. | Chris Lattner |
2008-01-06 | rename isLoad -> isSimpleLoad due to evan's desire to have such a predicate. | Chris Lattner |
2008-01-06 | rename isStore -> mayStore to more accurately reflect what it captures. | Chris Lattner |
2007-12-29 | Remove attribution from file headers, per discussion on llvmdev. | Chris Lattner |
2007-09-05 | LVXL and STVXL are also a load and store resp. | Bill Wendling |
2007-07-13 | Skeleton of post-RA scheduler; doesn't do anything yet. | Dale Johannesen |
2007-02-27 | Fix parenthesis for BCTRL_{ELF|Macho} test. | Nicolas Geoffray |
2007-02-25 | implement support for the linux/ppc function call ABI. Patch by | Chris Lattner |
2006-12-07 | What should be the last unnecessary <iostream>s in the library. | Bill Wendling |
2006-11-16 | add ppc64 r+i stores with update. | Chris Lattner |
2006-11-15 | Switch loads over to use memri as the operand instead of a reg/imm operand | Chris Lattner |
2006-11-13 | teach the g5 hazard recognizer about update loads. This fixes | Chris Lattner |
2006-07-14 | Add missing PPC64 extload/truncstores | Chris Lattner |
2006-07-10 | Implement Regression/CodeGen/PowerPC/bswap-load-store.ll by folding bswaps | Chris Lattner |
2006-03-22 | When possible, custom lower 32-bit SINT_TO_FP to this: | Chris Lattner |
2006-03-13 | Fix a couple of bugs that broke the alpha tester build | Chris Lattner |
2006-03-13 | Handle cracked instructions in dispatch group formation. | Chris Lattner |
2006-03-12 | Several big changes: | Chris Lattner |
2006-03-11 | blr is a branch too | Chris Lattner |
2006-03-08 | Change the interface for getting a target HazardRecognizer to be more clean. | Chris Lattner |
2006-03-07 | add another missing store. | Chris Lattner |
2006-03-07 | add a couple more load/store instrs, add a newline to the end of file. | Chris Lattner |
2006-03-07 | This kinda sorta implements "things that have to lead a dispatch group". | Nate Begeman |