Age | Commit message (Expand) | Author |
2013-04-01 | Add support for vector data types in the LLVM interpreter. | Nadav Rotem |
2013-02-01 | Fix misplaced 'break'. | Jim Grosbach |
2013-01-31 | interpreter: Fix errant fallthrough. | Jim Grosbach |
2013-01-02 | Move all of the header files which are involved in modelling the LLVM IR | Chandler Carruth |
2012-12-03 | Use the new script to sort the includes of every file under lib. | Chandler Carruth |
2012-11-01 | Revert the majority of the next patch in the address space series: | Chandler Carruth |
2012-10-15 | Resubmit the changes to llvm core to update the functions to support differen... | Micah Villmow |
2012-10-11 | Revert 165732 for further review. | Micah Villmow |
2012-10-11 | Add in the first iteration of support for llvm/clang/lldb to allow variable p... | Micah Villmow |
2012-06-23 | Optimized usage of new SwitchInst case values (IntegersSubset type) in Local.... | Stepan Dyatkovskiy |
2012-06-02 | PR1255: case ranges. | Stepan Dyatkovskiy |
2012-06-01 | PR1255: case ranges. | Stepan Dyatkovskiy |
2012-05-29 | ConstantRangesSet renamed to IntegersSubset. CRSBuilder renamed to IntegersSu... | Stepan Dyatkovskiy |
2012-05-28 | PR1255: Case Ranges | Stepan Dyatkovskiy |
2012-05-21 | PR1255 (case ranges: work with ConstantRangesSet instead of ConstantInt) rela... | Stepan Dyatkovskiy |
2012-03-11 | llvm::SwitchInst | Stepan Dyatkovskiy |
2012-03-08 | Taken into account Duncan's comments for r149481 dated by 2nd Feb 2012: | Stepan Dyatkovskiy |
2012-02-19 | Remove dead code. Improve llvm_unreachable text. Simplify some control flow. | Ahmed Charles |
2012-02-06 | [unwind removal] We no longer have 'unwind' instructions being generated, so | Bill Wendling |
2012-02-01 | SwitchInst refactoring. | Stepan Dyatkovskiy |
2012-01-20 | More dead code removal (using -Wunreachable-code) | David Blaikie |
2011-09-29 | Clean up uses of switch instructions so they are not dependent on the operand... | Eli Friedman |
2011-07-18 | land David Blaikie's patch to de-constify Type, with a few tweaks. | Chris Lattner |
2010-11-28 | PR5207: change APInt::doubleToBits() and APInt::floatToBits() to be | Jay Foad |
2010-06-18 | Handle execution entrypoints with non-integer return types. | Dan Gohman |
2010-04-07 | rename llvm::llvm_report_error -> llvm::report_fatal_error | Chris Lattner |
2010-02-16 | There are two ways of checking for a given type, for example isa<PointerType>(T) | Duncan Sands |
2010-02-15 | Uniformize the names of type predicates: rather than having isFloatTy and | Duncan Sands |
2010-01-05 | Avoid going through the LLVMContext for type equality where it's safe to dere... | Benjamin Kramer |
2010-01-05 | Change errs() to dbgs(). | David Greene |
2009-11-08 | Fix the interpreter to not crash due to zeroext/signext | Nick Lewycky |
2009-10-29 | add interpreter support for indirect goto / blockaddress. The interpreter | Chris Lattner |
2009-10-26 | Remove FreeInst. | Victor Hernandez |
2009-10-23 | Remove AllocationInst. Since MallocInst went away, AllocaInst is the only su... | Victor Hernandez |
2009-10-05 | strength reduce a ton of type equality tests to check the typeid (Through | Chris Lattner |
2009-08-23 | remove the std::ostream version of module and type printing. | Chris Lattner |
2009-08-23 | eliminate the "Value" printing methods that print to a std::ostream. | Chris Lattner |
2009-08-13 | Push LLVMContexts through the IntegerType APIs. | Owen Anderson |
2009-08-03 | llvm_report_error already prints "LLVM ERROR:". So stop reporting errors like... | Benjamin Kramer |
2009-07-14 | llvm_unreachable->llvm_unreachable(0), LLVM_UNREACHABLE->llvm_unreachable. | Torok Edwin |
2009-07-11 | assert(0) -> LLVM_UNREACHABLE. | Torok Edwin |
2009-07-11 | Convert more assert(0)+abort() -> LLVM_UNREACHABLE, | Torok Edwin |
2009-07-09 | remove dead function. | Chris Lattner |
2009-06-26 | Get rid of unnecessary global variables. | Owen Anderson |
2009-06-04 | Split the Add, Sub, and Mul instruction opcodes into separate | Dan Gohman |
2009-05-09 | Rename PaddedSize to AllocSize, in the hope that this | Duncan Sands |
2009-04-01 | Use CHAR_BIT instead of hard-coding 8 in several places where it | Dan Gohman |
2009-01-16 | don't assert and die on out of range (undefined) shifts. This fixes | Chris Lattner |
2009-01-12 | Rename getABITypeSize to getTypePaddedSize, as | Duncan Sands |
2008-09-25 | Large mechanical patch. | Devang Patel |