aboutsummaryrefslogtreecommitdiff
path: root/lib/Target/MSP430/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Target/MSP430/CMakeLists.txt')
-rw-r--r--lib/Target/MSP430/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/lib/Target/MSP430/CMakeLists.txt b/lib/Target/MSP430/CMakeLists.txt
index 3b6cf89d1f..3840b03b97 100644
--- a/lib/Target/MSP430/CMakeLists.txt
+++ b/lib/Target/MSP430/CMakeLists.txt
@@ -22,6 +22,19 @@ add_llvm_target(MSP430CodeGen
MSP430MCInstLower.cpp
)
+add_llvm_library_dependencies(LLVMMSP430CodeGen
+ LLVMAsmPrinter
+ LLVMCodeGen
+ LLVMCore
+ LLVMMC
+ LLVMMSP430AsmPrinter
+ LLVMMSP430Desc
+ LLVMMSP430Info
+ LLVMSelectionDAG
+ LLVMSupport
+ LLVMTarget
+ )
+
add_subdirectory(InstPrinter)
add_subdirectory(TargetInfo)
add_subdirectory(MCTargetDesc)