aboutsummaryrefslogtreecommitdiff
path: root/lib/Analysis/CMakeLists.txt
diff options
context:
space:
mode:
authorDevang Patel <dpatel@apple.com>2010-11-04 15:01:38 +0000
committerDevang Patel <dpatel@apple.com>2010-11-04 15:01:38 +0000
commit35fcd6557f53aab69c2990b80fed4653fbaa3473 (patch)
tree9ff71fdf207bbbeb36a2d18431121baf17852a85 /lib/Analysis/CMakeLists.txt
parentab70ed41f344c04dabaf180c40f04827bc9c56b5 (diff)
Introduce DIBuilder. It is intended to be a front-end friendly interface to emit debuggging information entries in LLVM IR.
To create debugging information for a pointer, using DIBUilder front-end just needs DBuilder.CreatePointerType(Ty, Size); instead of DebugFactory.CreateDerivedType(llvm::dwarf::DW_TAG_pointer_type, TheCU, "", getOrCreateMainFile(), 0, Size, 0, 0, 0, OCTy); git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@118248 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Analysis/CMakeLists.txt')
-rw-r--r--lib/Analysis/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Analysis/CMakeLists.txt b/lib/Analysis/CMakeLists.txt
index d69ab59907..0c595827bd 100644
--- a/lib/Analysis/CMakeLists.txt
+++ b/lib/Analysis/CMakeLists.txt
@@ -11,6 +11,7 @@ add_llvm_library(LLVMAnalysis
ConstantFolding.cpp
DbgInfoPrinter.cpp
DebugInfo.cpp
+ DIBuilder.cpp
DomPrinter.cpp
IVUsers.cpp
InlineCost.cpp