Age | Commit message (Expand) | Author |
2010-03-19 | driver-core: document ERR_PTR() return values | Jani Nikula |
2010-03-07 | Driver core: Constify struct sysfs_ops in struct kobj_type | Emese Revfy |
2010-03-07 | driver core: Add class_attr_string for simple read-only string | Andi Kleen |
2010-03-07 | driver-core: Add attribute argument to class_attribute show/store | Andi Kleen |
2010-02-16 | class: Free the class private data in class_release | Laurent Pinchart |
2009-09-15 | Driver core: Add support for compatibility classes | Jean Delvare |
2008-10-09 | driver-core: use klist for class device list and implement iterator | Tejun Heo |
2008-08-21 | driver model: anti-oopsing medicine | David Brownell |
2008-07-28 | locking: fix mutex @key parameter kernel-doc notation | Randy Dunlap |
2008-07-21 | class: change internal semaphore to a mutex | Dave Young |
2008-07-21 | class: add lockdep infrastructure | Matthew Wilcox |
2008-07-21 | class: rename "sem" to "class_sem" in internal class structure | Greg Kroah-Hartman |
2008-07-21 | class: rename "subsys" to "class_subsys" in internal class structure | Greg Kroah-Hartman |
2008-07-21 | class: rename "interfaces" to "class_interfaces" in internal class structure | Greg Kroah-Hartman |
2008-07-21 | class: rename "devices" to "class_devices" in internal class structure | Greg Kroah-Hartman |
2008-07-21 | class: move driver core specific parts to a private structure | Greg Kroah-Hartman |
2008-07-21 | Driver Core: add ability for class_find_device to start in middle of list | Greg Kroah-Hartman |
2008-07-21 | Driver Core: add ability for class_for_each_device to start in middle of list | Greg Kroah-Hartman |
2008-07-21 | sysfs: add /sys/dev/{char,block} to lookup sysfs path by major:minor | Dan Williams |
2008-05-14 | Driver core: struct class remove children list | Dave Young |
2008-04-30 | driver core: remove no longer used "struct class_device" | Kay Sievers |
2008-04-19 | driver core: replace remaining __FUNCTION__ occurrences | Harvey Harrison |
2008-01-31 | Merge git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-2.6 | Linus Torvalds |
2008-01-31 | docbook: fix drivers/base/class warning | Randy Dunlap |
2008-01-27 | Driver core: Fix up build when CONFIG_BLOCK=N | Greg Kroah-Hartman |
2008-01-24 | Driver core: coding style fixes | Greg Kroah-Hartman |
2008-01-24 | Driver Core: add class iteration api | Dave Young |
2008-01-24 | Driver core: change sysdev classes to use dynamic kobject names | Kay Sievers |
2008-01-24 | Kobject: rename kobject_init_ng() to kobject_init() | Greg Kroah-Hartman |
2008-01-24 | Kobject: rename kobject_add_ng() to kobject_add() | Greg Kroah-Hartman |
2008-01-24 | Driver core: convert block from raw kobjects to core devices | Kay Sievers |
2008-01-24 | Kobject: convert drivers/base/class.c to use kobject_init/add_ng() | Greg Kroah-Hartman |
2008-01-24 | kobject: remove subsystem_(un)register functions | Greg Kroah-Hartman |
2008-01-24 | kset: remove decl_subsys macro | Greg Kroah-Hartman |
2008-01-24 | kset: convert drivers/base/class.c to use kset_create | Greg Kroah-Hartman |
2008-01-24 | kobject: remove struct kobj_type from struct kset | Greg Kroah-Hartman |
2007-10-31 | Revert "Driver core: remove class_device_*_bin_file" | Greg Kroah-Hartman |
2007-10-30 | Driver core: remove class_device_*_bin_file | Greg Kroah-Hartman |
2007-10-12 | Driver core: rename ktype_class | Greg Kroah-Hartman |
2007-10-12 | driver core: remove subsystem_init() | Greg Kroah-Hartman |
2007-10-12 | Driver core: remove subsys_get() | Greg Kroah-Hartman |
2007-10-12 | Driver core: remove subsys_put() | Greg Kroah-Hartman |
2007-10-12 | Driver core: remove subsys_set_kset | Greg Kroah-Hartman |
2007-10-12 | Driver core: change add_uevent_var to use a struct | Kay Sievers |
2007-07-11 | driver-core: make devt_attr and uevent_attr static | Tejun Heo |
2007-07-11 | sysfs: kill unnecessary attribute->owner | Tejun Heo |
2007-06-08 | Driver core: keep PHYSDEV for old struct class_device | Kay Sievers |
2007-05-02 | remove "struct subsystem" as it is no longer needed | Greg Kroah-Hartman |
2007-04-27 | driver core: fix namespace issue with devices assigned to classes | Kay Sievers |
2007-02-23 | Driver core: remove class_device_rename | Greg Kroah-Hartman |