aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorAlejandro G. Castro <alex@igalia.com>2008-10-30 17:58:43 +0000
committerAlejandro G. Castro <alex@igalia.com>2008-10-30 17:58:43 +0000
commit948e84b7676632fef43ca8f9c2ceffd23b1eddbf (patch)
tree9b85b0409039a123ed385db7654796544141c95d /tests/Makefile.am
parentf926ff03766424b582cf7edf1704dac02b2b53e0 (diff)
Added a new EXTRA_CFLAGS option to add the deprecated define to the compilation command. This way we can avoid using the define in the documentation compilation.
* configure.ac: Defined EXTRA_CFLAGS. * examples/Makefile.am: * src/Makefile.am: * tests/Makefile.am: Included EXTRA_CFLAGS in the compilation.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4ae618b..eff6759 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -42,6 +42,7 @@ endif
check_test_LDADD = $(HILDON_OBJ_LIBS)
check_test_LDFLAGS = -module -avoid-version
-check_test_CFLAGS = $(HILDON_OBJ_CFLAGS)
+check_test_CFLAGS = $(HILDON_OBJ_CFLAGS) \
+ $(EXTRA_CFLAGS)
endif