aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMichael Dominic Kostrzewa <michael.kostrzewa@nokia.com>2007-01-15 16:11:13 +0000
committerMichael Dominic Kostrzewa <michael.kostrzewa@nokia.com>2007-01-15 16:11:13 +0000
commit62535c95d73315a590193c5104709a7430e5fbbc (patch)
tree3152910adbe1a735cf8d22df8f41c942b23eccf4 /tests/Makefile.am
parente2430cc62f074506300f36f711548b25294ca146 (diff)
Adding the test suite.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..e305577
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,35 @@
+if BUILD_TESTS
+
+noinst_PROGRAMS = check_test
+
+check_test_SOURCES = check_test.c \
+ check_utils.c \
+ check-hildon-range-editor.c \
+ check-hildon-date-editor.c \
+ check-hildon-time-editor.c \
+ check-hildon-weekday-picker.c \
+ check-hildon-controlbar.c \
+ check-hildon-seekbar.c \
+ check-hildon-time-picker.c \
+ check-hildon-number-editor.c \
+ check-hildon-calendar-popup.c \
+ check-hildon-caption.c \
+ check-hildon-defines.c \
+ check-hildon-code-dialog.c \
+ check-hildon-find-toolbar.c \
+ check-hildon-sort-dialog.c \
+ check-hildon-note.c \
+ check-hildon-volumebar.c \
+ check-hildon-volumebar-range.c \
+ check-hildon-banner.c \
+ check-hildon-wizard-dialog.c \
+ check-hildon-font-selection-dialog.c \
+ check-hildon-window.c \
+ check-hildon-program.c \
+ check-hildon-composite-widget.c
+
+check_test_LDADD = $(HILDON_WIDGETS_OBJ_LIBS)
+check_test_LDFLAGS = -module -avoid-version
+check_test_CFLAGS = $(HILDON_WIDGETS_OBJ_CFLAGS)
+
+endif