aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTomasz Sterna <tomek@xiaoka.com>2012-01-04 22:27:18 +0100
committerTomasz Sterna <tomek@xiaoka.com>2012-01-24 00:36:01 +0100
commitdf3f3c11dfadc3d0d191f8a642b407d29fca2084 (patch)
tree7d30bd02ff5d6b9aa8e3e15fd8f8f6c874f68197 /configure.ac
parent1548555bd7050e000b062e2160838552ea843b63 (diff)
Removed deprecated widgets and methods
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 2 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index ff5066e..116d6b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -163,18 +163,6 @@ else
FATAL_CFLAGS=""
fi
-# disable deprecated symbols
-AC_ARG_ENABLE(deprecated,
- [AC_HELP_STRING([--enable-deprecated],
- [enable use of deprecated symbols [default=yes]])],,
- [enable_deprecated="yes"])
-
-if test x$enable_deprecated = xno; then
- DISABLE_DEPRECATED="-DHILDON_DISABLE_DEPRECATED"
-fi
-
-AM_CONDITIONAL([HILDON_DISABLE_DEPRECATED], test "x$enable_deprecated" = "xno")
-
# Check support (c unit test)
PKG_CHECK_MODULES(CHECK, check , [BUILD_TESTS="yes"], [BUILD_TESTS="no"])
AM_CONDITIONAL(BUILD_TESTS, test "x$BUILD_TESTS" = "xyes")
@@ -182,8 +170,8 @@ AM_CONDITIONAL(BUILD_TESTS, test "x$BUILD_TESTS" = "xyes")
CFLAGS="$CFLAGS ${ASSERT_CFLAGS} ${DEBUG_CFLAGS} -Wall -Wmissing-prototypes -Wmissing-declarations -Wno-format ${FATAL_CFLAGS}"
# -Wno-format due to way translation string are done
-### disable deprecated symbols and enable MAEMO platform extensions
-EXTRA_CFLAGS="$DISABLE_DEPRECATED $MAEMO_CHANGES $MAEMO_GTK"
+### enable MAEMO platform extensions
+EXTRA_CFLAGS="$MAEMO_CHANGES $MAEMO_GTK"
AC_SUBST(EXTRA_CFLAGS)
# HILDON_OBJ_*
@@ -217,7 +205,6 @@ Configuration:
- Version............: ${VERSION}
- Api................: ${PACKAGE}-${API_VERSION_MAJOR}
- Compiler...........: ${CC}
-- Enable deprecated..: ${enable_deprecated}
- gtk-doc support....: ${enable_gtk_doc}
- Build examples.....: ${BUILD_EXAMPLES}
- Build with asserts.: ${BUILD_WITH_ASSERTS}