aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2013-05-22 10:29:15 +0000
committerFlorian Dold <florian.dold@gmail.com>2013-05-22 10:29:15 +0000
commit4289fca5aeefd0652ae60bc16f90ed911c7e1c60 (patch)
treeda266c48ada44f11ce88a38833960b0eb08c1c5d /src/set/Makefile.am
parent3418f171c455980c99ac6363a74116243bddede6 (diff)
- moved MQ to util
- MQ support for stream - set api - starting to use set for consensus
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am34
1 files changed, 2 insertions, 32 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
index a609840b15..13278b05c2 100644
--- a/src/set/Makefile.am
+++ b/src/set/Makefile.am
@@ -16,7 +16,7 @@ if USE_COVERAGE
endif
bin_PROGRAMS = \
- gnunet-set gnunet-set-bug
+ gnunet-set
libexec_PROGRAMS = \
gnunet-service-set
@@ -35,17 +35,9 @@ gnunet_set_LDADD = \
gnunet_set_DEPENDENCIES = \
libgnunetset.la
-gnunet_set_bug_SOURCES = \
- gnunet-set-bug.c
-gnunet_set_bug_LDADD = \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/stream/libgnunetstream.la \
- $(GN_LIBINTL)
-
gnunet_service_set_SOURCES = \
gnunet-service-set.c \
gnunet-service-set_union.c \
- mq.c \
ibf.c \
strata_estimator.c
gnunet_service_set_LDADD = \
@@ -54,13 +46,9 @@ gnunet_service_set_LDADD = \
$(top_builddir)/src/stream/libgnunetstream.la \
$(top_builddir)/src/mesh/libgnunetmesh.la \
$(GN_LIBINTL)
-# hack for mq.c, see automake Objects ‘created with both libtool and without’
-# remove once GNUNET_MQ is in util/
-gnunet_service_set_CFLAGS = $(AM_CFLAGS)
libgnunetset_la_SOURCES = \
- set_api.c \
- mq.c
+ set_api.c
libgnunetset_la_LIBADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/stream/libgnunetstream.la \
@@ -84,24 +72,6 @@ test_set_api_LDADD = \
test_set_api_DEPENDENCIES = \
libgnunetset.la
-
-test_mq_SOURCES = \
- test_mq.c \
- mq.c
-test_mq_LDADD = \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/stream/libgnunetstream.la
-test_mq_CFLAGS = $(AM_CFLAGS)
-
-
-test_mq_client_SOURCES = \
- test_mq_client.c \
- mq.c
-test_mq_client_LDADD = \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/stream/libgnunetstream.la
-test_mq_client_CFLAGS = $(AM_CFLAGS)
-
EXTRA_DIST = \
test_set.conf