aboutsummaryrefslogtreecommitdiff
path: root/src/peerinfo/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2013-04-10 07:25:24 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2013-04-10 07:25:24 +0000
commit54ed2dc773c3f009f6861af2317f26b031e9d2a3 (patch)
tree13c7a20bc151f2093299721ca98fc51176de4d8c /src/peerinfo/Makefile.am
parentd65fc468de7a61f016e476cfe3fc471901f32e8a (diff)
testing hellos shipped
Diffstat (limited to 'src/peerinfo/Makefile.am')
-rw-r--r--src/peerinfo/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/peerinfo/Makefile.am b/src/peerinfo/Makefile.am
index 89ce66a26f..c3863ab653 100644
--- a/src/peerinfo/Makefile.am
+++ b/src/peerinfo/Makefile.am
@@ -47,6 +47,7 @@ if HAVE_BENCHMARKS
endif
check_PROGRAMS = \
+ test_peerinfo_shipped_hellos \
test_peerinfo_api \
test_peerinfo_api_friend_only \
test_peerinfo_api_notify_friend_only \
@@ -56,6 +57,14 @@ if ENABLE_TEST_RUN
TESTS = $(check_PROGRAMS)
endif
+test_peerinfo_shipped_hellos_SOURCES = \
+ test_peerinfo_shipped_hellos.c
+test_peerinfo_shipped_hellos_LDADD = \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
test_peerinfo_api_SOURCES = \
test_peerinfo_api.c
test_peerinfo_api_LDADD = \