aboutsummaryrefslogtreecommitdiff
path: root/src/consensus/Makefile.am
diff options
context:
space:
mode:
authorgrothoff <grothoff@140774ce-b5e7-0310-ab8b-a85725594a96>2012-11-08 13:03:19 +0000
committergrothoff <grothoff@140774ce-b5e7-0310-ab8b-a85725594a96>2012-11-08 13:03:19 +0000
commiteac3ae094edf3de8499d0a1c7d9909d9ebbf9c63 (patch)
treeb9a8fee10db372b14a9f9153b60c54a414d264b7 /src/consensus/Makefile.am
parent5e4b952dab215a314ee627a0ef27dc1a317e361a (diff)
-starting build system for consensus
git-svn-id: https://gnunet.org/svn/gnunet@24838 140774ce-b5e7-0310-ab8b-a85725594a96
Diffstat (limited to 'src/consensus/Makefile.am')
-rw-r--r--src/consensus/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/src/consensus/Makefile.am b/src/consensus/Makefile.am
new file mode 100644
index 0000000000..2041ec1acd
--- /dev/null
+++ b/src/consensus/Makefile.am
@@ -0,0 +1,48 @@
+INCLUDES = -I$(top_srcdir)/src/include
+
+pkgcfgdir= $(pkgdatadir)/config.d/
+
+libexecdir= $(pkglibdir)/libexec/
+
+pkgcfg_DATA = \
+ consensus.conf
+
+if MINGW
+ WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
+endif
+
+if USE_COVERAGE
+ AM_CFLAGS = -fprofile-arcs -ftest-coverage
+endif
+
+#bin_PROGRAMS = \
+# gnunet-consensus
+
+libexec_PROGRAMS = \
+ gnunet-service-consensus
+
+#gnunet_consensus_SOURCES = \
+# gnunet-consensus.c
+#gnunet_consensus_LDADD = \
+# $(top_builddir)/src/util/libgnunetutil.la \
+# $(GN_LIBINTL)
+
+gnunet_service_consensus_SOURCES = \
+ gnunet-service-consensus.cc
+gnunet_service_consensus_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(GN_LIBINTL)
+
+
+#check_PROGRAMS = \
+# test_consensus_api
+
+#if ENABLE_TEST_RUN
+#TESTS = $(check_PROGRAMS)
+#endif
+#
+#test_consensus_api_SOURCES = \
+# test_consensus_api.c
+#test_consensus_api_LDADD = \
+# $(top_builddir)/src/util/libgnunetutil.la
+