aboutsummaryrefslogtreecommitdiff
path: root/src/arm/Makefile.am
diff options
context:
space:
mode:
authorgrothoff <grothoff@140774ce-b5e7-0310-ab8b-a85725594a96>2009-05-29 00:46:26 +0000
committergrothoff <grothoff@140774ce-b5e7-0310-ab8b-a85725594a96>2009-05-29 00:46:26 +0000
commit6ba89ee6eee308c69d69b6bbebcf2cc67a76ce01 (patch)
tree6b552f40eb089db96409a312a98d9b12bd669102 /src/arm/Makefile.am
ng
git-svn-id: https://gnunet.org/svn/gnunet@8472 140774ce-b5e7-0310-ab8b-a85725594a96
Diffstat (limited to 'src/arm/Makefile.am')
-rw-r--r--src/arm/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/src/arm/Makefile.am b/src/arm/Makefile.am
new file mode 100644
index 0000000000..65fa145ee7
--- /dev/null
+++ b/src/arm/Makefile.am
@@ -0,0 +1,58 @@
+INCLUDES = -I$(top_srcdir)/src/include
+
+if MINGW
+ WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
+endif
+
+if USE_COVERAGE
+ AM_CFLAGS = -fprofile-arcs -ftest-coverage
+endif
+
+lib_LTLIBRARIES = libgnunetarm.la
+
+libgnunetarm_la_SOURCES = \
+ arm_api.c arm.h
+libgnunetarm_la_LIBADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(GN_LIBINTL)
+libgnunetarm_la_LDFLAGS = \
+ $(GN_LIB_LDFLAGS) $(WINFLAGS) \
+ -version-info 0:0:0
+
+
+bin_PROGRAMS = \
+ gnunet-arm \
+ gnunet-service-arm
+
+gnunet_arm_SOURCES = \
+ gnunet-arm.c
+gnunet_arm_LDADD = \
+ $(top_builddir)/src/arm/libgnunetarm.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(GN_LIBINTL)
+
+gnunet_service_arm_SOURCES = \
+ gnunet-service-arm.c
+gnunet_service_arm_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(GN_LIBINTL)
+
+
+check_PROGRAMS = \
+ test_arm_api
+
+check_SCRIPTS = \
+ test_gnunet_arm.sh
+
+TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
+
+test_arm_api_SOURCES = \
+ test_arm_api.c
+test_arm_api_LDADD = \
+ $(top_builddir)/src/arm/libgnunetarm.la \
+ $(top_builddir)/src/resolver/libgnunetresolver.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+
+EXTRA_DIST = \
+ test_arm_api_data.conf