aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
authorNils Gillmann <ng0@n0.is>2018-05-19 14:43:13 +0000
committerNils Gillmann <ng0@n0.is>2018-05-19 14:43:13 +0000
commit6ab60d4920bb3199aee8cd872b930e9e3e808ba7 (patch)
tree3d761dbf8793a1d2422fbd14667255c7e0292ea4 /contrib/Makefile.am
parentc2f27dfe8218545c327ab49d225a49910347c5c6 (diff)
Restructure contrib folder.
contrib/pogen.sh -> bin/pogen.sh bootstrap: Use new pogen location and execute it. contrib/openvpn-tap32: Move to contrib/3rdparty/Windows/openvpn-tap32. contrib/gnunet-logo*: Move to contrib/branding/logo/ Delete old patches in contrib, predating git. Move buildbot data to contrib/ci/buildbot, move docker data to contrib/ci/docker. Create contrib/conf and populate it with config files found in contrib and bin. Move gns related data to contrib/gns. delete contrib/repeat.sh Move contrib/log.php into contrib/web/log.php. Create folder contrib/scripts and use it for most scripts in contrib. Remove trailing whitespace in doc/Makefile.am Signed-off-by: Nils Gillmann <ng0@n0.is>
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am92
1 files changed, 46 insertions, 46 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 40e6d3e92b..8e07a5d8c2 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -17,54 +17,62 @@ timeout_watchdog_SOURCES = \
endif
noinst_SCRIPTS = \
- terminate.py \
- pydiffer.py \
- removetrailingwhitespace.py \
- gnunet_pyexpect.py \
- gnunet_janitor.py \
- gnunet-chk.py
+ scripts/terminate.py \
+ scripts/pydiffer.py \
+ scripts/removetrailingwhitespace.py \
+ scripts/gnunet_pyexpect.py \
+ scripts/gnunet_janitor.py \
+ scripts/gnunet-chk.py
dist_pkgdata_DATA = \
- gns-bcd.html \
- gns-bcd.tex \
- gnunet-logo.pdf \
- gnunet-logo-color.png \
+ gns/gns-bcd.html \
+ gns/gns-bcd.tex \
+ gns/def.tex \
+ gns/gns-form-fields.xml \
+ gns/gns-form.xslt \
+ branding/logo/gnunet-logo.pdf \
+ branding/logo/gnunet-logo-color.png \
+ scripts/report.sh \
testing_hostkeys.ecc
if MINGW
tap32_DATA = \
- openvpn-tap32/tapw32/tap0901.sys \
- openvpn-tap32/tapw32/tap0901.cat \
- openvpn-tap32/tapw32/OemWin2k.inf
+ 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.sys \
+ 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.cat \
+ 3rdparty/Windows/openvpn-tap32/tapw32/OemWin2k.inf
tap64_DATA = \
- openvpn-tap32/tapw64/tap0901.sys \
- openvpn-tap32/tapw64/tap0901.cat \
- openvpn-tap32/tapw64/OemWin2k.inf
+ 3rdparty/Windows/openvpn-tap32/tapw64/tap0901.sys \
+ 3rdparty/Windows/openvpn-tap32/tapw64/tap0901.cat \
+ 3rdparty/Windows/openvpn-tap32/tapw64/OemWin2k.inf
endif
EXTRA_DIST = \
- no_forcestart.conf \
- no_autostart_above_core.conf \
- coverage.sh \
- nssswitch.conf \
- report.sh \
- terminate.py.in \
- gnunet_pyexpect.py.in \
- gnunet_janitor.py.in \
- gnunet-chk.py.in \
- removetrailingwhitespace.py.in \
- pydiffer.py.in \
- gnunet-gns-import.sh \
- openvpn-tap32/tapw32/tap0901.sys \
- openvpn-tap32/tapw32/tap0901.cat \
- openvpn-tap32/tapw32/OemWin2k.inf \
- openvpn-tap32/tapw64/tap0901.sys \
- openvpn-tap32/tapw64/tap0901.cat \
- openvpn-tap32/tapw64/OemWin2k.inf \
- openvpn-tap32/INSTALL \
- openvpn-tap32/tap32-signed-i386-2.1.zip \
- openvpn-tap32/tap32-source-2.1.zip
+ conf/colorit/colorit.conf \
+ conf/editors/eclipse/gnunet_codingstyle.xml \
+ conf/gnunet/no_forcestart.conf \
+ conf/gnunet/no_autostart_above_core.conf \
+ conf/nss/nssswitch.conf \
+ conf/wireshark/wireshark.lua \
+ scripts/coverage.sh \
+ scripts/terminate.py.in \
+ scripts/gnunet_pyexpect.py.in \
+ scripts/gnunet_janitor.py.in \
+ scripts/gnunet-chk.py.in \
+ scripts/removetrailingwhitespace.py.in \
+ scripts/pydiffer.py.in \
+ scripts/gnunet-gns-import.sh \
+ packages/nix/default.nix \
+ packages/nix/gnunet-dex.nix \
+ 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.sys \
+ 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.cat \
+ 3rdparty/Windows/openvpn-tap32/tapw32/OemWin2k.inf \
+ 3rdparty/Windows/openvpn-tap32/tapw64/tap0901.sys \
+ 3rdparty/Windows/openvpn-tap32/tapw64/tap0901.cat \
+ 3rdparty/Windows/openvpn-tap32/tapw64/OemWin2k.inf \
+ 3rdparty/Windows/openvpn-tap32/INSTALL \
+ 3rdparty/Windows/openvpn-tap32/tap32-signed-i386-2.1.zip \
+ 3rdparty/Windows/openvpn-tap32/tap32-source-2.1.zip
CLEANFILES = \
$(noinst_SCRIPTS)
@@ -82,21 +90,13 @@ do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
#
# instead of this:
+SUFFIXES =
SUFFIXES = .py.in .py
.py.in.py:
$(do_subst) < $< > $@
chmod +x $@
-# init_gnunet_redhat \
-# init_gnunet_ubuntu \
-# visualize_stats.sh \
-# gnmessage.sh \
-# junkinsert.sh \
-# junklookup.sh \
-# namespacehelper.sh
-
-
check_PROGRAMS = \
test_gnunet_prefix