aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-05-30 18:35:02 +0000
committerChristian Grothoff <christian@grothoff.org>2015-05-30 18:35:02 +0000
commit93fba12ad8159dc6b683f9e7ce9f0528a11047f5 (patch)
tree73b1bd212c6c5a32adb924d208d8a315b606e854 /configure.ac
parentcfd880578bd21f9adedba557291c903d325e93cd (diff)
make libextractor actually optional, both for GNUnet and GNUnet-taler builds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 15 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 039652b78b..ebbb694652 100644
--- a/configure.ac
+++ b/configure.ac
@@ -557,11 +557,6 @@ AC_ARG_ENABLE([taler-wallet],
AC_MSG_RESULT($taler_only)
AM_CONDITIONAL([TALER_ONLY], [test "x$taler_only" = "xyes"])
-if test "$taler_only" != yes
-then
-
-
-
# test for libextractor
extractor=0
AC_MSG_CHECKING(for libextractor)
@@ -590,14 +585,22 @@ AC_ARG_WITH(extractor,
AC_CHECK_HEADERS(extractor.h,
AC_CHECK_LIB([extractor], [EXTRACTOR_plugin_add_defaults],
extractor=1))])
+# restore LIBS
+LIBS=$SAVE_LIBS
+
if test "$extractor" != 1
then
- AC_MSG_ERROR([GNUnet requires libextractor])
+ AM_CONDITIONAL(HAVE_LIBEXTRACTOR, false)
+ AC_DEFINE([HAVE_LIBEXTRACTOR],[0],[Lacking libextractor])
+else
+ AM_CONDITIONAL(HAVE_LIBEXTRACTOR, true)
+ AC_DEFINE([HAVE_LIBEXTRACTOR],[1],[Have libextractor])
fi
-# restore LIBS
-LIBS=$SAVE_LIBS
+if test "$taler_only" != yes
+then
+
# Check for libltdl header (#2999)
ltdl=0
AC_MSG_CHECKING(for libltdl)
@@ -1674,6 +1677,10 @@ then
fi
fi
+if test "$extractor" != 1
+then
+ AC_MSG_WARN([NOTICE: libextractor not found, but various file-sharing functions require it])
+fi
AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite, Postgres: $postgres])