aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorgrothoff <grothoff@140774ce-b5e7-0310-ab8b-a85725594a96>2012-05-31 18:42:31 +0000
committergrothoff <grothoff@140774ce-b5e7-0310-ab8b-a85725594a96>2012-05-31 18:42:31 +0000
commit4c852ab2fae14936d23ffa2317566ca3eed3225a (patch)
tree98c483f918b5fa57f69d8754b388485da4f2ecd3 /configure.ac
parent47f3ee6e061662f02e173fc15d114843e3697507 (diff)
-test for nss.h
git-svn-id: https://gnunet.org/svn/gnunet@21665 140774ce-b5e7-0310-ab8b-a85725594a96
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2cc522bf6a..a861bd4097 100644
--- a/configure.ac
+++ b/configure.ac
@@ -339,6 +339,18 @@ else
fi
+
+AC_CHECK_HEADERS([nss.h],[nss=true],[nss=false])
+if test x$nss = xnss
+then
+ AM_CONDITIONAL(HAVE_GLIBCNSS, false)
+ AC_MSG_WARN([No GNU libc nss header, will not build NSS plugin])
+else
+ AM_CONDITIONAL(HAVE_GLIBCNSS, true)
+fi
+
+
+
# test for kvm and kstat (for CPU stats under BSD/Solaris)
AC_CHECK_LIB([kvm],[kvm_open])
AC_CHECK_LIB([kstat],[kstat_open])