aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-05-28 09:02:31 +0000
committerChristian Grothoff <christian@grothoff.org>2015-05-28 09:02:31 +0000
commit078f7063aef1d4105e71160b8764ab95c2dcdfbe (patch)
tree86d498356ceaaa1ba738f64a158cce2cd0163a15 /configure.ac
parent9469cd334f29ca9437e13eb951b53b7690f10be9 (diff)
adding --enable-taler-wallet configure option to build a reduced version of libgnunetutil with only the parts needed by GNU Taler wallets
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6495cc6288..53bb114b72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -546,6 +546,21 @@ fi
AC_CHECK_LIB([kvm],[kvm_open])
AC_CHECK_LIB([kstat],[kstat_open])
+
+# should experimental code be compiled (code that may not yet compile)?
+AC_MSG_CHECKING(whether to compile GNU Taler Wallet library ONLY)
+AC_ARG_ENABLE([taler-wallet],
+ [AS_HELP_STRING([--taler-wallet], [only compile for Taler wallet])],
+ [taler_only=${enableval}],
+ [taler_only=no])
+AC_MSG_RESULT($taler_only)
+AM_CONDITIONAL([TALER_ONLY], [test "x$taler_only" = "xyes"])
+
+if test "$taler_only" != yes
+then
+
+
+
# test for libextractor
extractor=0
AC_MSG_CHECKING(for libextractor)
@@ -581,6 +596,7 @@ fi
# restore LIBS
LIBS=$SAVE_LIBS
+
# Check for libltdl header (#2999)
ltdl=0
AC_MSG_CHECKING(for libltdl)
@@ -618,6 +634,8 @@ fi
# restore LIBS
LIBS=$SAVE_LIBS
+fi
+
# test for libunistring
gl_LIBUNISTRING
if test $HAVE_LIBUNISTRING != yes; then