aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am471
1 files changed, 317 insertions, 154 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index b040874..5f65dff 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -4,29 +4,42 @@ plugindir = $(libdir)/gnunet
pkgcfgdir= $(pkgdatadir)/config.d/
+libexecdir= $(pkglibdir)/libexec/
+
pkgcfg_DATA = \
transport.conf
if HAVE_MHD
GN_LIBMHD = -lmicrohttpd
- HTTP_PLUGIN_LA = libgnunet_plugin_transport_http.la
+ HTTP_SERVER_PLUGIN_LA = libgnunet_plugin_transport_http_server.la
+ HTTPS_SERVER_PLUGIN_LA = libgnunet_plugin_transport_https_server.la
+ HTTP_SERVER_PLUGIN_TEST = test_plugin_http_server
+ HTTPS_SERVER_PLUGIN_TEST = test_plugin_https_server
+endif
+
+if HAVE_LIBCURL
+ HTTP_CLIENT_PLUGIN_TEST = test_plugin_http_client
+ HTTPS_CLIENT_PLUGIN_TEST = test_plugin_https_client
+ HTTP_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_http_client.la
+ HTTPS_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_https_client.la
+endif
+
+if HAVE_MHD
+if HAVE_LIBCURL
HTTP_API_TEST = test_transport_api_http
- HTTP_NAT_API_TEST = test_transport_api_http_nat
+ HTTP_REVERSE_API_TEST = test_transport_api_http_reverse
HTTP_API_TIMEOUT_TEST = test_transport_api_timeout_http
HTTP_REL_TEST = test_transport_api_reliability_http
- HTTP_NAT_REL_TEST = test_transport_api_reliability_http_nat
HTTP_QUOTA_TEST = test_quota_compliance_http \
test_quota_compliance_http_asymmetric
- HTTPS_PLUGIN_LA = libgnunet_plugin_transport_https.la
HTTPS_API_TEST = test_transport_api_https
- HTTPS_NAT_API_TEST = test_transport_api_https_nat
HTTPS_API_TIMEOUT_TEST = test_transport_api_timeout_https
HTTPS_REL_TEST = test_transport_api_reliability_https
- HTTPS_NAT_REL_TEST = test_transport_api_reliability_https_nat
HTTPS_QUOTA_TEST = test_quota_compliance_https \
- test_quota_compliance_https_asymmetric
+ test_quota_compliance_https_asymmetric
endif
+endif
if USE_COVERAGE
AM_CFLAGS = --coverage -O0
@@ -36,17 +49,20 @@ if LINUX
WLAN_BIN = gnunet-helper-transport-wlan
WLAN_BIN_DUMMY = gnunet-helper-transport-wlan-dummy
WLAN_BIN_SENDER = gnunet-transport-wlan-sender
+ WLAN_BIN_RECEIVER = gnunet-transport-wlan-receiver
WLAN_PLUGIN_LA = libgnunet_plugin_transport_wlan.la
+ WLAN_PLUGIN_TEST = test_plugin_wlan
WLAN_API_TEST = test_transport_api_wlan
WLAN_REL_TEST = test_transport_api_reliability_wlan
WLAN_UREL_TEST = test_transport_api_unreliability_wlan
+ WLAN_QUOTA_TEST = test_quota_compliance_wlan \
+ test_quota_compliance_wlan_asymmetric
endif
if LINUX
install-exec-hook:
- $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-transport-wlan || true
- $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-transport-wlan || true
+ $(top_srcdir)/src/transport/install-wlan-helper.sh $(libexecdir) $(SUDO_BINARY) || true
else
install-exec-hook:
endif
@@ -54,6 +70,7 @@ endif
if !MINGW
UNIX_PLUGIN_LA = libgnunet_plugin_transport_unix.la
UNIX_PLUGIN_TEST = test_transport_api_unix
+UNIX_TEST = test_plugin_unix
UNIX_PLUGIN_TIMEOUT_TEST = test_transport_api_timeout_unix
UNIX_REL_TEST = test_transport_api_unreliability_unix
UNIX_QUOTA_TEST = test_quota_compliance_unix \
@@ -61,8 +78,8 @@ UNIX_QUOTA_TEST = test_quota_compliance_unix \
endif
noinst_PROGRAMS = \
- $(WLAN_BIN_SENDER)
-# gnunet-transport-connect-running-peers
+ $(WLAN_BIN_SENDER) \
+ $(WLAN_BIN_RECEIVER)
lib_LTLIBRARIES = \
libgnunettransport.la \
@@ -74,6 +91,7 @@ libgnunettransporttesting_la_LIBADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(GN_LIBINTL)
libgnunettransporttesting_la_DEPENDENCIES = \
libgnunettransport.la
@@ -91,13 +109,15 @@ libgnunettransport_la_LIBADD = \
$(GN_LIBINTL)
libgnunettransport_la_LDFLAGS = \
$(GN_LIB_LDFLAGS) $(WINFLAGS) \
- -version-info 1:0:0
+ -version-info 3:0:1
-bin_PROGRAMS = \
- gnunet-transport \
+libexec_PROGRAMS = \
$(WLAN_BIN) \
$(WLAN_BIN_DUMMY) \
- gnunet-service-transport \
+ gnunet-service-transport
+
+bin_PROGRAMS = \
+ gnunet-transport \
gnunet-transport-certificate-creation
#bin_SCRIPTS = \
@@ -121,6 +141,11 @@ gnunet_transport_wlan_sender_SOURCES = \
gnunet_transport_wlan_sender_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la
+gnunet_transport_wlan_receiver_SOURCES = \
+ gnunet-transport-wlan-receiver.c
+gnunet_transport_wlan_receiver_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la
+
gnunet_transport_SOURCES = \
gnunet-transport.c
gnunet_transport_LDADD = \
@@ -139,7 +164,8 @@ gnunet_service_transport_SOURCES = \
gnunet-service-transport_hello.h gnunet-service-transport_hello.c \
gnunet-service-transport_neighbours.h gnunet-service-transport_neighbours.c \
gnunet-service-transport_plugins.h gnunet-service-transport_plugins.c \
- gnunet-service-transport_validation.h gnunet-service-transport_validation.c
+ gnunet-service-transport_validation.h gnunet-service-transport_validation.c \
+ gnunet-service-transport_manipulation.h gnunet-service-transport_manipulation.c
gnunet_service_transport_LDADD = \
$(top_builddir)/src/ats/libgnunetats.la \
$(top_builddir)/src/hello/libgnunethello.la \
@@ -148,13 +174,18 @@ gnunet_service_transport_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(GN_GLPK) \
$(GN_LIBINTL)
+gnunet_service_transport_CFLAGS = \
+ $(CFLAGS)
+# -DANALYZE
plugin_LTLIBRARIES = \
libgnunet_plugin_transport_tcp.la \
libgnunet_plugin_transport_udp.la \
$(UNIX_PLUGIN_LA) \
- $(HTTP_PLUGIN_LA) \
- $(HTTPS_PLUGIN_LA) \
+ $(HTTP_CLIENT_PLUGIN_LA) \
+ $(HTTPS_CLIENT_PLUGIN_LA) \
+ $(HTTP_SERVER_PLUGIN_LA) \
+ $(HTTPS_SERVER_PLUGIN_LA) \
$(WLAN_PLUGIN_LA) \
libgnunet_plugin_transport_template.la
@@ -165,14 +196,16 @@ libgnunet_plugin_transport_tcp_la_LIBADD = \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
$(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
$(top_builddir)/src/nat/libgnunetnat.la \
- $(top_builddir)/src/util/libgnunetutil.la
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(LTLIBINTL)
libgnunet_plugin_transport_tcp_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
libgnunet_plugin_transport_template_la_SOURCES = \
plugin_transport_template.c
libgnunet_plugin_transport_template_la_LIBADD = \
- $(top_builddir)/src/util/libgnunetutil.la
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(LTLIBINTL)
libgnunet_plugin_transport_template_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
@@ -196,7 +229,8 @@ libgnunet_plugin_transport_udp_la_LIBADD = \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
$(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
$(top_builddir)/src/nat/libgnunetnat.la \
- $(top_builddir)/src/util/libgnunetutil.la
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(LTLIBINTL)
libgnunet_plugin_transport_udp_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
@@ -206,50 +240,88 @@ libgnunet_plugin_transport_unix_la_LIBADD = \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
$(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
- $(top_builddir)/src/util/libgnunetutil.la
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(LTLIBINTL)
libgnunet_plugin_transport_unix_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
-libgnunet_plugin_transport_http_la_SOURCES = \
- plugin_transport_http.c plugin_transport_http.h \
- plugin_transport_http_client.c plugin_transport_http_server.c
-libgnunet_plugin_transport_http_la_LIBADD = \
+
+libgnunet_plugin_transport_http_client_la_SOURCES = \
+ plugin_transport_http_client.c plugin_transport_http_common.c plugin_transport_http_common.h
+libgnunet_plugin_transport_http_client_la_LIBADD = \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
$(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
@LIBCURL@ \
$(top_builddir)/src/nat/libgnunetnat.la \
$(top_builddir)/src/util/libgnunetutil.la
-libgnunet_plugin_transport_http_la_LDFLAGS = \
- $(GN_LIBMHD) \
+libgnunet_plugin_transport_http_client_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
-libgnunet_plugin_transport_http_la_CFLAGS = \
+libgnunet_plugin_transport_http_client_la_CFLAGS = \
$(CFLAGS)
-libgnunet_plugin_transport_http_la_CPPFLAGS = \
+libgnunet_plugin_transport_http_client_la_CPPFLAGS = \
@LIBCURL_CPPFLAGS@
-libgnunet_plugin_transport_https_la_SOURCES = \
- plugin_transport_http.c plugin_transport_http.h \
- plugin_transport_http_client.c plugin_transport_http_server.c
-libgnunet_plugin_transport_https_la_LIBADD = \
+
+libgnunet_plugin_transport_http_server_la_SOURCES = \
+ plugin_transport_http_server.c plugin_transport_http_common.c
+libgnunet_plugin_transport_http_server_la_LIBADD = \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
$(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
- @LIBCURL@ \
$(top_builddir)/src/nat/libgnunetnat.la \
$(top_builddir)/src/util/libgnunetutil.la
-libgnunet_plugin_transport_https_la_LDFLAGS = \
+libgnunet_plugin_transport_http_server_la_LDFLAGS = \
$(GN_LIBMHD) \
$(GN_PLUGIN_LDFLAGS)
-libgnunet_plugin_transport_https_la_CFLAGS = \
+libgnunet_plugin_transport_http_server_la_CFLAGS = \
+ $(CFLAGS)
+
+libgnunet_plugin_transport_https_client_la_SOURCES = \
+ plugin_transport_http_client.c plugin_transport_http_common.c
+libgnunet_plugin_transport_https_client_la_LIBADD = \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
+ @LIBCURL@ \
+ $(top_builddir)/src/nat/libgnunetnat.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+libgnunet_plugin_transport_https_client_la_LDFLAGS = \
+ $(GN_PLUGIN_LDFLAGS)
+libgnunet_plugin_transport_https_client_la_CFLAGS = \
$(CFLAGS) -DBUILD_HTTPS
-libgnunet_plugin_transport_https_la_CPPFLAGS = \
+libgnunet_plugin_transport_https_client_la_CPPFLAGS = \
@LIBCURL_CPPFLAGS@
+libgnunet_plugin_transport_https_server_la_SOURCES = \
+ plugin_transport_http_server.c plugin_transport_http_common.c
+libgnunet_plugin_transport_https_server_la_LIBADD = \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
+ $(top_builddir)/src/nat/libgnunetnat.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+libgnunet_plugin_transport_https_server_la_LDFLAGS = \
+ $(GN_LIBMHD) \
+ $(GN_PLUGIN_LDFLAGS)
+libgnunet_plugin_transport_https_server_la_CFLAGS = \
+ $(CFLAGS) -DBUILD_HTTPS
+
check_PROGRAMS = \
+ test_transport_testing_startstop \
+ test_transport_testing_restart \
test_transport_testing \
test_transport_startonly \
+ test_plugin_tcp \
+ test_plugin_udp \
+ $(UNIX_TEST) \
+ $(WLAN_PLUGIN_TEST) \
+ test_http_common \
+ $(HTTP_CLIENT_PLUGIN_TEST) \
+ $(HTTPS_CLIENT_PLUGIN_TEST) \
+ $(HTTP_SERVER_PLUGIN_TEST) \
+ $(HTTPS_SERVER_PLUGIN_TEST) \
test_transport_api_blacklisting \
test_transport_api_disconnect_tcp \
test_transport_api_bidirectional_connect \
@@ -265,35 +337,41 @@ check_PROGRAMS = \
$(UNIX_PLUGIN_TIMEOUT_TEST) \
test_transport_api_udp_nat \
$(HTTP_API_TEST) \
- $(HTTP_NAT_API_TEST) \
+ $(HTTP_REVERSE_API_TEST) \
$(HTTP_API_TIMEOUT_TEST) \
$(HTTPS_API_TEST) \
- $(HTTPS_NAT_API_TEST) \
$(HTTPS_API_TIMEOUT_TEST) \
+ $(WLAN_API_TEST) \
test_transport_api_multi \
+ test_transport_api_manipulation_send_tcp \
+ test_transport_api_manipulation_recv_tcp \
test_transport_api_reliability_tcp \
test_transport_api_reliability_tcp_nat \
test_transport_api_unreliability_udp \
test_transport_api_unreliability_constant_udp \
$(UNIX_REL_TEST) \
$(HTTP_REL_TEST) \
- $(HTTP_NAT_REL_TEST) \
$(HTTPS_REL_TEST) \
- $(HTTPS_NAT_REL_TEST) \
+ $(WLAN_REL_TEST) \
+ $(WLAN_UREL_TEST) \
test_quota_compliance_tcp \
test_quota_compliance_tcp_asymmetric \
test_quota_compliance_udp \
$(UNIX_QUOTA_TEST) \
$(HTTP_QUOTA_TEST) \
$(HTTPS_QUOTA_TEST) \
- $(WLAN_API_TEST) \
- $(WLAN_REL_TEST) \
- $(WLAN_UREL_TEST)
+ $(WLAN_QUOTA_TEST)
if ENABLE_TEST_RUN
TESTS = \
+ test_transport_testing_startstop \
+ test_transport_testing_restart \
test_transport_testing \
test_transport_startonly \
+ test_plugin_tcp \
+ test_plugin_udp \
+ $(UNIX_TEST) \
+ $(WLAN_PLUGIN_TEST) \
test_transport_api_blacklisting \
test_transport_api_disconnect_tcp \
test_transport_api_bidirectional_connect \
@@ -309,32 +387,46 @@ TESTS = \
$(UNIX_PLUGIN_TIMEOUT_TEST) \
test_transport_api_udp_nat \
$(HTTP_API_TEST) \
- $(HTTP_NAT_API_TEST) \
$(HTTP_API_TIMEOUT_TEST) \
$(HTTPS_API_TEST) \
- $(HTTPS_NAT_API_TEST) \
$(HTTPS_API_TIMEOUT_TEST) \
+ $(WLAN_API_TEST) \
test_transport_api_multi \
+ test_transport_api_manipulation_send_tcp \
+ test_transport_api_manipulation_recv_tcp \
test_transport_api_reliability_tcp \
test_transport_api_reliability_tcp_nat \
test_transport_api_unreliability_udp \
test_transport_api_unreliability_constant_udp \
$(UNIX_REL_TEST) \
$(HTTP_REL_TEST) \
- $(HTTP_NAT_REL_TEST) \
$(HTTPS_REL_TEST) \
- $(HTTPS_NAT_REL_TEST) \
+ $(WLAN_REL_TEST) \
+ $(WLAN_UREL_TEST) \
test_quota_compliance_tcp \
test_quota_compliance_tcp_asymmetric \
test_quota_compliance_udp \
$(UNIX_QUOTA_TEST) \
$(HTTP_QUOTA_TEST) \
- $(HTTPS_QUOTA_TEST) \
- $(WLAN_API_TEST) \
- $(WLAN_REL_TEST) \
- $(WLAN_UREL_TEST)
+ $(HTTPS_QUOTA_TEST)
endif
+test_transport_testing_startstop_SOURCES = \
+ test_transport_testing_startstop.c
+test_transport_testing_startstop_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+test_transport_testing_restart_SOURCES = \
+ test_transport_testing_restart.c
+test_transport_testing_restart_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
test_transport_testing_SOURCES = \
test_transport_testing.c
test_transport_testing_LDADD = \
@@ -343,14 +435,6 @@ test_transport_testing_LDADD = \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-#gnunet_transport_connect_running_peers_SOURCES = \
-# gnunet-transport-connect-running-peers.c
-#gnunet_transport_connect_running_peers_LDADD = \
-# $(top_builddir)/src/transport/libgnunettransport.la \
-# $(top_builddir)/src/hello/libgnunethello.la \
-# $(top_builddir)/src/util/libgnunetutil.la \
-# $(top_builddir)/src/transport/libgnunettransporttesting.la
-
test_transport_api_blacklisting_SOURCES = \
test_transport_api_blacklisting.c
test_transport_api_blacklisting_LDADD = \
@@ -378,6 +462,88 @@ test_transport_startonly_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
+test_plugin_tcp_SOURCES = \
+ test_plugin_transport.c
+test_plugin_tcp_LDADD = \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+test_plugin_udp_SOURCES = \
+ test_plugin_transport.c
+test_plugin_udp_LDADD = \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+test_plugin_unix_SOURCES = \
+ test_plugin_transport.c
+test_plugin_unix_LDADD = \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+test_plugin_wlan_SOURCES = \
+ test_plugin_transport.c
+test_plugin_wlan_LDADD = \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+
+test_http_common_SOURCES = \
+ test_http_common.c plugin_transport_http_common.c
+test_http_common_LDADD = \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+test_plugin_http_server_SOURCES = \
+ test_plugin_transport.c
+test_plugin_http_server_LDADD = \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+test_plugin_https_server_SOURCES = \
+ test_plugin_transport.c
+test_plugin_https_server_LDADD = \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+test_plugin_http_client_SOURCES = \
+ test_plugin_transport.c
+test_plugin_http_client_LDADD = \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+test_plugin_https_client_SOURCES = \
+ test_plugin_transport.c
+test_plugin_https_client_LDADD = \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
test_transport_api_tcp_SOURCES = \
test_transport_api.c
test_transport_api_tcp_LDADD = \
@@ -385,7 +551,7 @@ test_transport_api_tcp_LDADD = \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-
+
test_transport_api_bidirectional_connect_SOURCES = \
test_transport_api_bidirectional_connect.c
test_transport_api_bidirectional_connect_LDADD = \
@@ -411,7 +577,7 @@ test_transport_api_restart_2peers_LDADD = \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-
+
test_transport_api_limited_sockets_tcp_SOURCES = \
test_transport_api_limited_sockets.c
test_transport_api_limited_sockets_tcp_LDADD = \
@@ -428,46 +594,47 @@ test_transport_api_tcp_nat_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-test_transport_api_reliability_tcp_SOURCES = \
- test_transport_api_reliability.c
-test_transport_api_reliability_tcp_LDADD = \
+test_transport_api_manipulation_send_tcp_SOURCES = \
+ test_transport_api_manipulation_send_tcp.c
+test_transport_api_manipulation_send_tcp_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-test_transport_api_timeout_tcp_SOURCES = \
- test_transport_api_timeout.c
-test_transport_api_timeout_tcp_LDADD = \
+test_transport_api_manipulation_recv_tcp_SOURCES = \
+ test_transport_api_manipulation_recv_tcp.c
+test_transport_api_manipulation_recv_tcp_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-test_transport_api_timeout_unix_SOURCES = \
- test_transport_api_timeout.c
-test_transport_api_timeout_unix_LDADD = \
+
+test_transport_api_reliability_tcp_SOURCES = \
+ test_transport_api_reliability.c
+test_transport_api_reliability_tcp_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-test_transport_api_timeout_http_SOURCES = \
+test_transport_api_timeout_tcp_SOURCES = \
test_transport_api_timeout.c
-test_transport_api_timeout_http_LDADD = \
+test_transport_api_timeout_tcp_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-
-test_transport_api_timeout_https_SOURCES = \
+
+test_transport_api_timeout_unix_SOURCES = \
test_transport_api_timeout.c
-test_transport_api_timeout_https_LDADD = \
+test_transport_api_timeout_unix_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-
+
test_transport_api_reliability_tcp_nat_SOURCES = \
test_transport_api_reliability.c
test_transport_api_reliability_tcp_nat_LDADD = \
@@ -491,7 +658,7 @@ test_transport_api_unreliability_wlan_LDADD = \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-
+
test_transport_api_udp_SOURCES = \
test_transport_api.c
test_transport_api_udp_LDADD = \
@@ -499,7 +666,7 @@ test_transport_api_udp_LDADD = \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-
+
test_transport_api_timeout_udp_SOURCES = \
test_transport_api_timeout.c
test_transport_api_timeout_udp_LDADD = \
@@ -524,21 +691,30 @@ test_transport_api_unix_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
+# HTTP tests
test_transport_api_http_SOURCES = \
test_transport_api.c
test_transport_api_http_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/transport/libgnunettransporttesting.la
-
- test_transport_api_http_nat_SOURCES = \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+test_transport_api_http_reverse_SOURCES = \
test_transport_api.c
-test_transport_api_http_nat_LDADD = \
+test_transport_api_http_reverse_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/transport/libgnunettransporttesting.la
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+test_transport_api_timeout_http_SOURCES = \
+ test_transport_api_timeout.c
+test_transport_api_timeout_http_LDADD = \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
test_transport_api_reliability_http_SOURCES = \
test_transport_api_reliability.c
@@ -548,14 +724,39 @@ test_transport_api_reliability_http_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-test_transport_api_reliability_http_nat_SOURCES = \
- test_transport_api_reliability.c
-test_transport_api_reliability_http_nat_LDADD = \
+test_quota_compliance_http_SOURCES = \
+ test_quota_compliance.c
+test_quota_compliance_http_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
+test_quota_compliance_http_asymmetric_SOURCES = \
+ test_quota_compliance.c
+test_quota_compliance_http_asymmetric_LDADD = \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+test_quota_compliance_https_SOURCES = \
+ test_quota_compliance.c
+test_quota_compliance_https_LDADD = \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+test_quota_compliance_https_asymmetric_SOURCES = \
+ test_quota_compliance.c
+test_quota_compliance_https_asymmetric_LDADD = \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
+# HTTPS tests
test_transport_api_https_SOURCES = \
test_transport_api.c
test_transport_api_https_LDADD = \
@@ -564,13 +765,14 @@ test_transport_api_https_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-test_transport_api_https_nat_SOURCES = \
- test_transport_api.c
-test_transport_api_https_nat_LDADD = \
+test_transport_api_timeout_https_SOURCES = \
+ test_transport_api_timeout.c
+test_transport_api_timeout_https_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/transport/libgnunettransporttesting.la
+ $(top_builddir)/src/transport/libgnunettransporttesting.la
+
test_transport_api_reliability_https_SOURCES = \
test_transport_api_reliability.c
@@ -580,14 +782,6 @@ test_transport_api_reliability_https_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-test_transport_api_reliability_https_nat_SOURCES = \
- test_transport_api_reliability.c
-test_transport_api_reliability_https_nat_LDADD = \
- $(top_builddir)/src/transport/libgnunettransport.la \
- $(top_builddir)/src/hello/libgnunethello.la \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/transport/libgnunettransporttesting.la
-
test_transport_api_unreliability_unix_SOURCES = \
test_transport_api_unreliability.c
test_transport_api_unreliability_unix_LDADD = \
@@ -638,75 +832,41 @@ test_quota_compliance_tcp_asymmetric_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-#test_quota_compliance_tcp_asymmetric_send_constant_SOURCES = \
-# test_quota_compliance.c
-#test_quota_compliance_tcp_asymmetric_send_constant_LDADD = \
-# $(top_builddir)/src/transport/libgnunettransport.la \
-# $(top_builddir)/src/util/libgnunetutil.la
-
-test_quota_compliance_http_SOURCES = \
- test_quota_compliance.c
-test_quota_compliance_http_LDADD = \
- $(top_builddir)/src/transport/libgnunettransport.la \
- $(top_builddir)/src/hello/libgnunethello.la \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/transport/libgnunettransporttesting.la
-
- test_quota_compliance_http_asymmetric_SOURCES = \
- test_quota_compliance.c
-test_quota_compliance_http_asymmetric_LDADD = \
- $(top_builddir)/src/transport/libgnunettransport.la \
- $(top_builddir)/src/hello/libgnunethello.la \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/transport/libgnunettransporttesting.la
-
-#test_quota_compliance_http_asymmetric_send_constant_SOURCES = \
-# test_quota_compliance.c
-#test_quota_compliance_http_asymmetric_send_constant_LDADD = \
-# $(top_builddir)/src/transport/libgnunettransport.la \
-# $(top_builddir)/src/util/libgnunetutil.la
-
-test_quota_compliance_https_SOURCES = \
+test_quota_compliance_udp_SOURCES = \
test_quota_compliance.c
-test_quota_compliance_https_LDADD = \
+test_quota_compliance_udp_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
- test_quota_compliance_https_asymmetric_SOURCES = \
+test_quota_compliance_unix_SOURCES = \
test_quota_compliance.c
-test_quota_compliance_https_asymmetric_LDADD = \
+test_quota_compliance_unix_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-#test_quota_compliance_https_asymmetric_send_constant_SOURCES = \
-# test_quota_compliance.c
-#test_quota_compliance_https_asymmetric_send_constant_LDADD = \
-# $(top_builddir)/src/transport/libgnunettransport.la \
-# $(top_builddir)/src/util/libgnunetutil.la
-
-test_quota_compliance_udp_SOURCES = \
+test_quota_compliance_unix_asymmetric_SOURCES = \
test_quota_compliance.c
-test_quota_compliance_udp_LDADD = \
+test_quota_compliance_unix_asymmetric_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-test_quota_compliance_unix_SOURCES = \
+test_quota_compliance_wlan_SOURCES = \
test_quota_compliance.c
-test_quota_compliance_unix_LDADD = \
+test_quota_compliance_wlan_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/transport/libgnunettransporttesting.la
-test_quota_compliance_unix_asymmetric_SOURCES = \
+test_quota_compliance_wlan_asymmetric_SOURCES = \
test_quota_compliance.c
-test_quota_compliance_unix_asymmetric_LDADD = \
+test_quota_compliance_wlan_asymmetric_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la \
@@ -722,7 +882,8 @@ test_transport_api_multi_LDADD = \
EXTRA_DIST = \
-gnunet-transport-certificate-creation \
+test_plugin_hostkey \
+test_plugin_hostkey.ecc \
template_cfg_peer1.conf\
template_cfg_peer2.conf\
test_plugin_transport_data.conf\
@@ -738,6 +899,8 @@ test_quota_compliance_udp_peer1.conf\
test_quota_compliance_udp_peer2.conf\
test_quota_compliance_unix_peer1.conf\
test_quota_compliance_unix_peer2.conf\
+test_quota_compliance_wlan_peer1.conf\
+test_quota_compliance_wlan_peer2.conf\
test_quota_compliance_http_asymmetric_peer1.conf\
test_quota_compliance_http_asymmetric_peer2.conf\
test_quota_compliance_https_asymmetric_peer1.conf\
@@ -746,6 +909,8 @@ test_quota_compliance_tcp_asymmetric_peer1.conf\
test_quota_compliance_tcp_asymmetric_peer2.conf\
test_quota_compliance_unix_asymmetric_peer1.conf\
test_quota_compliance_unix_asymmetric_peer2.conf\
+test_quota_compliance_wlan_asymmetric_peer1.conf\
+test_quota_compliance_wlan_asymmetric_peer2.conf\
test_transport_api_data.conf\
test_transport_api_http_peer1.conf\
test_transport_api_http_peer2.conf\
@@ -769,6 +934,10 @@ test_transport_api_reliability_wlan_peer1.conf\
test_transport_api_reliability_wlan_peer2.conf\
test_transport_api_bidirectional_connect_peer1.conf\
test_transport_api_bidirectional_connect_peer2.conf\
+test_transport_api_manipulation_send_tcp_peer1.conf\
+test_transport_api_manipulation_send_tcp_peer2.conf\
+test_transport_api_manipulation_recv_tcp_peer1.conf\
+test_transport_api_manipulation_recv_tcp_peer2.conf\
test_transport_api_tcp_nat_peer1.conf\
test_transport_api_tcp_nat_peer2.conf\
test_transport_api_tcp_peer1.conf\
@@ -795,17 +964,11 @@ test_transport_defaults.conf\
test_transport_startonly.conf\
test_transport_api_disconnect_tcp_peer1.conf\
test_transport_api_disconnect_tcp_peer2.conf\
-test_transport_api_http_nat_peer1.conf\
-test_transport_api_http_nat_peer2.conf\
-test_transport_api_https_nat_peer1.conf\
-test_transport_api_https_nat_peer2.conf\
-test_transport_api_reliability_http_nat_peer1.conf\
-test_transport_api_reliability_http_nat_peer2.conf\
-test_transport_api_reliability_https_nat_peer1.conf\
-test_transport_api_reliability_https_nat_peer2.conf\
test_transport_api_timeout_http_peer1.conf\
test_transport_api_timeout_http_peer2.conf\
test_transport_api_timeout_https_peer1.conf\
test_transport_api_timeout_https_peer2.conf\
test_transport_api_unreliability_constant_udp_peer1.conf\
-test_transport_api_unreliability_constant_udp_peer2.conf
+test_transport_api_unreliability_constant_udp_peer2.conf\
+test_transport_api_http_reverse_peer1.conf \
+test_transport_api_http_reverse_peer2.conf