aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am72
1 files changed, 60 insertions, 12 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 7783506..1d36fe7 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -4,6 +4,8 @@ plugindir = $(libdir)/gnunet
pkgcfgdir= $(pkgdatadir)/config.d/
+libexecdir= $(pkglibdir)/libexec/
+
pkgcfg_DATA = \
namestore.conf
@@ -18,13 +20,18 @@ if USE_COVERAGE
endif
if HAVE_SQLITE
-SQLITE_TESTS = \
- test_plugin_namestore_sqlite
+SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
+SQLITE_TESTS = test_plugin_namestore_sqlite
+endif
+if HAVE_POSTGRES
+POSTGRES_TESTS = test_plugin_namestore_postgres
+POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
endif
-
+if HAVE_SQLITE
check_PROGRAMS = \
$(SQLITE_TESTS) \
+ $(POSTGRES_TESTS) \
test_namestore_record_serialization \
test_namestore_api_sign_verify \
test_namestore_api \
@@ -39,6 +46,7 @@ check_PROGRAMS = \
test_namestore_api_zone_iteration \
test_namestore_api_zone_iteration_specific_zone \
test_namestore_api_zone_iteration_stop
+endif
if ENABLE_TEST_RUN
TESTS = $(check_PROGRAMS)
@@ -55,10 +63,12 @@ libgnunetnamestore_la_LIBADD = \
$(GN_LIBINTL)
libgnunetnamestore_la_LDFLAGS = \
$(GN_LIB_LDFLAGS) $(WINFLAGS) \
- -version-info 0:0:0
+ -version-info 0:1:0
+
+libexec_PROGRAMS = \
+ gnunet-service-namestore
bin_PROGRAMS = \
- gnunet-service-namestore \
gnunet-namestore
@@ -87,19 +97,18 @@ gnunet_service_namestore_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
libgnunetnamestore.la
-if HAVE_SQLITE
- SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
-endif
plugin_LTLIBRARIES = \
- $(SQLITE_PLUGIN)
+ $(SQLITE_PLUGIN) \
+ $(POSTGRES_PLUGIN)
libgnunet_plugin_namestore_sqlite_la_SOURCES = \
plugin_namestore_sqlite.c namestore_common.c
libgnunet_plugin_namestore_sqlite_la_LIBADD = \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
- $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3
+ $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
+ $(LTLIBINTL)
libgnunet_plugin_namestore_sqlite_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
libgnunet_plugin_namestore_sqlite_la_DEPENDENCIES = \
@@ -107,33 +116,55 @@ libgnunet_plugin_namestore_sqlite_la_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
libgnunetnamestore.la
+
+libgnunet_plugin_namestore_postgres_la_SOURCES = \
+ plugin_namestore_postgres.c namestore_common.c
+libgnunet_plugin_namestore_postgres_la_LIBADD = \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/postgres/libgnunetpostgres.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lpq \
+ $(LTLIBINTL)
+libgnunet_plugin_namestore_postgres_la_LDFLAGS = \
+ $(GN_PLUGIN_LDFLAGS)
+libgnunet_plugin_namestore_postgres_la_DEPENDENCIES = \
+ $(top_builddir)/src/postgres/libgnunetpostgres.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ libgnunetnamestore.la
+
test_namestore_api_sign_verify_SOURCES = \
test_namestore_api_sign_verify.c
test_namestore_api_sign_verify_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
test_namestore_api_SOURCES = \
test_namestore_api.c
test_namestore_api_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
test_namestore_api_put_SOURCES = \
test_namestore_api_put.c
test_namestore_api_put_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
test_namestore_api_lookup_SOURCES = \
test_namestore_api_lookup.c
test_namestore_api_lookup_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
test_namestore_api_lookup_specific_type_SOURCES = \
test_namestore_api_lookup_specific_type.c
test_namestore_api_lookup_specific_type_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
@@ -141,12 +172,14 @@ test_namestore_api_lookup_specific_type_LDADD = \
test_namestore_api_create_SOURCES = \
test_namestore_api_create.c
test_namestore_api_create_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
test_namestore_api_create_update_SOURCES = \
test_namestore_api_create_update.c
test_namestore_api_create_update_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
@@ -154,48 +187,56 @@ test_namestore_api_create_update_LDADD = \
test_namestore_api_remove_SOURCES = \
test_namestore_api_remove.c
test_namestore_api_remove_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
test_namestore_api_remove_not_existing_record_SOURCES = \
test_namestore_api_remove_not_existing_record.c
test_namestore_api_remove_not_existing_record_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
test_namestore_api_zone_to_name_SOURCES = \
test_namestore_api_zone_to_name.c
test_namestore_api_zone_to_name_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
test_namestore_api_zone_iteration_SOURCES = \
test_namestore_api_zone_iteration.c
test_namestore_api_zone_iteration_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
-
+
test_namestore_api_zone_iteration_specific_zone_SOURCES = \
test_namestore_api_zone_iteration_specific_zone.c
test_namestore_api_zone_iteration_specific_zone_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
-
+
test_namestore_api_zone_iteration_stop_SOURCES = \
test_namestore_api_zone_iteration_stop.c
test_namestore_api_zone_iteration_stop_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
test_namestore_record_serialization_SOURCES = \
test_namestore_record_serialization.c
test_namestore_record_serialization_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la
EXTRA_DIST = \
test_namestore_api.conf \
test_plugin_namestore_sqlite.conf\
+ test_plugin_namestore_postgres.conf\
test_hostkey \
zonefiles/HGU0A0VCU334DN7F2I9UIUMVQMM7JMSD142LIMNUGTTV9R0CF4EG.zkey \
zonefiles/N0UJMP015AFUNR2BTNM3FKPBLG38913BL8IDMCO2H0A1LIB81960.zkey
@@ -204,4 +245,11 @@ EXTRA_DIST = \
test_plugin_namestore_sqlite_SOURCES = \
test_plugin_namestore.c
test_plugin_namestore_sqlite_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+test_plugin_namestore_postgres_SOURCES = \
+ test_plugin_namestore.c
+test_plugin_namestore_postgres_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la