aboutsummaryrefslogtreecommitdiff
path: root/src/integration-tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/integration-tests/Makefile.am')
-rw-r--r--src/integration-tests/Makefile.am15
1 files changed, 4 insertions, 11 deletions
diff --git a/src/integration-tests/Makefile.am b/src/integration-tests/Makefile.am
index fb69e28..e42fb0c 100644
--- a/src/integration-tests/Makefile.am
+++ b/src/integration-tests/Makefile.am
@@ -21,7 +21,7 @@ noinst_SCRIPTS = \
test_integration_connection_values_tcp_udp.py \
test_integration_connection_values_tcp_udp_http.py
-if HAVE_PYTHON_PEXPECT
+if HAVE_PYTHON
check_SCRIPTS = \
test_integration_bootstrap_and_connect.py \
test_integration_bootstrap_and_connect_and_disconnect.py \
@@ -33,14 +33,13 @@ check_SCRIPTS = \
endif
# test_integration_disconnect.py
-check_PROGRAMS = \
- test_connection_stability
-
+if HAVE_MHD
if ENABLE_TEST_RUN
TESTS = \
$(check_SCRIPTS)
endif
+endif
connection_watchdog_SOURCE = \
connection_watchdog.c
@@ -113,12 +112,6 @@ test_integration_connection_values_tcp_udp_http.py: test_integration_connection_
$(do_subst) < $(srcdir)/test_integration_connection_values_tcp_udp_http.py.in > test_integration_connection_values_tcp_udp_http.py
chmod +x test_integration_connection_values_tcp_udp_http.py
-test_connection_stability_SOURCES = \
- test_connection_stability.c
-test_connection_stability_LDADD = \
- $(top_builddir)/src/testing/libgnunettesting.la \
- $(top_builddir)/src/util/libgnunetutil.la
-
EXTRA_DIST = \
gnunet_testing.py.in \
@@ -135,6 +128,7 @@ EXTRA_DIST = \
test_integration_clique.py.in \
test_integration_clique_nat.py.in \
confs/c_bootstrap_server.conf \
+ confs/c_bootstrap_server_w_massif.conf \
confs/c_nat_client.conf \
confs/c_no_nat_client_2.conf \
confs/c_no_nat_client.conf \
@@ -147,7 +141,6 @@ EXTRA_DIST = \
confs/c_no_nat_client_http_2.conf \
confs/c_no_nat_client_unix.conf \
confs/c_no_nat_client_unix_2.conf \
- test_connection_stability.conf \
hostkeys/0000-hostkey \
hostkeys/0001-hostkey \
hostkeys/0002-hostkey \