aboutsummaryrefslogtreecommitdiff
path: root/src/hello/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/hello/Makefile.am')
-rw-r--r--src/hello/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/hello/Makefile.am b/src/hello/Makefile.am
new file mode 100644
index 0000000..1788e8f
--- /dev/null
+++ b/src/hello/Makefile.am
@@ -0,0 +1,34 @@
+INCLUDES = -I$(top_srcdir)/src/include
+
+if MINGW
+ WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
+endif
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+lib_LTLIBRARIES = libgnunethello.la
+
+libgnunethello_la_SOURCES = \
+ hello.c address.c
+libgnunethello_la_LIBADD = \
+ $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
+libgnunethello_la_LDFLAGS = \
+ $(GN_LIB_LDFLAGS) \
+ -version-info 0:0:0
+
+check_PROGRAMS = \
+ test_hello
+
+if ENABLE_TEST_RUN
+TESTS = $(check_PROGRAMS)
+endif
+
+test_hello_SOURCES = \
+ test_hello.c
+test_hello_LDADD = \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+