aboutsummaryrefslogtreecommitdiff
path: root/src/gns/nss/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gns/nss/Makefile.am')
-rw-r--r--src/gns/nss/Makefile.am25
1 files changed, 14 insertions, 11 deletions
diff --git a/src/gns/nss/Makefile.am b/src/gns/nss/Makefile.am
index 5e8ab5a..64bc813 100644
--- a/src/gns/nss/Makefile.am
+++ b/src/gns/nss/Makefile.am
@@ -3,8 +3,8 @@
# This file taken and modified from nss-gns.
#
# nss-gns is free software; you can redistribute it and/or modify it
-# under the terms of the GNU Lesser General Public License as
-# published by the Free Software Foundation; either version 2 of the
+# under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 3 of the
# License, or (at your option) any later version.
#
# nss-gns is distributed in the hope that it will be useful, but
@@ -17,24 +17,24 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.
-EXTRA_DIST = map-file
+EXTRA_DIST = map-file \
+ install-nss-plugin.sh \
+ uninstall-nss-plugin.sh
AM_LDFLAGS=-avoid-version -module -export-dynamic
-if HAVE_SUDO
-nssdir = /lib/
-else
-nssdir = $(libdir)
-endif
+nssdir = $(NSS_DIR)
LIBTOOL = $(SUDO_BINARY) $(SHELL) $(top_builddir)/libtool
if !MINGW
+if INSTALL_NSS
nss_LTLIBRARIES = \
libnss_gns.la \
libnss_gns4.la \
libnss_gns6.la
endif
+endif
sources = nss_gns_query.h nss_gns_query.c
@@ -51,9 +51,12 @@ libnss_gns6_la_SOURCES=$(libnss_gns_la_SOURCES)
libnss_gns6_la_CFLAGS=$(libnss_gns_la_CFLAGS) -DNSS_IPV6_ONLY=1
libnss_gns6_la_LDFLAGS=$(libnss_gns_la_LDFLAGS)
+if !MINGW
install-data-hook:
- $(SUDO_BINARY) $(SHELL) $(top_builddir)/libtool --finish $(nssdir)
- $(SUDO_BINARY) rm -f $(nssdir)/libnss_gns.la $(nssdir)/libnss_gns4.la $(nssdir)/libnss_gns6.la
+ $(top_srcdir)/src/gns/nss/install-nss-plugin.sh $(SHELL) $(top_builddir) $(nssdir) $(SUDO_BINARY)
uninstall-hook:
- $(SUDO_BINARY) rm -f $(nssdir)/libnss_gns.so.2 $(nssdir)/libnss_gns4.so.2 $(nssdir)/libnss_gns6.so.2
+ $(top_srcdir)/src/gns/nss/uninstall-nss-plugin.sh $(SHELL) $(top_builddir) "rm -f $(nssdir)/libnss_gns.so.2" $(SUDO_BINARY)
+ $(top_srcdir)/src/gns/nss/uninstall-nss-plugin.sh $(SHELL) $(top_builddir) "rm -f $(nssdir)/libnss_gns4.so.2" $(SUDO_BINARY)
+ $(top_srcdir)/src/gns/nss/uninstall-nss-plugin.sh $(SHELL) $(top_builddir) "rm -f $(nssdir)/libnss_gns6.so.2" $(SUDO_BINARY)
+endif