aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am354
1 files changed, 257 insertions, 97 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index 10b9ff3..d4fcb6b 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -6,37 +6,202 @@ endif
SUBDIRS = . $(NSS_SUBDIR)
+EXTRA_DIST = \
+ test_gns_defaults.conf \
+ test_gns_simple_lookup.conf \
+ test_gns_dht_default.conf \
+ gns-helper-service-w32.conf \
+ gnunet-gns-proxy-setup-ca \
+ zonefiles/188JSUMKEF25GVU8TTV0PBNNN8JVCPUEDFV1UHJJU884JD25V0T0.zkey \
+ zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \
+ zonefiles/test_zonekey
+
if MINGW
WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
+ DO_W32_HELPER = gnunet-gns-helper-service-w32
+ DO_W32_NSP = libw32nsp.la
+ DO_W32_NSPTOOLS = w32nsp-install w32nsp-uninstall w32nsp-resolve
+ DO_W32_HS_CONF = gns-helper-service-w32.conf
+else
+ USE_VPN = $(top_builddir)/src/vpn/libgnunetvpn.la
endif
if USE_COVERAGE
AM_CFLAGS = --coverage -O0
endif
-pkgcfgdir= $(pkgdatadir)/config.d/
+pkgcfgdir = $(pkgdatadir)/config.d/
+
+libexecdir= $(pkglibdir)/libexec/
plugindir = $(libdir)/gnunet
pkgcfg_DATA = \
- gns.conf
+ gns.conf \
+ $(DO_W32_HS_CONF)
lib_LTLIBRARIES = \
- libgnunetgns.la
+ $(DO_W32_NSP) \
+ libgnunetgns.la \
+ libgnunetgns_common.la
+
if HAVE_MHD
DO_FCFSD=gnunet-gns-fcfsd
+if HAVE_GNUTLS
DO_PROXY=gnunet-gns-proxy
endif
+endif
+
+libexec_PROGRAMS = \
+ gnunet-service-gns $(DO_FCFSD) \
+ $(DO_PROXY) \
+ $(DO_W32_HELPER) \
+ gnunet-dns2gns
bin_PROGRAMS = \
- gnunet-service-gns \
- $(DO_FCFSD) \
- $(DO_PROXY) \
- gnunet-gns
+ $(DO_W32_NSPTOOLS) \
+ gnunet-gns
+
+bin_SCRIPTS = gnunet-gns-proxy-setup-ca
+
+plugin_LTLIBRARIES = \
+ libgnunet_plugin_block_gns.la
+
+gnunet_gns_SOURCES = \
+ gnunet-gns.c
+gnunet_gns_LDADD = \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(GN_LIBINTL)
+gnunet_gns_DEPENDENCIES = \
+ libgnunetgns.la
+
+gnunet_dns2gns_SOURCES = \
+ gnunet-dns2gns.c
+gnunet_dns2gns_LDADD = \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/dns/libgnunetdnsparser.la \
+ $(top_builddir)/src/dns/libgnunetdnsstub.la \
+ $(GN_LIBINTL)
+gnunet_dns2gns_DEPENDENCIES = \
+ libgnunetgns.la
+
+gnunet_gns_proxy_SOURCES = \
+ gnunet-gns-proxy.c gns_proxy_proto.h
+gnunet_gns_proxy_LDADD = -lmicrohttpd -lcurl -lgnutls \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(GN_LIBINTL)
+gnunet_gns_proxy_DEPENDENCIES = \
+ libgnunetgns.la
+
+gnunet_gns_helper_service_w32_SOURCES = \
+ gnunet-gns-helper-service-w32.c
+gnunet_gns_helper_service_w32_LDADD = \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(GN_LIBINTL)
+gnunet_gns_helper_service_w32_DEPENDENCIES = \
+ libgnunetgns.la
+
+w32nsp_install_SOURCES = \
+ w32nsp-install.c
+w32nsp_install_LDADD = -lws2_32
+
+w32nsp_uninstall_SOURCES = \
+ w32nsp-uninstall.c
+w32nsp_uninstall_LDADD = -lws2_32
+
+w32nsp_resolve_SOURCES = \
+ w32nsp-resolve.c
+w32nsp_resolve_LDADD = -lws2_32
+
+gnunet_service_gns_SOURCES = \
+ gnunet-service-gns.c \
+ gnunet-service-gns_resolver.c gnunet-service-gns_resolver.h \
+ gnunet-service-gns_interceptor.c gnunet-service-gns_interceptor.h
+gnunet_service_gns_LDADD = \
+ -lm \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ libgnunetgns_common.la \
+ $(top_builddir)/src/dns/libgnunetdns.la \
+ $(top_builddir)/src/dns/libgnunetdnsparser.la \
+ $(top_builddir)/src/dht/libgnunetdht.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(USE_VPN) \
+ $(GN_LIBINTL)
+gnunet_service_gns_DEPENDENCIES = \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ libgnunetgns_common.la \
+ $(top_builddir)/src/dns/libgnunetdns.la \
+ $(top_builddir)/src/dns/libgnunetdnsparser.la \
+ $(top_builddir)/src/dht/libgnunetdht.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(USE_VPN)
+
+
+
+gnunet_gns_fcfsd_SOURCES = \
+ gnunet-gns-fcfsd.c
+gnunet_gns_fcfsd_LDADD = -lmicrohttpd \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(GN_LIBINTL)
+gnunet_gns_fcfsd_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la
+
+libw32nsp_la_SOURCES = \
+ w32nsp.c
+libw32nsp_la_LIBADD = \
+ -lole32 -lws2_32
+libw32nsp_la_LDFLAGS = \
+ -export-symbols $(top_srcdir)/src/gns/w32nsp.def \
+ $(GN_LIB_LDFLAGS)
+
+libgnunetgns_la_SOURCES = \
+ gns_api.c gns.h
+libgnunetgns_la_LIBADD = \
+ $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la
+libgnunetgns_la_LDFLAGS = \
+ $(GN_LIB_LDFLAGS)
+libgnunetgns_la_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la
+
+
+libgnunetgns_common_la_SOURCES = \
+ gns_common.c gns_common.h
+libgnunetgns_common_la_LDFLAGS = \
+ $(GN_LIB_LDFLAGS)
+libgnunetgns_common_la_LIBADD = \
+ $(top_builddir)/src/util/libgnunetutil.la
+libgnunetgns_common_la_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+
+libgnunet_plugin_block_gns_la_SOURCES = \
+ plugin_block_gns.c
+libgnunet_plugin_block_gns_la_LIBADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/block/libgnunetblock.la \
+ $(top_builddir)/src/gns/libgnunetgns_common.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la
+libgnunet_plugin_block_gns_la_LDFLAGS = \
+ $(GN_PLUGIN_LDFLAGS)
+libgnunet_plugin_block_gns_la_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ libgnunetgns_common.la \
+ $(top_builddir)/src/block/libgnunetblock.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la
-#noinst_PROGRAMS = \
-# gnunet-gns-lookup
check_PROGRAMS = \
test_gns_simple_shorten \
@@ -44,11 +209,22 @@ check_PROGRAMS = \
test_gns_simple_lookup \
test_gns_simple_delegated_lookup \
test_gns_simple_mx_lookup \
+ test_gns_simple_srv_lookup \
test_gns_simple_zkey_lookup \
test_gns_dht_delegated_lookup \
test_gns_pseu_shorten \
test_gns_max_queries \
- test_gns_dht_threepeer
+ test_gns_cname_lookup \
+ test_gns_ns_lookup \
+ test_gns_revocation \
+ test_gns_dht_three_peers
+ #test_gns_proxy
+
+if ENABLE_TEST_RUN
+if LINUX
+TESTS = $(check_PROGRAMS)
+endif
+endif
# test_gns_simple_lookup
@@ -56,21 +232,33 @@ check_PROGRAMS = \
# test_gns_dht_delegated_lookup
-plugin_LTLIBRARIES = \
- libgnunet_plugin_block_gns.la
-
-test_gns_dht_threepeer_SOURCES = \
- test_gns_dht_threepeer.c
-test_gns_dht_threepeer_LDADD = \
+#test_gns_proxy_SOURCES = \
+# test_gns_proxy.c
+#test_gns_proxy_LDADD = -lmicrohttpd @LIBCURL@ \
+# $(top_builddir)/src/util/libgnunetutil.la \
+# $(top_builddir)/src/namestore/libgnunetnamestore.la \
+# $(top_builddir)/src/gns/libgnunetgns.la \
+# $(top_builddir)/src/testing/libgnunettesting.la
+#test_gns_proxy_DEPENDENCIES = \
+# $(top_builddir)/src/util/libgnunetutil.la \
+# $(top_builddir)/src/namestore/libgnunetnamestore.la \
+# libgnunetgns.la \
+# $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_dht_three_peers_SOURCES = \
+ test_gns_dht_three_peers.c
+test_gns_dht_three_peers_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
$(top_builddir)/src/gns/libgnunetgns.la \
- $(top_builddir)/src/testing/libgnunettesting.la
-test_gns_dht_threepeer_DEPENDENCIES = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/testbed/libgnunettestbed.la
+test_gns_dht_three_peers_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
- $(top_builddir)/src/gns/libgnunetgns.la \
- $(top_builddir)/src/testing/libgnunettesting.la
+ libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/testbed/libgnunettestbed.la
test_gns_simple_lookup_SOURCES = \
test_gns_simple_lookup.c
@@ -82,7 +270,7 @@ test_gns_simple_lookup_LDADD = \
test_gns_simple_lookup_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
- $(top_builddir)/src/gns/libgnunetgns.la \
+ libgnunetgns.la \
$(top_builddir)/src/testing/libgnunettesting.la
test_gns_simple_delegated_lookup_SOURCES = \
@@ -95,7 +283,7 @@ test_gns_simple_delegated_lookup_LDADD = \
test_gns_simple_delegated_lookup_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
- $(top_builddir)/src/gns/libgnunetgns.la \
+ libgnunetgns.la \
$(top_builddir)/src/testing/libgnunettesting.la
test_gns_simple_mx_lookup_SOURCES = \
@@ -108,8 +296,21 @@ test_gns_simple_mx_lookup_LDADD = \
test_gns_simple_mx_lookup_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
+ libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_srv_lookup_SOURCES = \
+ test_gns_simple_srv_lookup.c
+test_gns_simple_srv_lookup_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
$(top_builddir)/src/gns/libgnunetgns.la \
$(top_builddir)/src/testing/libgnunettesting.la
+test_gns_simple_srv_lookup_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
test_gns_simple_zkey_lookup_SOURCES = \
test_gns_simple_zkey_lookup.c
@@ -121,7 +322,7 @@ test_gns_simple_zkey_lookup_LDADD = \
test_gns_simple_zkey_lookup_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
- $(top_builddir)/src/gns/libgnunetgns.la \
+ libgnunetgns.la \
$(top_builddir)/src/testing/libgnunettesting.la
test_gns_dht_delegated_lookup_SOURCES = \
@@ -136,7 +337,7 @@ test_gns_dht_delegated_lookup_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
$(top_builddir)/src/dht/libgnunetdht.la \
- $(top_builddir)/src/gns/libgnunetgns.la \
+ libgnunetgns.la \
$(top_builddir)/src/testing/libgnunettesting.la
test_gns_simple_shorten_SOURCES = \
@@ -149,7 +350,7 @@ test_gns_simple_shorten_LDADD = \
test_gns_simple_shorten_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
- $(top_builddir)/src/gns/libgnunetgns.la \
+ libgnunetgns.la \
$(top_builddir)/src/testing/libgnunettesting.la
test_gns_simple_get_authority_SOURCES = \
@@ -162,7 +363,7 @@ test_gns_simple_get_authority_LDADD = \
test_gns_simple_get_authority_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
- $(top_builddir)/src/gns/libgnunetgns.la \
+ libgnunetgns.la \
$(top_builddir)/src/testing/libgnunettesting.la
@@ -178,7 +379,7 @@ test_gns_pseu_shorten_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
$(top_builddir)/src/dht/libgnunetdht.la \
- $(top_builddir)/src/gns/libgnunetgns.la \
+ libgnunetgns.la \
$(top_builddir)/src/testing/libgnunettesting.la
@@ -192,83 +393,51 @@ test_gns_max_queries_LDADD = \
test_gns_max_queries_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
- $(top_builddir)/src/gns/libgnunetgns.la \
+ libgnunetgns.la \
$(top_builddir)/src/testing/libgnunettesting.la
-gnunet_gns_SOURCES = \
- gnunet-gns.c
-gnunet_gns_LDADD = \
- $(top_builddir)/src/gns/libgnunetgns.la \
+test_gns_cname_lookup_SOURCES = \
+ test_gns_cname_lookup.c
+test_gns_cname_lookup_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
- $(GN_LIBINTL)
-gnunet_gns_DEPENDENCIES = \
- libgnunetgns.la
-
-gnunet_gns_proxy_SOURCES = \
- gnunet-gns-proxy.c gns_proxy_proto.h
-gnunet_gns_proxy_LDADD = -lmicrohttpd \
$(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+test_gns_cname_lookup_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
- $(GN_LIBINTL)
-gnunet_gns_proxy_DEPENDENCIES = \
- libgnunetgns.la
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
-gnunet_service_gns_SOURCES = \
- gnunet-service-gns.c \
- gnunet-service-gns_resolver.c gnunet-service-gns_resolver.h \
- gnunet-service-gns_interceptor.c gnunet-service-gns_interceptor.h
-gnunet_service_gns_LDADD = \
- $(top_builddir)/src/statistics/libgnunetstatistics.la \
+
+test_gns_ns_lookup_SOURCES = \
+ test_gns_ns_lookup.c
+test_gns_ns_lookup_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/dns/libgnunetdns.la \
- $(top_builddir)/src/dns/libgnunetdnsparser.la \
- $(top_builddir)/src/dht/libgnunetdht.la \
- $(top_builddir)/src/namestore/libgnunetnamestore.la \
- $(GN_LIBINTL)
-gnunet_service_gns_DEPENDENCIES = \
- $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+test_gns_ns_lookup_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/dns/libgnunetdns.la \
- $(top_builddir)/src/dns/libgnunetdnsparser.la \
- $(top_builddir)/src/dht/libgnunetdht.la \
- $(top_builddir)/src/namestore/libgnunetnamestore.la
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
-gnunet_gns_fcfsd_SOURCES = \
- gnunet-gns-fcfsd.c
-gnunet_gns_fcfsd_LDADD = -lmicrohttpd \
+test_gns_revocation_SOURCES = \
+ test_gns_revocation.c
+test_gns_revocation_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/namestore/libgnunetnamestore.la \
- $(GN_LIBINTL)
-gnunet_gns_fcfsd_DEPENDENCIES = \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+test_gns_revocation_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/namestore/libgnunetnamestore.la
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
-libgnunetgns_la_SOURCES = \
- gns_api.c gns.h
-libgnunetgns_la_LIBADD = \
- $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
- $(top_builddir)/src/namestore/libgnunetnamestore.la
-libgnunetgns_la_LDFLAGS = \
- $(GN_LIB_LDFLAGS)
-libgnunetgns_la_DEPENDENCIES = \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/namestore/libgnunetnamestore.la
-
-libgnunet_plugin_block_gns_la_SOURCES = \
- plugin_block_gns.c
-libgnunet_plugin_block_gns_la_LIBADD = \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/block/libgnunetblock.la \
- $(top_builddir)/src/namestore/libgnunetnamestore.la
-libgnunet_plugin_block_gns_la_LDFLAGS = \
- $(GN_PLUGIN_LDFLAGS)
-libgnunet_plugin_block_gns_la_DEPENDENCIES = \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/block/libgnunetblock.la \
- $(top_builddir)/src/namestore/libgnunetnamestore.la
#Build stub api
#libgnunetnamestore_la_SOURCES = \
@@ -280,14 +449,5 @@ libgnunet_plugin_block_gns_la_DEPENDENCIES = \
#libgnunetnamestore_la_DEPENDENCIES = \
# $(top_builddir)/src/util/libgnunetutil.la
-if ENABLE_TEST_RUN
-if LINUX
-TESTS = $(check_PROGRAMS)
-endif
-endif
-EXTRA_DIST = \
- test_gns_defaults.conf \
- test_gns_simple_lookup.conf \
- test_gns_dht_default.conf