aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am83
1 files changed, 77 insertions, 6 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index e7bccbc..57639fa 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -4,6 +4,8 @@ plugindir = $(libdir)/gnunet
pkgcfgdir= $(pkgdatadir)/config.d/
+libexecdir= $(pkglibdir)/libexec/
+
pkgcfg_DATA = \
datastore.conf
@@ -31,7 +33,7 @@ libgnunetdatastore_la_LDFLAGS = \
-version-info 1:0:0
-bin_PROGRAMS = \
+libexec_PROGRAMS = \
gnunet-service-datastore
gnunet_service_datastore_SOURCES = \
@@ -85,6 +87,7 @@ plugin_LTLIBRARIES = \
$(SQLITE_PLUGIN) \
$(MYSQL_PLUGIN) \
$(POSTGRES_PLUGIN) \
+ libgnunet_plugin_datastore_heap.la \
libgnunet_plugin_datastore_template.la
@@ -92,11 +95,21 @@ libgnunet_plugin_datastore_sqlite_la_SOURCES = \
plugin_datastore_sqlite.c
libgnunet_plugin_datastore_sqlite_la_LIBADD = \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
- $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3
+ $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
+ $(LTLIBINTL)
libgnunet_plugin_datastore_sqlite_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
+libgnunet_plugin_datastore_heap_la_SOURCES = \
+ plugin_datastore_heap.c
+libgnunet_plugin_datastore_heap_la_LIBADD = \
+ $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
+ $(LTLIBINTL)
+libgnunet_plugin_datastore_heap_la_LDFLAGS = \
+ $(GN_PLUGIN_LDFLAGS)
+
+
libgnunet_plugin_datastore_mysql_la_SOURCES = \
plugin_datastore_mysql.c
libgnunet_plugin_datastore_mysql_la_LIBADD = \
@@ -123,11 +136,17 @@ libgnunet_plugin_datastore_postgres_la_CPPFLAGS = \
libgnunet_plugin_datastore_template_la_SOURCES = \
plugin_datastore_template.c
libgnunet_plugin_datastore_template_la_LIBADD = \
- $(top_builddir)/src/util/libgnunetutil.la $(XLIBS)
+ $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
+ $(LTLIBINTL)
libgnunet_plugin_datastore_template_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
check_PROGRAMS = \
+ test_datastore_api_heap \
+ test_datastore_api_management_heap \
+ perf_datastore_api_heap \
+ perf_plugin_datastore_heap \
+ test_plugin_datastore_heap \
$(SQLITE_TESTS) \
$(MYSQL_TESTS) \
$(POSTGRES_TESTS)
@@ -136,90 +155,139 @@ if ENABLE_TEST_RUN
TESTS = $(check_PROGRAMS)
endif
+test_datastore_api_heap_SOURCES = \
+ test_datastore_api.c
+test_datastore_api_heap_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/datastore/libgnunetdatastore.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+test_datastore_api_management_heap_SOURCES = \
+ test_datastore_api_management.c
+test_datastore_api_management_heap_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/datastore/libgnunetdatastore.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+perf_datastore_api_heap_SOURCES = \
+ perf_datastore_api.c
+perf_datastore_api_heap_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/datastore/libgnunetdatastore.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+perf_plugin_datastore_heap_SOURCES = \
+ perf_plugin_datastore.c
+perf_plugin_datastore_heap_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+test_plugin_datastore_heap_SOURCES = \
+ test_plugin_datastore.c
+test_plugin_datastore_heap_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+
test_datastore_api_sqlite_SOURCES = \
test_datastore_api.c
test_datastore_api_sqlite_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datastore/libgnunetdatastore.la \
$(top_builddir)/src/util/libgnunetutil.la
test_datastore_api_management_sqlite_SOURCES = \
test_datastore_api_management.c
test_datastore_api_management_sqlite_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datastore/libgnunetdatastore.la \
$(top_builddir)/src/util/libgnunetutil.la
perf_datastore_api_sqlite_SOURCES = \
perf_datastore_api.c
perf_datastore_api_sqlite_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datastore/libgnunetdatastore.la \
$(top_builddir)/src/util/libgnunetutil.la
perf_plugin_datastore_sqlite_SOURCES = \
perf_plugin_datastore.c
perf_plugin_datastore_sqlite_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la
test_plugin_datastore_sqlite_SOURCES = \
test_plugin_datastore.c
test_plugin_datastore_sqlite_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la
test_datastore_api_mysql_SOURCES = \
test_datastore_api.c
test_datastore_api_mysql_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datastore/libgnunetdatastore.la \
$(top_builddir)/src/util/libgnunetutil.la
test_datastore_api_management_mysql_SOURCES = \
test_datastore_api_management.c
test_datastore_api_management_mysql_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datastore/libgnunetdatastore.la \
$(top_builddir)/src/util/libgnunetutil.la
perf_datastore_api_mysql_SOURCES = \
perf_datastore_api.c
perf_datastore_api_mysql_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datastore/libgnunetdatastore.la \
$(top_builddir)/src/util/libgnunetutil.la
test_plugin_datastore_mysql_SOURCES = \
test_plugin_datastore.c
test_plugin_datastore_mysql_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la
perf_plugin_datastore_mysql_SOURCES = \
perf_plugin_datastore.c
perf_plugin_datastore_mysql_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la
test_datastore_api_postgres_SOURCES = \
test_datastore_api.c
test_datastore_api_postgres_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datastore/libgnunetdatastore.la \
$(top_builddir)/src/util/libgnunetutil.la
test_datastore_api_management_postgres_SOURCES = \
test_datastore_api_management.c
test_datastore_api_management_postgres_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datastore/libgnunetdatastore.la \
$(top_builddir)/src/util/libgnunetutil.la
perf_datastore_api_postgres_SOURCES = \
perf_datastore_api.c
perf_datastore_api_postgres_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datastore/libgnunetdatastore.la \
$(top_builddir)/src/util/libgnunetutil.la
test_plugin_datastore_postgres_SOURCES = \
test_plugin_datastore.c
test_plugin_datastore_postgres_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la
perf_plugin_datastore_postgres_SOURCES = \
perf_plugin_datastore.c
perf_plugin_datastore_postgres_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/util/libgnunetutil.la
@@ -227,10 +295,13 @@ EXTRA_DIST = \
test_defaults.conf \
test_datastore_api_data_sqlite.conf \
perf_plugin_datastore_data_sqlite.conf \
+ test_plugin_datastore_data_sqlite.conf \
+ test_datastore_api_data_heap.conf \
+ perf_plugin_datastore_data_heap.conf \
+ test_plugin_datastore_data_heap.conf \
test_datastore_api_data_mysql.conf \
perf_plugin_datastore_data_mysql.conf \
+ test_plugin_datastore_data_mysql.conf \
test_datastore_api_data_postgres.conf \
perf_plugin_datastore_data_postgres.conf \
- test_plugin_datastore_data_mysql.conf \
- test_plugin_datastore_data_postgres.conf \
- test_plugin_datastore_data_sqlite.conf \ No newline at end of file
+ test_plugin_datastore_data_postgres.conf