aboutsummaryrefslogtreecommitdiff
path: root/src/datacache/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/datacache/Makefile.am')
-rw-r--r--src/datacache/Makefile.am69
1 files changed, 36 insertions, 33 deletions
diff --git a/src/datacache/Makefile.am b/src/datacache/Makefile.am
index d34e6e8..c6c27b3 100644
--- a/src/datacache/Makefile.am
+++ b/src/datacache/Makefile.am
@@ -19,9 +19,6 @@ endif
if HAVE_SQLITE
SQLITE_PLUGIN = libgnunet_plugin_datacache_sqlite.la
endif
-if HAVE_MYSQL
- MYSQL_PLUGIN = libgnunet_plugin_datacache_mysql.la
-endif
if HAVE_POSTGRES
POSTGRES_PLUGIN = libgnunet_plugin_datacache_postgres.la
endif
@@ -42,8 +39,8 @@ libgnunetdatacache_la_LDFLAGS = \
plugin_LTLIBRARIES = \
$(SQLITE_PLUGIN) \
- $(MYSQL_PLUGIN) \
$(POSTGRES_PLUGIN) \
+ libgnunet_plugin_datacache_heap.la \
libgnunet_plugin_datacache_template.la
@@ -51,21 +48,19 @@ libgnunet_plugin_datacache_sqlite_la_SOURCES = \
plugin_datacache_sqlite.c
libgnunet_plugin_datacache_sqlite_la_LIBADD = \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
- $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3
+ $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
+ $(LTLIBINTL)
libgnunet_plugin_datacache_sqlite_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
-libgnunet_plugin_datacache_mysql_la_SOURCES = \
- plugin_datacache_mysql.c
-libgnunet_plugin_datacache_mysql_la_LIBADD = \
+libgnunet_plugin_datacache_heap_la_SOURCES = \
+ plugin_datacache_heap.c
+libgnunet_plugin_datacache_heap_la_LIBADD = \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
- $(top_builddir)/src/mysql/libgnunetmysql.la \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(GN_PLUGIN_LDFLAGS) $(MYSQL_LDFLAGS) -lmysqlclient
-libgnunet_plugin_datacache_mysql_la_CPPFLAGS = \
- $(MYSQL_CPPFLAGS)
-libgnunet_plugin_datacache_mysql_la_LDFLAGS = \
- $(GN_PLUGIN_LDFLAGS) $(MYSQL_LDFLAGS) -lmysqlclient
+ $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
+ $(LTLIBINTL)
+libgnunet_plugin_datacache_heap_la_LDFLAGS = \
+ $(GN_PLUGIN_LDFLAGS)
libgnunet_plugin_datacache_postgres_la_SOURCES = \
plugin_datacache_postgres.c
@@ -82,7 +77,8 @@ libgnunet_plugin_datacache_postgres_la_LDFLAGS = \
libgnunet_plugin_datacache_template_la_SOURCES = \
plugin_datacache_template.c
libgnunet_plugin_datacache_template_la_LIBADD = \
- $(top_builddir)/src/util/libgnunetutil.la $(XLIBS)
+ $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
+ $(LTLIBINTL)
libgnunet_plugin_datacache_template_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
@@ -98,16 +94,14 @@ SQLITE_TESTS = \
$(SQLITE_BENCHMARKS)
endif
-if HAVE_MYSQL
if HAVE_BENCHMARKS
- MYSQL_BENCHMARKS = \
- perf_datacache_mysql
-endif
-MYSQL_TESTS = \
- test_datacache_mysql \
- test_datacache_quota_mysql \
- $(MYSQL_BENCHMARKS)
+ HEAP_BENCHMARKS = \
+ perf_datacache_heap
endif
+HEAP_TESTS = \
+ test_datacache_heap \
+ test_datacache_quota_heap \
+ $(HEAP_BENCHMARKS)
if HAVE_POSTGRES
if HAVE_BENCHMARKS
@@ -122,7 +116,7 @@ endif
check_PROGRAMS = \
$(SQLITE_TESTS) \
- $(MYSQL_TESTS) \
+ $(HEAP_TESTS) \
$(POSTGRES_TESTS)
if ENABLE_TEST_RUN
@@ -132,61 +126,70 @@ endif
test_datacache_sqlite_SOURCES = \
test_datacache.c
test_datacache_sqlite_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datacache/libgnunetdatacache.la \
$(top_builddir)/src/util/libgnunetutil.la
test_datacache_quota_sqlite_SOURCES = \
test_datacache_quota.c
test_datacache_quota_sqlite_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datacache/libgnunetdatacache.la \
$(top_builddir)/src/util/libgnunetutil.la
perf_datacache_sqlite_SOURCES = \
perf_datacache.c
perf_datacache_sqlite_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datacache/libgnunetdatacache.la \
$(top_builddir)/src/util/libgnunetutil.la
-test_datacache_mysql_SOURCES = \
+test_datacache_heap_SOURCES = \
test_datacache.c
-test_datacache_mysql_LDADD = \
+test_datacache_heap_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datacache/libgnunetdatacache.la \
$(top_builddir)/src/util/libgnunetutil.la
-test_datacache_quota_mysql_SOURCES = \
+test_datacache_quota_heap_SOURCES = \
test_datacache_quota.c
-test_datacache_quota_mysql_LDADD = \
+test_datacache_quota_heap_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datacache/libgnunetdatacache.la \
$(top_builddir)/src/util/libgnunetutil.la
-perf_datacache_mysql_SOURCES = \
+perf_datacache_heap_SOURCES = \
perf_datacache.c
-perf_datacache_mysql_LDADD = \
+perf_datacache_heap_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datacache/libgnunetdatacache.la \
$(top_builddir)/src/util/libgnunetutil.la
test_datacache_postgres_SOURCES = \
test_datacache.c
test_datacache_postgres_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datacache/libgnunetdatacache.la \
$(top_builddir)/src/util/libgnunetutil.la
test_datacache_quota_postgres_SOURCES = \
test_datacache_quota.c
test_datacache_quota_postgres_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datacache/libgnunetdatacache.la \
$(top_builddir)/src/util/libgnunetutil.la
perf_datacache_postgres_SOURCES = \
perf_datacache.c
perf_datacache_postgres_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/datacache/libgnunetdatacache.la \
$(top_builddir)/src/util/libgnunetutil.la
EXTRA_DIST = \
test_datacache_data_sqlite.conf \
perf_datacache_data_sqlite.conf \
- test_datacache_data_mysql.conf \
- perf_datacache_data_mysql.conf \
+ test_datacache_data_heap.conf \
+ perf_datacache_data_heap.conf \
test_datacache_data_postgres.conf \
perf_datacache_data_postgres.conf