aboutsummaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
index e95cbcf..6d073da 100644
--- a/src/core/Makefile.am
+++ b/src/core/Makefile.am
@@ -2,6 +2,8 @@ INCLUDES = -I$(top_srcdir)/src/include
pkgcfgdir= $(pkgdatadir)/config.d/
+libexecdir= $(pkglibdir)/libexec/
+
pkgcfg_DATA = \
core.conf
@@ -27,11 +29,13 @@ libgnunetcore_la_LIBADD = \
$(GN_LIBINTL) $(XLIB)
libgnunetcore_la_LDFLAGS = \
$(GN_LIB_LDFLAGS) $(WINFLAGS) \
- -version-info 0:0:0
+ -version-info 0:1:0
+
+libexec_PROGRAMS = \
+ gnunet-service-core
bin_PROGRAMS = \
- gnunet-service-core \
gnunet-core
gnunet_service_core_SOURCES = \
@@ -89,12 +93,14 @@ test_core_api_send_to_self_SOURCES = \
test_core_api_send_to_self.c
test_core_api_send_to_self_LDADD = \
$(top_builddir)/src/core/libgnunetcore.la \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/util/libgnunetutil.la
test_core_api_start_only_SOURCES = \
test_core_api_start_only.c
test_core_api_start_only_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/core/libgnunetcore.la \
$(top_builddir)/src/util/libgnunetutil.la