aboutsummaryrefslogtreecommitdiff
path: root/src/ats-tool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/ats-tool/Makefile.am')
-rw-r--r--src/ats-tool/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/ats-tool/Makefile.am b/src/ats-tool/Makefile.am
new file mode 100644
index 0000000..c633a20
--- /dev/null
+++ b/src/ats-tool/Makefile.am
@@ -0,0 +1,21 @@
+INCLUDES = -I$(top_srcdir)/src/include
+
+if MINGW
+ WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
+endif
+
+if USE_COVERAGE
+ AM_CFLAGS = -fprofile-arcs -ftest-coverage
+endif
+
+bin_PROGRAMS = \
+ gnunet-ats
+
+gnunet_ats_SOURCES = \
+ gnunet-ats.c
+gnunet_ats_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/ats/libgnunetats.la \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(GN_LIBINTL)