aboutsummaryrefslogtreecommitdiff
path: root/contrib
diff options
context:
space:
mode:
Diffstat (limited to 'contrib')
-rw-r--r--contrib/Makefile.am10
-rw-r--r--contrib/Makefile.in148
-rwxr-xr-xcontrib/coverage.sh2
-rw-r--r--contrib/gnunet_janitor.py.in8
-rw-r--r--contrib/hostlist.cgi5
-rw-r--r--contrib/hostlist.php35
-rw-r--r--contrib/pydiffer.py.in39
-rwxr-xr-xcontrib/report.sh62
-rw-r--r--contrib/terminate.py.in64
-rw-r--r--contrib/testing_hostkeys.eccbin0 -> 8388608 bytes
10 files changed, 266 insertions, 107 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 0d65393..e287696 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -13,6 +13,8 @@ timeout_watchdog_SOURCES = \
endif
noinst_SCRIPTS = \
+ terminate.py \
+ pydiffer.py \
gnunet_pyexpect.py \
gnunet_janitor.py
@@ -21,15 +23,16 @@ bin_SCRIPTS = \
dist_pkgdata_DATA = \
gnunet-logo-color.png \
- testing_hostkeys.dat
+ testing_hostkeys.dat \
+ testing_hostkeys.ecc
EXTRA_DIST = \
coverage.sh \
- hostlist.cgi \
- hostlist.php \
report.sh \
+ terminate.py.in \
gnunet_pyexpect.py.in \
gnunet_janitor.py.in \
+ pydiffer.py.in \
gnunet-gns-import.sh
do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
@@ -56,6 +59,7 @@ test_gnunet_prefix_SOURCES = \
test_gnunet_prefix_LDADD = \
$(GCLIBADD) $(WINLIB) \
$(LTLIBICONV) \
+ $(GN_LIBINTL) \
-lltdl -lunistring $(XLIB)
pkghellodir= $(pkgdatadir)/hellos
diff --git a/contrib/Makefile.in b/contrib/Makefile.in
index 80134e5..3869ee8 100644
--- a/contrib/Makefile.in
+++ b/contrib/Makefile.in
@@ -1,9 +1,9 @@
-# Makefile.in generated by automake 1.11.1 from Makefile.am.
+# Makefile.in generated by automake 1.11.6 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation,
-# Inc.
+# 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free Software
+# Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -18,6 +18,23 @@
VPATH = @srcdir@
+am__make_dryrun = \
+ { \
+ am__dry=no; \
+ case $$MAKEFLAGS in \
+ *\\[\ \ ]*) \
+ echo 'am--echo: ; @echo "AM" OK' | $(MAKE) -f - 2>/dev/null \
+ | grep '^AM OK$$' >/dev/null || am__dry=yes;; \
+ *) \
+ for am__flg in $$MAKEFLAGS; do \
+ case $$am__flg in \
+ *=*|--*) ;; \
+ *n*) am__dry=yes; break;; \
+ esac; \
+ done;; \
+ esac; \
+ test $$am__dry = yes; \
+ }
pkgdatadir = $(datadir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
@@ -45,14 +62,15 @@ DIST_COMMON = $(dist_pkgdata_DATA) $(srcdir)/Makefile.am \
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/absolute-header.m4 \
$(top_srcdir)/m4/align.m4 $(top_srcdir)/m4/argz.m4 \
- $(top_srcdir)/m4/gettext.m4 $(top_srcdir)/m4/iconv.m4 \
- $(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
- $(top_srcdir)/m4/lib-prefix.m4 $(top_srcdir)/m4/libcurl.m4 \
- $(top_srcdir)/m4/libgcrypt.m4 $(top_srcdir)/m4/libtool.m4 \
- $(top_srcdir)/m4/libunistring.m4 $(top_srcdir)/m4/ltdl.m4 \
- $(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
- $(top_srcdir)/m4/ltversion.m4 $(top_srcdir)/m4/lt~obsolete.m4 \
- $(top_srcdir)/m4/nls.m4 $(top_srcdir)/m4/po.m4 \
+ $(top_srcdir)/m4/gettext.m4 $(top_srcdir)/m4/glib-2.0.m4 \
+ $(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/lib-ld.m4 \
+ $(top_srcdir)/m4/lib-link.m4 $(top_srcdir)/m4/lib-prefix.m4 \
+ $(top_srcdir)/m4/libcurl.m4 $(top_srcdir)/m4/libgcrypt.m4 \
+ $(top_srcdir)/m4/libtool.m4 $(top_srcdir)/m4/libunistring.m4 \
+ $(top_srcdir)/m4/ltdl.m4 $(top_srcdir)/m4/ltoptions.m4 \
+ $(top_srcdir)/m4/ltsugar.m4 $(top_srcdir)/m4/ltversion.m4 \
+ $(top_srcdir)/m4/lt~obsolete.m4 $(top_srcdir)/m4/nls.m4 \
+ $(top_srcdir)/m4/pkg.m4 $(top_srcdir)/m4/po.m4 \
$(top_srcdir)/m4/progtest.m4 $(top_srcdir)/acinclude.m4 \
$(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
@@ -65,9 +83,10 @@ PROGRAMS = $(noinst_PROGRAMS)
am_test_gnunet_prefix_OBJECTS = test_gnunet_prefix.$(OBJEXT)
test_gnunet_prefix_OBJECTS = $(am_test_gnunet_prefix_OBJECTS)
am__DEPENDENCIES_1 =
-test_gnunet_prefix_DEPENDENCIES = $(am__DEPENDENCIES_1)
-AM_V_lt = $(am__v_lt_$(V))
-am__v_lt_ = $(am__v_lt_$(AM_DEFAULT_VERBOSITY))
+test_gnunet_prefix_DEPENDENCIES = $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1)
+AM_V_lt = $(am__v_lt_@AM_V@)
+am__v_lt_ = $(am__v_lt_@AM_DEFAULT_V@)
am__v_lt_0 = --silent
am__timeout_watchdog_SOURCES_DIST = timeout_watchdog.c \
timeout_watchdog_w32.c
@@ -97,6 +116,12 @@ am__nobase_list = $(am__nobase_strip_setup); \
am__base_list = \
sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
+am__uninstall_files_from_dir = { \
+ test -z "$$files" \
+ || { test ! -d "$$dir" && test ! -f "$$dir" && test ! -r "$$dir"; } \
+ || { echo " ( cd '$$dir' && rm -f" $$files ")"; \
+ $(am__cd) "$$dir" && rm -f $$files; }; \
+ }
am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgdatadir)"
SCRIPTS = $(bin_SCRIPTS) $(noinst_SCRIPTS)
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
@@ -109,25 +134,30 @@ LTCOMPILE = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) \
$(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
$(AM_CFLAGS) $(CFLAGS)
-AM_V_CC = $(am__v_CC_$(V))
-am__v_CC_ = $(am__v_CC_$(AM_DEFAULT_VERBOSITY))
+AM_V_CC = $(am__v_CC_@AM_V@)
+am__v_CC_ = $(am__v_CC_@AM_DEFAULT_V@)
am__v_CC_0 = @echo " CC " $@;
-AM_V_at = $(am__v_at_$(V))
-am__v_at_ = $(am__v_at_$(AM_DEFAULT_VERBOSITY))
+AM_V_at = $(am__v_at_@AM_V@)
+am__v_at_ = $(am__v_at_@AM_DEFAULT_V@)
am__v_at_0 = @
CCLD = $(CC)
LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
-AM_V_CCLD = $(am__v_CCLD_$(V))
-am__v_CCLD_ = $(am__v_CCLD_$(AM_DEFAULT_VERBOSITY))
+AM_V_CCLD = $(am__v_CCLD_@AM_V@)
+am__v_CCLD_ = $(am__v_CCLD_@AM_DEFAULT_V@)
am__v_CCLD_0 = @echo " CCLD " $@;
-AM_V_GEN = $(am__v_GEN_$(V))
-am__v_GEN_ = $(am__v_GEN_$(AM_DEFAULT_VERBOSITY))
+AM_V_GEN = $(am__v_GEN_@AM_V@)
+am__v_GEN_ = $(am__v_GEN_@AM_DEFAULT_V@)
am__v_GEN_0 = @echo " GEN " $@;
SOURCES = $(test_gnunet_prefix_SOURCES) $(timeout_watchdog_SOURCES)
DIST_SOURCES = $(test_gnunet_prefix_SOURCES) \
$(am__timeout_watchdog_SOURCES_DIST)
+am__can_run_installinfo = \
+ case $$AM_UPDATE_INFO_DIR in \
+ n|no|NO) false;; \
+ *) (install-info --version) >/dev/null 2>&1;; \
+ esac
DATA = $(dist_pkgdata_DATA)
ETAGS = etags
CTAGS = ctags
@@ -167,6 +197,10 @@ EXEEXT = @EXEEXT@
EXT_LIBS = @EXT_LIBS@
EXT_LIB_PATH = @EXT_LIB_PATH@
FGREP = @FGREP@
+GLIB_CFLAGS = @GLIB_CFLAGS@
+GLIB_GENMARSHAL = @GLIB_GENMARSHAL@
+GLIB_LIBS = @GLIB_LIBS@
+GLIB_MKENUMS = @GLIB_MKENUMS@
GMSGFMT = @GMSGFMT@
GMSGFMT_015 = @GMSGFMT_015@
GNUNETDNS_GROUP = @GNUNETDNS_GROUP@
@@ -177,6 +211,7 @@ GN_LIBINTL = @GN_LIBINTL@
GN_LIB_LDFLAGS = @GN_LIB_LDFLAGS@
GN_PLUGIN_LDFLAGS = @GN_PLUGIN_LDFLAGS@
GN_USER_HOME_DIR = @GN_USER_HOME_DIR@
+GOBJECT_QUERY = @GOBJECT_QUERY@
GREP = @GREP@
HAVE_LIBUNISTRING = @HAVE_LIBUNISTRING@
INCLTDL = @INCLTDL@
@@ -199,6 +234,8 @@ LIBCURL_CPPFLAGS = @LIBCURL_CPPFLAGS@
LIBGCRYPT_CFLAGS = @LIBGCRYPT_CFLAGS@
LIBGCRYPT_CONFIG = @LIBGCRYPT_CONFIG@
LIBGCRYPT_LIBS = @LIBGCRYPT_LIBS@
+LIBGTOP_CFLAGS = @LIBGTOP_CFLAGS@
+LIBGTOP_LIBS = @LIBGTOP_LIBS@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
LIBLTDL = @LIBLTDL@
@@ -220,6 +257,7 @@ LT_CONFIG_H = @LT_CONFIG_H@
LT_DLLOADERS = @LT_DLLOADERS@
LT_DLPREOPEN = @LT_DLPREOPEN@
MAKEINFO = @MAKEINFO@
+MANIFEST_TOOL = @MANIFEST_TOOL@
MKDIR_P = @MKDIR_P@
MONKEYPREFIX = @MONKEYPREFIX@
MSGFMT = @MSGFMT@
@@ -229,6 +267,7 @@ MYSQL_CPPFLAGS = @MYSQL_CPPFLAGS@
MYSQL_LDFLAGS = @MYSQL_LDFLAGS@
NM = @NM@
NMEDIT = @NMEDIT@
+NSS_DIR = @NSS_DIR@
OBJC = @OBJC@
OBJCDEPMODE = @OBJCDEPMODE@
OBJCFLAGS = @OBJCFLAGS@
@@ -244,6 +283,7 @@ PACKAGE_TARNAME = @PACKAGE_TARNAME@
PACKAGE_URL = @PACKAGE_URL@
PACKAGE_VERSION = @PACKAGE_VERSION@
PATH_SEPARATOR = @PATH_SEPARATOR@
+PKG_CONFIG = @PKG_CONFIG@
POSTGRES_CPPFLAGS = @POSTGRES_CPPFLAGS@
POSTGRES_LDFLAGS = @POSTGRES_LDFLAGS@
POSUB = @POSUB@
@@ -275,6 +315,7 @@ abs_builddir = @abs_builddir@
abs_srcdir = @abs_srcdir@
abs_top_builddir = @abs_top_builddir@
abs_top_srcdir = @abs_top_srcdir@
+ac_ct_AR = @ac_ct_AR@
ac_ct_CC = @ac_ct_CC@
ac_ct_CXX = @ac_ct_CXX@
ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
@@ -297,6 +338,7 @@ datarootdir = @datarootdir@
docdir = @docdir@
dvidir = @dvidir@
exec_prefix = @exec_prefix@
+gitcommand = @gitcommand@
host = @host@
host_alias = @host_alias@
host_cpu = @host_cpu@
@@ -310,7 +352,6 @@ libdir = @libdir@
libexecdir = @libexecdir@
localedir = @localedir@
localstatedir = @localstatedir@
-lt_ECHO = @lt_ECHO@
ltdl_LIBOBJS = @ltdl_LIBOBJS@
ltdl_LTLIBOBJS = @ltdl_LTLIBOBJS@
mandir = @mandir@
@@ -328,6 +369,7 @@ sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
srcdir = @srcdir@
subdirs = @subdirs@
+svnversioncommand = @svnversioncommand@
sys_symbol_underscore = @sys_symbol_underscore@
sysconfdir = @sysconfdir@
target = @target@
@@ -346,6 +388,8 @@ INCLUDES = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include
@MINGW_TRUE@ timeout_watchdog_w32.c
noinst_SCRIPTS = \
+ terminate.py \
+ pydiffer.py \
gnunet_pyexpect.py \
gnunet_janitor.py
@@ -354,15 +398,16 @@ bin_SCRIPTS = \
dist_pkgdata_DATA = \
gnunet-logo-color.png \
- testing_hostkeys.dat
+ testing_hostkeys.dat \
+ testing_hostkeys.ecc
EXTRA_DIST = \
coverage.sh \
- hostlist.cgi \
- hostlist.php \
report.sh \
+ terminate.py.in \
gnunet_pyexpect.py.in \
gnunet_janitor.py.in \
+ pydiffer.py.in \
gnunet-gns-import.sh
do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
@@ -372,6 +417,7 @@ test_gnunet_prefix_SOURCES = \
test_gnunet_prefix_LDADD = \
$(GCLIBADD) $(WINLIB) \
$(LTLIBICONV) \
+ $(GN_LIBINTL) \
-lltdl -lunistring $(XLIB)
pkghellodir = $(pkgdatadir)/hellos
@@ -427,16 +473,19 @@ clean-noinstPROGRAMS:
list=`for p in $$list; do echo "$$p"; done | sed 's/$(EXEEXT)$$//'`; \
echo " rm -f" $$list; \
rm -f $$list
-test_gnunet_prefix$(EXEEXT): $(test_gnunet_prefix_OBJECTS) $(test_gnunet_prefix_DEPENDENCIES)
+test_gnunet_prefix$(EXEEXT): $(test_gnunet_prefix_OBJECTS) $(test_gnunet_prefix_DEPENDENCIES) $(EXTRA_test_gnunet_prefix_DEPENDENCIES)
@rm -f test_gnunet_prefix$(EXEEXT)
$(AM_V_CCLD)$(LINK) $(test_gnunet_prefix_OBJECTS) $(test_gnunet_prefix_LDADD) $(LIBS)
-timeout_watchdog$(EXEEXT): $(timeout_watchdog_OBJECTS) $(timeout_watchdog_DEPENDENCIES)
+timeout_watchdog$(EXEEXT): $(timeout_watchdog_OBJECTS) $(timeout_watchdog_DEPENDENCIES) $(EXTRA_timeout_watchdog_DEPENDENCIES)
@rm -f timeout_watchdog$(EXEEXT)
$(AM_V_CCLD)$(LINK) $(timeout_watchdog_OBJECTS) $(timeout_watchdog_LDADD) $(LIBS)
install-binSCRIPTS: $(bin_SCRIPTS)
@$(NORMAL_INSTALL)
- test -z "$(bindir)" || $(MKDIR_P) "$(DESTDIR)$(bindir)"
@list='$(bin_SCRIPTS)'; test -n "$(bindir)" || list=; \
+ if test -n "$$list"; then \
+ echo " $(MKDIR_P) '$(DESTDIR)$(bindir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(bindir)" || exit 1; \
+ fi; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
if test -f "$$d$$p"; then echo "$$d$$p"; echo "$$p"; else :; fi; \
@@ -464,9 +513,7 @@ uninstall-binSCRIPTS:
@list='$(bin_SCRIPTS)'; test -n "$(bindir)" || exit 0; \
files=`for p in $$list; do echo "$$p"; done | \
sed -e 's,.*/,,;$(transform)'`; \
- test -n "$$list" || exit 0; \
- echo " ( cd '$(DESTDIR)$(bindir)' && rm -f" $$files ")"; \
- cd "$(DESTDIR)$(bindir)" && rm -f $$files
+ dir='$(DESTDIR)$(bindir)'; $(am__uninstall_files_from_dir)
mostlyclean-compile:
-rm -f *.$(OBJEXT)
@@ -481,26 +528,23 @@ distclean-compile:
.c.o:
@am__fastdepCC_TRUE@ $(AM_V_CC)$(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
-@am__fastdepCC_FALSE@ $(AM_V_CC) @AM_BACKSLASH@
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-@am__fastdepCC_FALSE@ $(COMPILE) -c $<
+@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c $<
.c.obj:
@am__fastdepCC_TRUE@ $(AM_V_CC)$(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'`
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
-@am__fastdepCC_FALSE@ $(AM_V_CC) @AM_BACKSLASH@
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-@am__fastdepCC_FALSE@ $(COMPILE) -c `$(CYGPATH_W) '$<'`
+@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c `$(CYGPATH_W) '$<'`
.c.lo:
@am__fastdepCC_TRUE@ $(AM_V_CC)$(LTCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Plo
-@am__fastdepCC_FALSE@ $(AM_V_CC) @AM_BACKSLASH@
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $<
+@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(LTCOMPILE) -c -o $@ $<
mostlyclean-libtool:
-rm -f *.lo
@@ -509,8 +553,11 @@ clean-libtool:
-rm -rf .libs _libs
install-dist_pkgdataDATA: $(dist_pkgdata_DATA)
@$(NORMAL_INSTALL)
- test -z "$(pkgdatadir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)"
@list='$(dist_pkgdata_DATA)'; test -n "$(pkgdatadir)" || list=; \
+ if test -n "$$list"; then \
+ echo " $(MKDIR_P) '$(DESTDIR)$(pkgdatadir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)" || exit 1; \
+ fi; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \
@@ -524,9 +571,7 @@ uninstall-dist_pkgdataDATA:
@$(NORMAL_UNINSTALL)
@list='$(dist_pkgdata_DATA)'; test -n "$(pkgdatadir)" || list=; \
files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
- test -n "$$files" || exit 0; \
- echo " ( cd '$(DESTDIR)$(pkgdatadir)' && rm -f" $$files ")"; \
- cd "$(DESTDIR)$(pkgdatadir)" && rm -f $$files
+ dir='$(DESTDIR)$(pkgdatadir)'; $(am__uninstall_files_from_dir)
ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
@@ -631,10 +676,15 @@ install-am: all-am
installcheck: installcheck-am
install-strip:
- $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
- install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
- `test -z '$(STRIP)' || \
- echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
+ if test -z '$(STRIP)'; then \
+ $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
+ install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
+ install; \
+ else \
+ $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
+ install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
+ "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'" install; \
+ fi
mostlyclean-generic:
clean-generic:
diff --git a/contrib/coverage.sh b/contrib/coverage.sh
index b53a382..dd6a6ab 100755
--- a/contrib/coverage.sh
+++ b/contrib/coverage.sh
@@ -2,7 +2,7 @@
# make sure configure was run with coverage enabled...
lcov --directory . --zerocounters
make check
-rm `find * -name "test_*.gc??"`
+rm `find * -name "test_*.gc??"` `find * -name "perf_*.gc??"`
for n in `find * -name "*.gc??" | grep libs`
do
cd `dirname $n`
diff --git a/contrib/gnunet_janitor.py.in b/contrib/gnunet_janitor.py.in
index 056ab9b..69186fd 100644
--- a/contrib/gnunet_janitor.py.in
+++ b/contrib/gnunet_janitor.py.in
@@ -30,13 +30,11 @@ import sys
import shutil
import time
import signal
+import terminate
if os.name == 'nt':
from win32com.client import GetObject
WMI = GetObject('winmgmts:')
- killsignal = signal.SIGTERM # any valid value will result in TerminateProcess()
-else:
- killsignal = signal.SIGKILL
def get_process_list ():
result = []
@@ -63,7 +61,7 @@ def main ():
if re.match (r'gnunet-service-arm', p[1]):
print ("killing arm process {0:5} {1}".format (p[0], p[1]))
try:
- os.kill (int (p[0]), killsignal)
+ terminate.safe_terminate_process_by_pid (int (p[0]), 1)
except OSError as e:
print ("failed: {0}".format (e))
pass
@@ -71,7 +69,7 @@ def main ():
if not re.match (r'gnunet-service-arm', p[1]):
print ("killing non-arm process {0:5} {1}".format (p[0], p[1]))
try:
- os.kill (int (p[0]), killsignal)
+ terminate.safe_terminate_process_by_pid (int (p[0]), 1)
except OSError as e:
print ("failed: {0}".format (e))
pass
diff --git a/contrib/hostlist.cgi b/contrib/hostlist.cgi
deleted file mode 100644
index f04246e..0000000
--- a/contrib/hostlist.cgi
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-# This is a CGI script to generate the host list on-demand.
-# by Michael Wensley, with minor improvements by Christian Grothoff
-echo -ne "Content-Type: application/octet-stream\r\n\r\n"
-cat /var/lib/gnunet/data/hosts/*.{2,3,4,5,6,8,12,17,23,25}
diff --git a/contrib/hostlist.php b/contrib/hostlist.php
deleted file mode 100644
index 1585615..0000000
--- a/contrib/hostlist.php
+++ /dev/null
@@ -1,35 +0,0 @@
-<?php
-// Requires PHP >= 4.3.0
-// Author: "Krasko Oleksandr" <0m3r.mail@gmail.com>
-// Minor improvements by Christian Grothoff <christian@grothoff.org>
-header("Content-Type: application/octet-stream\r\n\r\n");
-$extmas = array();
-$pv=$_GET['p'];
-if (isset($pv))
- {
- for ($ii=0;$ii<64;$ii++)
- if (0 != ($pv & (1 << $ii)))
- $extmas[] = $ii;
- }
-else
- {
- $extmas = array('2','3','4','5','6','8','12','17','23','25');
- }
-$path = '/var/lib/gnunet/data/hosts/'; // adjust as necessary
-$dir = opendir($path);
-if (! $dir)
- die("Cannot open directory $path.\n");
-$mas = array();
-while ($fname = readdir($dir)) {
- $fn = $path . '/' . $fname;
- if (is_file($fn)) {
- $dpo = strpos($fname, '.') + 1;
- $len = strlen($fname);
- if (in_array(substr($fname, $dpo - $len), $extmas))
- $mas[] = $fn;
- }
-}
-shuffle($mas); // randomize order
-foreach ($mas as $val)
- echo file_get_contents($val);
-?>
diff --git a/contrib/pydiffer.py.in b/contrib/pydiffer.py.in
new file mode 100644
index 0000000..23d546b
--- /dev/null
+++ b/contrib/pydiffer.py.in
@@ -0,0 +1,39 @@
+#!@PYTHON@
+import os
+import sys
+import difflib
+import filecmp
+
+def getdiff (old, new):
+ diff = []
+ with open (old) as a:
+ with open (new) as b:
+ for l in difflib.unified_diff (a.read ().splitlines (), b.read ().splitlines ()):
+ diff.append (l)
+ return diff
+
+def dc_getdiff (dc, old, new):
+ diff = []
+ for f in dc.left_only:
+ diff.append ("Only in {}: {}".format (old, f))
+ for f in dc.right_only:
+ diff.append ("Only in {}: {}".format (new, f))
+ for f in dc.diff_files:
+ r = getdiff (os.path.join (old, f), os.path.join (new, f))
+ diff.extend (r)
+ for dn, dc in dc.subdirs.items ():
+ r = dc_getdiff (dc, os.path.join (old, dn), os.path.join (new, dn))
+ diff.extend (r)
+ return diff
+
+def dcdiff (old, new):
+ dc = filecmp.dircmp (old, new)
+ diff = dc_getdiff (dc, old, new)
+ return diff
+
+def main ():
+ for l in dcdiff (sys.argv[1], sys.argv[2]):
+ print (l)
+
+if __name__ == '__main__':
+ main ()
diff --git a/contrib/report.sh b/contrib/report.sh
index 37a1c41..6e1d399 100755
--- a/contrib/report.sh
+++ b/contrib/report.sh
@@ -156,6 +156,26 @@ else
fi
fi
+TEST=`$WHICH dpkg 2> /dev/null`
+if test -n "$TEST"; then
+ LINES=`dpkg -s libunistring-dev | grep Version | wc -l`
+ if test "$LINES" = "1"
+ then
+ VERSION=`dpkg -s libunistring-dev | grep Version | awk '{print $2}'`
+ echo "libunistring : libunistring3-dev-$VERSION.deb"
+ else
+ echo "libunistring : dpkg: libunistring3-dev not installed"
+ fi
+else
+ TEST=`$WHICH rpm 2> /dev/null`
+ if test -n "$TEST"; then
+ rpm -q unistring | sed -e "s/unistring-//" 2> /dev/null | \
+ awk '{print "libunistring : "$1.rpm}'
+ else
+ echo "libunistring : Test not available"
+ fi
+fi
+
TEST=`$WHICH gettext 2> /dev/null`
if test -n "$TEST"; then
gettext --version | head -n1 2> /dev/null | \
@@ -173,15 +193,7 @@ else
echo "libcurl : Not found"
fi
-
-TEST=`which qmake 2> /dev/null`
-if test -x "$TEST"; then
- qmake --version | tail -n 1 | awk '{print "Qt : "$4}'
-else
- echo "Qt : Not found"
-fi
-
-echo -n "MHD : "
+echo -n "libmicrohttpd : "
TMPFILE=`mktemp /tmp/mhd-version-testXXXXXX`
cat - >$TMPFILE.c <<EOF
#include <microhttpd.h>
@@ -197,4 +209,36 @@ gcc -o $TMPFILE $TMPFILE.c 2> /dev/null && $TMPFILE || echo "Not found"
rm -f $TMPFILE $TMPFILE.bin
+echo -n "GNU GLPK : "
+TMPFILE=`mktemp /tmp/glpk-version-testXXXXXX`
+cat - >$TMPFILE.c <<EOF
+#include <glpk.h>
+#include <stdio.h>
+int main()
+{
+ fprintf (stdout, "%u.%u\n", GLP_MAJOR_VERSION, GLP_MINOR_VERSION);
+ return 0;
+}
+EOF
+
+gcc -o $TMPFILE $TMPFILE.c 2> /dev/null && $TMPFILE || echo "Not found"
+rm -f $TMPFILE $TMPFILE.bin
+
+
+echo -n "GNUtls : "
+TMPFILE=`mktemp /tmp/gnutls-version-testXXXXXX`
+cat - >$TMPFILE.c <<EOF
+#include <gnutls/gnutls.h>
+#include <stdio.h>
+int main()
+{
+ fprintf (stdout, "%s\n", GNUTLS_VERSION);
+ return 0;
+}
+EOF
+
+gcc -o $TMPFILE $TMPFILE.c 2> /dev/null && $TMPFILE || echo "Not found"
+rm -f $TMPFILE $TMPFILE.bin
+
+
echo "--------------------------------------------------------------"
diff --git a/contrib/terminate.py.in b/contrib/terminate.py.in
new file mode 100644
index 0000000..14c79c1
--- /dev/null
+++ b/contrib/terminate.py.in
@@ -0,0 +1,64 @@
+#!@PYTHON@
+# This file is part of GNUnet.
+# (C) 2011 Christian Grothoff (and other contributing authors)
+#
+# GNUnet is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published
+# by the Free Software Foundation; either version 2, or (at your
+# option) any later version.
+#
+# GNUnet is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNUnet; see the file COPYING. If not, write to the
+# Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+#
+# Utility module that implements safe process termination for W32.
+# For other platforms it's equivalent to Popen.kill ()
+# Requires pywin32 on W32.
+
+import sys
+import os
+import subprocess
+if os.name == 'nt':
+ import win32api
+ import win32process
+
+class dummyobj (object):
+ pass
+
+def safe_terminate_process_by_pid (pid, code):
+ if os.name == 'nt':
+ p = dummyobj ()
+ p._handle = win32api.OpenProcess (2 | 1024 | 8 | 32 | 16, 0, pid)
+ result = safe_terminate_process (p, code)
+ win32api.CloseHandle (p._handle)
+ return result
+ else:
+ return os.kill (int (pid), SIGKILL)
+
+def safe_terminate_process (proc, code):
+ if os.name == 'nt':
+ cp = win32api.GetCurrentProcess ()
+ result = False
+ dupproc = win32api.DuplicateHandle (cp, proc._handle, cp, 2 | 1024 | 8 | 32 | 16, 0, 0)
+ try:
+ exitcode = win32process.GetExitCodeProcess (dupproc)
+ if exitcode == 0x103:
+ kernel32 = win32api.GetModuleHandle ("kernel32")
+ exitprocess = win32api.GetProcAddress (kernel32, "ExitProcess")
+ th, tid = win32process.CreateRemoteThread (dupproc, None, 0, exitprocess, code, 0)
+ win32api.CloseHandle (th)
+ result = True
+ else:
+ result = True
+ # except failed to get exit code? failed to get module handle?
+ finally:
+ win32api.CloseHandle (dupproc)
+ return result
+ else:
+ return proc.kill ()
diff --git a/contrib/testing_hostkeys.ecc b/contrib/testing_hostkeys.ecc
new file mode 100644
index 0000000..ec28939
--- /dev/null
+++ b/contrib/testing_hostkeys.ecc
Binary files differ