aboutsummaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog7030
1 files changed, 7030 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index d1ebc0e..233d630 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7033 @@
+2013-02-05 16:06 wachs
+
+ * [r26026] src/transport/gnunet-service-transport_manipulation.c,
+ src/transport/test_transport_api_manipulation_recv_tcp.c,
+ src/transport/test_transport_api_manipulation_send_tcp.c:
+ documentation
+
+2013-02-05 16:03 wachs
+
+ * [r26025] src/transport/Makefile.am: extradist
+ -This line, and those below, will be ignored--
+
+ M src/transport/Makefile.am
+
+2013-02-05 16:02 wachs
+
+ * [r26024] src/include/gnunet_transport_service.h,
+ src/transport/transport_api.c: docu
+
+2013-02-05 15:53 wachs
+
+ * [r26023]
+ src/transport/test_transport_api_manipulation_recv_tcp.c: new
+ test
+
+2013-02-05 15:50 wachs
+
+ * [r26022] src/transport/gnunet-service-transport_manipulation.c,
+ src/transport/test_transport_api_manipulation_send_tcp.c: fixes
+
+2013-02-05 15:35 wachs
+
+ * [r26021] src/transport/Makefile.am,
+ src/transport/gnunet-service-transport_manipulation.c,
+ src/transport/gnunet-service-transport_manipulation.h,
+ src/transport/test_transport_api_manipulation.c,
+ src/transport/test_transport_api_manipulation_recv_tcp_peer1.conf,
+ src/transport/test_transport_api_manipulation_recv_tcp_peer2.conf,
+ src/transport/test_transport_api_manipulation_send_tcp.c,
+ src/transport/test_transport_api_manipulation_send_tcp_peer1.conf,
+ src/transport/test_transport_api_manipulation_send_tcp_peer2.conf,
+ src/transport/test_transport_api_manipulation_tcp_peer1.conf,
+ src/transport/test_transport_api_manipulation_tcp_peer2.conf:
+ traffic manipulation: receive delay
+
+2013-02-05 14:39 wachs
+
+ * [r26020] src/transport/test_transport_api_manipulation.c: delay
+ sending implemented
+
+2013-02-05 14:24 harsha
+
+ * [r26019] src/gns/test_gns_dht_three_peers.c,
+ src/include/gnunet_testbed_service.h,
+ src/regex/gnunet-regex-profiler.c,
+ src/testbed/test_testbed_api_topology.c,
+ src/testbed/test_testbed_api_topology_clique.c,
+ src/testbed/testbed_api_testbed.c,
+ src/testbed/testbed_api_topology.c: add completion callback for
+ overlay topology configure functions
+
+2013-02-05 12:47 wachs
+
+ * [r26016] src/include/gnunet_transport_service.h,
+ src/transport/Makefile.am, src/transport/transport_api.c: last
+ commit for metric
+
+2013-02-05 12:46 wachs
+
+ * [r26015] src/include/gnunet_protocols.h,
+ src/transport/test_transport_api_manipulation_tcp_peer1.conf,
+ src/transport/test_transport_api_manipulation_tcp_peer2.conf:
+ more
+
+2013-02-05 12:45 wachs
+
+ * [r26014] src/transport/gnunet-service-transport.c,
+ src/transport/gnunet-service-transport.h,
+ src/transport/transport.h: more metric
+
+2013-02-05 12:44 wachs
+
+ * [r26013] src/transport/gnunet-service-transport_clients.c,
+ src/transport/test_transport_api_manipulation.c: transport metric
+ manipulation
+
+2013-02-04 16:54 wachs
+
+ * [r26007] src/transport/plugin_transport_tcp.c: limit connection
+ for tcp
+
+2013-02-04 15:40 wachs
+
+ * [r26003] src/transport/gnunet-service-transport.c,
+ src/transport/gnunet-service-transport_neighbours.c,
+ src/transport/gnunet-service-transport_neighbours.h,
+ src/transport/gnunet-service-transport_validation.c,
+ src/transport/gnunet-service-transport_validation.h,
+ src/transport/transport.h: throttling validations
+
+2013-02-04 15:34 wachs
+
+ * [r26002] configure.ac: check for getrlimit
+
+2013-02-04 10:52 wachs
+
+ * [r26001] src/transport/gnunet-transport.c: implemented 0002773
+
+2013-02-04 09:53 wachs
+
+ * [r25997] src/ats/gnunet-service-ats_addresses.c: fix for 0002723
+
+2013-02-04 09:34 wachs
+
+ * [r25996] src/transport/gnunet-service-transport.c,
+ src/transport/plugin_transport_tcp.c: check code for 0002774
+
+2013-02-02 17:26 LRN
+
+ * [r25988] src/util/container_meta_data.c: Discard large metadata
+ items first
+
+2013-02-02 17:26 LRN
+
+ * [r25987] src/util/container_meta_data.c: Fix a memory leak in MD
+ serializer
+
+2013-02-02 17:25 LRN
+
+ * [r25986] src/util/container_meta_data.c: Fix a buffer overflow
+
+2013-02-02 17:25 LRN
+
+ * [r25985] src/fs/gnunet-helper-fs-publish.c: Don't send more than
+ 64k from fs helper
+
+2013-02-01 12:49 harsha
+
+ * [r25974] src/transport/transport_api.c:
+ GNUNET_TRANSPORT_get_hello() to call its callback asynchronously
+
+2013-01-31 14:15 cfuchs
+
+ * [r25967] src/exit/gnunet-helper-exit-windows.c: re-enumated argv
+ to conform with helper-exit syntax
+
+ added stub for ipv4 nat. Note that there is a problem ahead!
+
+2013-01-31 13:12 cfuchs
+
+ * [r25966] src/exit/gnunet-helper-exit-windows.c,
+ src/vpn/gnunet-helper-vpn-windows.c: added support for partial
+ write to stdin/stdout.
+
+ there seems to be no point in adding support for partial read
+ from the
+ TAP, as there is no delimiter and we get data on a per-frame
+ level.
+
+2013-01-31 12:32 cfuchs
+
+ * [r25964] src/exit/gnunet-helper-exit-windows.c,
+ src/vpn/gnunet-helper-vpn-windows.c: added support for partial
+ reads from stdin
+
+2013-01-31 10:41 cfuchs
+
+ * [r25959] src/exit/gnunet-helper-exit-windows.c,
+ src/vpn/gnunet-helper-vpn-windows.c: helper-vpn and helper-exit
+ now are 64bit capabled.
+
+ added check if we are running on a win32/wow64/win64 host system.
+
+2013-01-31 09:45 grothoff
+
+ * [r25956] src/vpn/vpn.conf.in: porting to W32 requires a port,
+ yepee
+
+2013-01-31 09:11 cfuchs
+
+ * [r25954] src/exit/gnunet-helper-exit-windows.c,
+ src/vpn/gnunet-helper-vpn-windows.c: some final
+ code-beautification (coding style 4tw!)
+
+ removed a few obsolete variables
+
+2013-01-31 08:52 cfuchs
+
+ * [r25953] src/exit/Makefile.am,
+ src/exit/gnunet-helper-exit-windows.c: added
+ gnunet-helper-exit-windows, which currently is just a copy of
+ gnunet-helper-vpn-windows
+
+2013-01-30 17:45 cfuchs
+
+ * [r25952] src/vpn/gnunet-helper-vpn-windows.c: added nice debug
+ output for gnunet-herlper-vpn-windows.
+
+2013-01-30 15:54 grothoff
+
+ * [r25947] src/fs/perf_gnunet_service_fs_p2p.c,
+ src/fs/perf_gnunet_service_fs_p2p.conf,
+ src/include/gnunet_network_lib.h,
+ src/testbed/gnunet-service-testbed_hc.c: API extension, make
+ blocking socket API visible
+
+2013-01-30 15:06 harsha
+
+ * [r25945] src/testbed/gnunet-service-testbed_hc.c: towards caching
+ CORE handles
+
+2013-01-30 13:38 harsha
+
+ * [r25944] src/core/core_api.c, src/include/gnunet_core_service.h:
+ function to synchronously check if a peer is connected at CORE
+ level
+
+2013-01-30 10:06 harsha
+
+ * [r25938] src/testbed/gnunet-service-testbed.h,
+ src/testbed/gnunet-service-testbed_hc.c,
+ src/testbed/gnunet-service-testbed_oc.c: cache transport handles
+ with peer connect notifications
+
+2013-01-30 09:22 wachs
+
+ * [r25937] src/include/gnunet_transport_service.h,
+ src/transport/transport_api.c: forgot
+
+2013-01-29 15:10 harsha
+
+ * [r25933] src/testbed/gnunet-service-testbed_hc.c,
+ src/testbed/gnunet-service-testbed_oc.c: caching transport
+ handles
+
+2013-01-26 14:27 harsha
+
+ * [r25921] src/testbed/gnunet-service-testbed_oc.c: bound remote
+ overlay connect operation execution to limited number of open
+ file descriptors
+
+2013-01-26 09:50 grothoff
+
+ * [r25919] src/arm/gnunet-arm.c, src/arm/test_arm_api.c,
+ src/arm/test_exponential_backoff.c,
+ src/arm/test_gnunet_service_arm.c: LRN: Here's a patch. See if it
+ doesn't break anything for you.
+
+ Arm service is started with -c <configname> only when the process
+ that
+ runs arm service has "[arm]/CONFIG" defined in the configuration
+ used
+ to run arm service (usually - process' own configuration).
+
+ Since default [arm] config has no CONFIG defined anymore (thanks
+ to
+ your r25908), we need to add this code to put the config file
+ that was
+ passed to gnunet-arm tool via -c as "[arm]/CONFIG" for arm
+ service to
+ receive it.
+
+ Otherwise arm service is run without config and reads default
+ config
+ (~/.gnunet/gnunet.conf) instead, which is clearly not what we
+ need.
+
+2013-01-25 22:27 harsha
+
+ * [r25918] po/POTFILES.in: fix 2746
+
+2013-01-25 20:38 harsha
+
+ * [r25917] src/testbed/gnunet-service-testbed.c,
+ src/testbed/gnunet-service-testbed.h,
+ src/testbed/testbed.conf.in: read MAX_OPEN_FDS from configuration
+
+2013-01-25 16:42 harsha
+
+ * [r25913] src/testbed/gnunet-service-testbed_oc.c: bound overlay
+ connect operation execution to limited number of open file
+ descriptors
+
+2013-01-25 16:02 grothoff
+
+ * [r25907] src/arm/arm_api.c: start gnunet-service-arm nicely if
+ configuration file does not exist
+
+2013-01-25 15:22 grothoff
+
+ * [r25904] src/exit/Makefile.am, src/exit/exit.conf,
+ src/exit/gnunet-daemon-exit.c: add DNS exit for mesh to
+ gnunet-daemon-exit
+
+2013-01-25 15:22 grothoff
+
+ * [r25903] src/dns/Makefile.am, src/dns/dns.conf.in,
+ src/dns/gnunet-service-dns.c: remove DNS exit for mesh from
+ gnunet-service-dns
+
+2013-01-25 10:55 harsha
+
+ * [r25892] src/testbed/Makefile.am,
+ src/testbed/gnunet-service-testbed.c,
+ src/testbed/gnunet-service-testbed.h,
+ src/testbed/gnunet-service-testbed_hc.c: separate hello cache as
+ module
+
+2013-01-24 17:01 harsha
+
+ * [r25889] src/testbed/test_testbed_api_operations.c: test harder
+
+2013-01-24 15:46 bartpolot
+
+ * [r25886] src/mesh/Makefile.am,
+ src/mesh/gnunet-daemon-regexprofiler.c,
+ src/mesh/gnunet-regex-profiler.c, src/mesh/gnunet-service-mesh.c,
+ src/regex, src/regex/Makefile.am,
+ src/regex/gnunet-daemon-regexprofiler.c,
+ src/regex/gnunet-regex-profiler.c: Moved regex profiler and
+ profiler daemon from mesh to regex, adaped to regex dht lib
+
+2013-01-24 13:54 cfuchs
+
+ * [r25885] src/vpn/gnunet-helper-vpn-windows.c: re-fixed incorrect
+ from last commit... :-D forgot to save.
+
+2013-01-24 13:51 cfuchs
+
+ * [r25884] src/vpn/gnunet-helper-vpn-windows.c: added debug logics
+ to print to and read from STDIN, instead of from
+ named pipes
+
+ moved declaration of hdr outside of the ifs
+
+ fixed an incorrect comparison introduced in last commit
+
+2013-01-24 13:07 cfuchs
+
+ * [r25883] src/vpn/gnunet-helper-vpn-windows.c: helper now always
+ uses BOOL(winbool) instead of boolean to stay
+ consistent
+
+ attept_write now properly resets the read facility to
+ IOSTATE_RESUME, in
+ case read was stalled because write was busy
+
+2013-01-24 12:49 cfuchs
+
+ * [r25882] src/vpn/gnunet-helper-vpn-windows.c: added
+ IOSTATE_RESUME and related code to state machines
+
+2013-01-24 12:24 harsha
+
+ * [r25881] src/testbed/testbed_api_operations.c,
+ src/testbed/testbed_api_operations.h: operations now can
+ explicitly register how many resources they require
+
+2013-01-24 11:46 dold
+
+ * [r25879] src/consensus/gnunet-consensus.c: fix
+
+2013-01-24 08:51 cfuchs
+
+ * [r25871] src/vpn/gnunet-helper-vpn-windows.c: added gnunet-header
+ stripping and adding functionality
+
+ woops logics bug discovered: when read goes into waiting, the
+ output
+ facility will
+ not transfer the input buffer and forget about it silently...
+
+2013-01-24 08:23 cfuchs
+
+ * [r25870] src/vpn/gnunet-helper-vpn-windows.c: added ip-address
+ remove functions
+
+ newly set IP addresses now should expire upon reboot (buggy on
+ some
+ windows, but at least it solves the IP-persistence issues in win7
+ and
+ above)
+
+ cloned read functions to properly apply or strip the gnunet
+ message
+ header
+
+ removed the status BOOL from the overlapped struct and made it
+ local
+
+ some fixes here and there
+
+ added a lot of comments
+
+ style adjustments
+
+ TODO:
+ * actually strip the gnunet message header or apply it again
+ * test with the main vpn binary
+
+2013-01-24 02:55 dold
+
+ * [r25866] src/consensus/consensus_api.c,
+ src/consensus/consensus_protocol.h,
+ src/consensus/gnunet-consensus.c,
+ src/consensus/gnunet-service-consensus.c, src/consensus/ibf.c,
+ src/consensus/test_consensus.conf: implemented value exchange,
+ various fixes
+
+2013-01-23 13:15 harsha
+
+ * [r25862] contrib/testbed_infiniband.conf: profiler now depends on
+ config file to give topology option
+
+2013-01-23 13:14 harsha
+
+ * [r25861] src/testbed/gnunet-testbed-profiler.c,
+ src/testbed/testbed_api_testbed.c: fix 2688: profiler now uses
+ GNUNET_TESTBED_run ()
+
+2013-01-23 10:46 harsha
+
+ * [r25860] src/testbed/testbed_api_testbed.c: use all IP addresses
+ of master controller as trusted ip
+
+2013-01-23 10:10 wachs
+
+ * [r25859] src/ats/test_ats_simplistic_pref_aging.c: test
+
+2013-01-22 16:44 wachs
+
+ * [r25857] src/ats/test_ats_simplistic_pref_aging.c: changes
+
+2013-01-22 16:01 wachs
+
+ * [r25856] src/ats/gnunet-service-ats_addresses_simplistic.c: wrong
+ type causing invalid reads
+
+2013-01-22 11:04 wachs
+
+ * [r25854] contrib/pydmesg: print dmesg messages with human
+ readable timestamps
+ useful to check when segfaults etc happened
+
+2013-01-21 16:58 wachs
+
+ * [r25853] src/ats/gnunet-service-ats_addresses_simplistic.c:
+ changes to aging
+
+2013-01-21 16:29 wachs
+
+ * [r25850] src/ats/gnunet-service-ats_addresses_simplistic.c: fixes
+
+2013-01-21 16:26 LRN
+
+ * [r25848] po/POTFILES.in: mesh_block_lib.c is gone
+
+2013-01-21 16:15 wachs
+
+ * [r25847] src/ats/test_ats_simplistic_pref_aging.c: improving test
+
+2013-01-21 13:24 grothoff
+
+ * [r25837] contrib/gnunet-chk.py: 3
+
+2013-01-18 16:52 wachs
+
+ * [r25835] src/ats/gnunet-service-ats_addresses_simplistic.c:
+ preference aging + improved quota recalculation due to pref
+ change
+
+2013-01-18 15:48 wachs
+
+ * [r25833] src/ats/Makefile.am,
+ src/ats/gnunet-service-ats_addresses_simplistic.c,
+ src/ats/test_ats_simplistic_pref_aging.c: changes
+
+2013-01-18 14:07 wachs
+
+ * [r25831] src/ats-tool/gnunet-ats.c: print network type
+
+2013-01-18 13:49 wachs
+
+ * [r25830] src/transport/plugin_transport_http_client.c,
+ src/transport/plugin_transport_http_common.c: changes
+
+2013-01-18 12:23 wachs
+
+ * [r25829] src/transport/plugin_transport_http_common.c,
+ src/transport/test_http_common.c: changes
+
+2013-01-18 12:01 wachs
+
+ * [r25828] src/transport/plugin_transport_http_common.c: mem leak
+
+2013-01-18 11:16 wachs
+
+ * [r25827] src/transport/test_http_common.c: change
+
+2013-01-18 11:07 wachs
+
+ * [r25826] src/transport/plugin_transport_http_common.c,
+ src/transport/plugin_transport_http_common.h,
+ src/transport/test_http_common.c: address parsing
+
+2013-01-18 04:51 LRN
+
+ * [r25823] src/regex/Makefile.am: Fix regex dependencies
+
+2013-01-18 04:43 LRN
+
+ * [r25822] src/transport/gnunet-transport.c: Fix FPRINTF invocation
+
+2013-01-18 04:43 LRN
+
+ * [r25821] src/core/gnunet-service-core_kx.c: Replace EPV with a
+ warning
+
+2013-01-18 04:43 LRN
+
+ * [r25820] src/transport/gnunet-service-transport_validation.c:
+ Re-enable signature check warning
+
+2013-01-17 17:09 bartpolot
+
+ * [r25819] src/include/block_mesh.h, src/include/block_regex.h,
+ src/include/gnunet_block_lib.h, src/include/gnunet_regex_lib.h,
+ src/mesh/Makefile.am, src/mesh/gnunet-service-mesh-new.c,
+ src/mesh/gnunet-service-mesh.c, src/mesh/mesh_block_lib.c,
+ src/mesh/mesh_block_lib.h, src/mesh/plugin_block_mesh.c,
+ src/regex/Makefile.am, src/regex/plugin_block_regex.c,
+ src/regex/regex.c, src/regex/regex_block_lib.c,
+ src/regex/regex_block_lib.h, src/regex/regex_dht.c: Move regex
+ DHT integration from mesh to regex
+
+2013-01-17 16:31 wachs
+
+ * [r25818] src/transport/test_http_common.c: test
+
+2013-01-17 16:21 wachs
+
+ * [r25817] src/transport/Makefile.am,
+ src/transport/gnunet-service-transport_clients.c,
+ src/transport/plugin_transport_http_common.c,
+ src/transport/plugin_transport_http_common.h: address parsing
+
+2013-01-17 14:23 cfuchs
+
+ * [r25816] src/vpn/gnunet-helper-vpn-windows.c: * a little bit of
+ bugfixing
+ * added functionality to remove ip addresses from our interfaces
+ * some formatting work
+ * added rety-loop for the interface-name resolver (retry up to 30
+ seconds)
+ * set new ipv4/v6 addresses to be forgotten on bootup
+ (store=active)
+ * adjusted some debug output (added a few \n here and there)
+
+2013-01-17 13:33 wachs
+
+ * [r25814] src/transport/gnunet-transport.c: end when no addresses
+ returned
+
+2013-01-17 13:03 wachs
+
+ * [r25813] src/transport/gnunet-transport.c: improved timeout
+ handling for address listing
+
+2013-01-17 12:25 wachs
+
+ * [r25812] src/transport/gnunet-transport.c: timeout for address
+ listing
+
+2013-01-17 10:28 grothoff
+
+ * [r25809] src/vpn/gnunet-helper-vpn-windows.c: minor style stuff
+
+2013-01-16 17:21 cfuchs
+
+ * [r25805] src/vpn/gnunet-helper-vpn-windows.c: more debugging
+ work.
+
+ Registry is extremely slow at refreshing. inserted a makeshift
+ sleep(5)
+ to avoid retrieving outdated interface-information.
+
+ added proper return-codes to set_address4/6
+
+ fixed incorrect string-length handling for the HWID tags
+
+ updatedriverforplugandplaydevicesa now updates only the driver
+ for our
+ current device, no longer the other siblings too (for >10
+ devices,
+ this could easily have taken > 60 seconds! ).
+
+ removed inet_pton, as we require API version XPSP2 anyway.
+
+2013-01-15 20:22 cfuchs
+
+ * [r25802] src/vpn/Makefile.am,
+ src/vpn/gnunet-helper-vpn-windows.c: added calls for updating the
+ driver in a for device. seems like this is
+ mandatory when adding a new device node. unfortunately this is
+ pretty
+ slow...
+
+ added new required include+library to link against: newdev.h/dll
+
+2013-01-15 19:15 cfuchs
+
+ * [r25801] src/vpn/gnunet-helper-vpn-windows.c: more bug fixing
+
+2013-01-15 18:50 cfuchs
+
+ * [r25800] src/vpn/gnunet-helper-vpn-windows.c: a bit of bugfixing
+
+2013-01-15 14:45 cfuchs
+
+ * [r25799] src/vpn/gnunet-helper-vpn-windows.c: final logics for
+ run implemented
+ added teardown functionality.
+
+ now: testing...
+
+2013-01-15 14:42 wachs
+
+ * [r25798] src/ats/gnunet-service-ats_addresses_simplistic.c: fix
+ for failing fs tests
+
+2013-01-15 14:11 wachs
+
+ * [r25797] src/sysmon/gnunet-service-sysmon.c,
+ src/sysmon/sysmon.conf.in: changes
+
+2013-01-15 13:32 wachs
+
+ * [r25794] src/sysmon/gnunet-service-sysmon.c,
+ src/sysmon/sysmon.conf.in: time stamp
+
+2013-01-15 13:23 wachs
+
+ * [r25793] src/sysmon/gnunet-service-sysmon.c: IPv6 support
+
+2013-01-15 12:55 wachs
+
+ * [r25792] src/sysmon/gnunet-service-sysmon.c,
+ src/sysmon/sysmon.conf.in, src/sysmon/test_glibtop_network.c:
+ changes
+
+2013-01-15 11:14 wachs
+
+ * [r25791] src/sysmon/Makefile.am,
+ src/sysmon/gnunet-service-sysmon.c,
+ src/sysmon/sysmon-properties.conf, src/sysmon/sysmon.conf.in:
+ changes
+
+2013-01-15 10:17 wachs
+
+ * [r25790] src/sysmon/gnunet-service-sysmon.c: fix
+
+2013-01-15 10:14 wachs
+
+ * [r25789] src/sysmon/gnunet-service-sysmon.c: fix
+
+2013-01-15 10:13 wachs
+
+ * [r25788] src/sysmon/Makefile.am: install withouth libgtop
+
+2013-01-15 09:34 wachs
+
+ * [r25787] src/ats/gnunet-service-ats_addresses_simplistic.c:
+ fixing 0002735:
+ precision error when calculating quotas
+
+2013-01-15 09:09 wachs
+
+ * [r25786] src/ats/gnunet-service-ats_addresses_simplistic.c: get
+ more information
+
+2013-01-14 16:44 wachs
+
+ * [r25785] src/sysmon/gnunet-service-sysmon.c,
+ src/sysmon/sysmon.conf.in: gtop integration
+
+2013-01-14 16:22 wachs
+
+ * [r25784] src/sysmon/gnunet-service-sysmon.c: changes
+
+2013-01-14 15:53 wachs
+
+ * [r25782] src/sysmon/gnunet-service-sysmon.c,
+ src/sysmon/sysmon.conf.in: changes
+
+2013-01-14 15:39 harsha
+
+ * [r25781] contrib/testbed_infiniband.conf: - kill irrelavant stuff
+
+2013-01-14 15:09 wachs
+
+ * [r25779] src/sysmon/gnunet-service-sysmon.c: changes
+
+2013-01-14 12:02 wachs
+
+ * [r25771] src/include/gnunet_ats_service.h: handle
+
+2013-01-14 11:14 wachs
+
+ * [r25770] src/transport/gnunet-service-transport_neighbours.c:
+ fixing mantis 0002732
+
+2013-01-14 11:11 wachs
+
+ * [r25769] src/ats/ats_api_scheduling.c: adding suggest handle to
+ allow transport to check if we have pending address request
+
+2013-01-14 11:00 wachs
+
+ * [r25768] src/ats/test_ats_simplistic_change_preference.c: no
+ pending request
+
+2013-01-14 10:49 wachs
+
+ * [r25767] src/ats/test_ats_simplistic.c: no suggest to cancel
+
+2013-01-14 10:01 wachs
+
+ * [r25766] src/ats/gnunet-service-ats_addresses_simplistic.c: fix
+ for quota check
+
+2013-01-11 16:32 wachs
+
+ * [r25762] src/ats/gnunet-service-ats_addresses_simplistic.c,
+ src/ats/test_ats_simplistic_change_preference.c: changes
+
+2013-01-11 15:32 wachs
+
+ * [r25761] src/ats/gnunet-service-ats_addresses_simplistic.c: fix
+ for broken tests
+
+2013-01-11 15:31 wachs
+
+ * [r25760] src/ats/test_ats_api_scheduling_check_min_bw_alt.c: fix
+ test
+
+2013-01-11 14:32 wachs
+
+ * [r25759] src/ats/gnunet-service-ats_addresses_simplistic.c:
+ changes
+
+2013-01-11 13:38 wachs
+
+ * [r25758] src/ats/gnunet-service-ats_addresses_simplistic.c:
+ changes
+
+2013-01-11 13:37 wachs
+
+ * [r25757] src/ats/test_ats_simplistic_change_preference.c: change
+ to test to let updates settle
+
+2013-01-11 12:39 wachs
+
+ * [r25754] src/ats/gnunet-service-ats_addresses_simplistic.c:
+ global calculation
+
+2013-01-11 10:37 wachs
+
+ * [r25753] src/ats/gnunet-service-ats_addresses_simplistic.c: docu
+
+2013-01-11 09:51 wachs
+
+ * [r25752] src/ats/gnunet-service-ats_addresses.c: commit for
+ mantis: 0002729
+ quota load: support "unlimited", fancy strings and integer values
+ (set by gnunet setup)
+
+2013-01-10 12:36 cfuchs
+
+ * [r25743] src/vpn/gnunet-helper-vpn-windows.c: consolidated read
+ and write functions, as we can read from a named pipe
+ the same way as we can read from our TAP.
+
+ added high-level description of attempt_read
+
+2013-01-10 11:54 cfuchs
+
+ * [r25741] src/vpn/gnunet-helper-vpn-windows.c: as discussed,
+ vpn-helper-windows will only function if stdin/stdout are
+ handed down as pipes.
+
+ helper will reopen stdin and stdout in overlapped mode.
+ ReOpenFile
+ requires WinXPSP2 or Win2003SP1.
+
+2013-01-10 09:39 cfuchs
+
+ * [r25737] src/vpn/gnunet-helper-vpn-windows.c: In Windows, pipes,
+ files and the console have to be accessed
+ differently(in contrast to *nix). overlapping does not exist for
+ console
+ handles, and different functions are required to read/write/poll
+ stdin/out.
+
+ - THus, we can now detect the type of handle we got as
+ stdin/stdout from our calling process.
+
+ - Did a bit of refactoring.
+
+ next: add logics to use the proper access mode depending on our
+ handletype.
+
+2013-01-09 23:53 harsha
+
+ * [r25736] src/testbed/testbed_api.c: allow customizing remote
+ shell command and the program started by it
+
+2013-01-09 09:34 wachs
+
+ * [r25727] src/ats/gnunet-service-ats_addresses_simplistic.c:
+ enable preference calculation to finish it and debug
+
+2013-01-09 08:48 wachs
+
+ * [r25726] src/transport/gnunet-service-transport_validation.c:
+ debug code for mantis 0002726
+
+2013-01-08 14:08 cfuchs
+
+ * [r25713] src/vpn/gnunet-helper-vpn-windows.c: fixed a wrong
+ conditional
+
+ more research on the conin/stdin+overlapping issue.
+
+2013-01-07 16:09 wachs
+
+ * [r25708] src/gns/test_gns_dht_three_peers.c: 10 sec was too
+ optimistic for mamasparc
+
+2013-01-07 15:52 wachs
+
+ * [r25707] src/gns/test_gns_dht_three_peers.c: fixing test by
+ debugging (but still fails)
+
+2013-01-06 00:13 harsha
+
+ * [r25702] src/testbed/gnunet-service-testbed.c,
+ src/testbed/test_testbed_api.conf,
+ src/testbed/test_testbed_api_testbed_run_topology2dtorus.conf,
+ src/testbed/test_testbed_api_testbed_run_topologyclique.conf,
+ src/testbed/test_testbed_api_testbed_run_topologyfromfile.conf,
+ src/testbed/test_testbed_api_testbed_run_topologyline.conf,
+ src/testbed/test_testbed_api_testbed_run_topologyrandom.conf,
+ src/testbed/test_testbed_api_testbed_run_topologyring.conf,
+ src/testbed/test_testbed_api_testbed_run_topologyscalefree.conf,
+ src/testbed/test_testbed_api_testbed_run_topologysmallworld.conf,
+ src/testbed/test_testbed_api_testbed_run_topologysmallworldring.conf,
+ src/testbed/testbed.conf.in: cache HELLO's of peers
+
+2013-01-05 16:48 harsha
+
+ * [r25700] src/testbed/gnunet-service-testbed.c: aggressively
+ persuade transport to connect
+
+2013-01-04 12:18 grothoff
+
+ * [r25691] src/peerinfo/gnunet-service-peerinfo.c: fix
+
+2013-01-03 22:40 grothoff
+
+ * [r25686] src/peerinfo/gnunet-service-peerinfo.c,
+ src/peerinfo/peerinfo.conf.in: adding NO_IO option to peerinfo to
+ disable disc accesses for experiments
+
+2013-01-03 16:11 cfuchs
+
+ * [r25683] src/vpn/gnunet-helper-vpn-windows.c: There are now four
+ states for the OI facilities:
+ * ready (to do work),
+ * queued (waiting for async-io to return),
+ * waiting (a read-facilities wait for its output partner to get
+ process)
+ * failed (if a socket error occured)
+
+ added attempt_tap_read machine.
+ reworked run() for overlapped IO
+
+2013-01-03 14:58 harsha
+
+ * [r25682] src/testbed/testbed_api_testbed.c: fix #2720
+
+2013-01-03 10:40 cfuchs
+
+ * [r25677] src/vpn/gnunet-helper-vpn-windows.c: added initial stuff
+ for overlapped IO and event handling
+
+2013-01-03 00:43 dold
+
+ * [r25675] src/consensus/Makefile.am, src/consensus/consensus.h,
+ src/consensus/consensus_api.c,
+ src/consensus/gnunet-consensus-start-peers.c,
+ src/consensus/gnunet-consensus.c,
+ src/consensus/gnunet-service-consensus.c,
+ src/consensus/test_consensus_api.c,
+ src/include/gnunet_applications.h,
+ src/include/gnunet_consensus_service.h,
+ src/include/gnunet_protocols.h: implemented the modified
+ consensus api, started implementing p2p protocol for consensus
+
+2013-01-02 16:03 harsha
+
+ * [r25674] src/testbed/testbed_api.c, src/testbed/testbed_api.h:
+ weigh all readings equally
+
+2013-01-02 15:36 harsha
+
+ * [r25673] src/testbed/testbed_api.c: linear increase and decrease
+ when SD is within 1 and 2 SD respectively
+
+2013-01-01 22:44 harsha
+
+ * [r25670] src/testbed/standard_deviation.c,
+ src/testbed/test_testbed_api.conf, src/testbed/testbed_api.c,
+ src/testbed/testbed_api.h, src/testbed/testbed_api_peers.c,
+ src/testbed/testbed_api_peers.h: adaptive parallelism for overlay
+ connect operations based on SD calculations
+
+2013-01-01 11:49 cfuchs
+
+ * [r25668] src/vpn/gnunet-helper-vpn-windows.c: * re-added mainloop
+ for run
+ * started work on our select-equivalent for windows.
+
+2012-12-31 15:52 cfuchs
+
+ * [r25667] src/include/tap-windows.h,
+ src/vpn/gnunet-helper-vpn-windows.c: * added tap version checking
+ logics. Many tap32 versions are broken,
+ Only version 9.8 and later support IPv6, 9.8 is broken with IPv4.
+ Thus,
+ we are using the same minium version as openvpn 2.3: tap32-9.9
+
+ * created our TAP/TUN handle-object (equivalent to the *nix
+ init_tun()
+ function), this still requires some more logics to be
+ complete.
+
+ * added logics to set the tun up (+a fixed sleep, to wait for it
+ to
+ come up)
+
+ * we now also store the device's GUID, as we need it for creating
+ the
+ handle.
+
+ * added the exports of tap32: src/include/tap_windows.h , for the
+ sake
+ of upgradability. This file contains version-specific defines for
+ the
+ driver.
+
+ * happy new year!
+
+2012-12-29 20:20 cfuchs
+
+ * [r25665] src/vpn/gnunet-helper-vpn-windows.c: reworked vpn-helper
+ to now use regular(!) char, instead of wchar,
+ according to recommendations found in the C/C++-specs(wchar !=
+ unicode support, but may break compiler compatibility).
+
+2012-12-24 12:08 LRN
+
+ * [r25643] src/consensus/Makefile.am: Dependencies in consensus
+ makefiles
+
+2012-12-24 09:48 LRN
+
+ * [r25642] src/sysmon/sysmon.conf.in: Resolve port conflict between
+ ats and sysmon
+
+2012-12-22 08:50 LRN
+
+ * [r25640] src/hostlist/hostlist.conf: Fix default hostlists
+
+2012-12-21 16:48 grothoff
+
+ * [r25635] po/de.po, po/es.po, po/sv.po, po/vi.po, po/zh_CN.po:
+ releasing GNUnet 0.9.5
+
+2012-12-21 16:29 harsha
+
+ * [r25634] src/lockmanager/gnunet-service-lockmanager.c: remove
+ disconnecting client from waitling lists of other locks
+
+2012-12-21 10:06 dold
+
+ * [r25613] src/consensus/gnunet-consensus-ibf.c,
+ src/consensus/ibf.c, src/consensus/ibf.h: collision detection for
+ IBF, timing for test tool
+
+2012-12-20 14:50 wachs
+
+ * [r25583] src/ats/gnunet-service-ats_addresses_simplistic.c,
+ src/ats/test_ats_simplistic_change_preference.c: preference value
+ calculation
+
+2012-12-20 14:01 bartpolot
+
+ * [r25581] configure.ac, po/POTFILES.in, src/Makefile.am,
+ src/testing_old: Remove testing_old
+
+2012-12-20 13:57 LRN
+
+ * [r25580] src/fs/fs_uri.c: Fix percentization of non-ASCII strings
+
+2012-12-20 00:39 dold
+
+ * [r25571] src/consensus/Makefile.am,
+ src/consensus/gnunet-consensus-ibf.c, src/consensus/ibf.c,
+ src/consensus/ibf.h: implemented the invertible bloom filter
+
+2012-12-19 09:36 wachs
+
+ * [r25538] src/ats/test_ats_simplistic_change_preference.c: fixing
+ test
+
+2012-12-17 16:03 wachs
+
+ * [r25520] src/ats/ats_api_peer_change_preference.c: unused code
+
+2012-12-17 15:08 wachs
+
+ * [r25517] src/ats/Makefile.am,
+ src/ats/gnunet-service-ats_addresses.c,
+ src/ats/gnunet-service-ats_addresses_simplistic.c: changes
+
+2012-12-17 14:30 wachs
+
+ * [r25516] src/ats/test_ats_api.conf: no valgrind
+
+2012-12-17 14:30 wachs
+
+ * [r25515] src/ats/gnunet-service-ats_addresses.c,
+ src/ats/gnunet-service-ats_addresses.h,
+ src/ats/gnunet-service-ats_addresses_mlp.c,
+ src/ats/gnunet-service-ats_addresses_mlp.h,
+ src/ats/gnunet-service-ats_addresses_simplistic.c,
+ src/ats/gnunet-service-ats_addresses_simplistic.h,
+ src/ats/gnunet-service-ats_performance.c,
+ src/ats/test_ats_api.conf: adding client reference
+
+2012-12-17 12:48 wachs
+
+ * [r25511] configure.ac: libgtop check
+
+2012-12-17 12:45 wachs
+
+ * [r25509] src/sysmon/Makefile.am: new check
+
+2012-12-17 12:15 wachs
+
+ * [r25506] src/sysmon/Makefile.am: glib check
+
+2012-12-17 12:14 wachs
+
+ * [r25505] configure.ac: check for glib
+
+2012-12-15 14:24 grothoff
+
+ * [r25493] src/fs/gnunet-service-fs_pe.c: LRN: fixing #2701
+
+2012-12-14 10:56 wachs
+
+ * [r25480] src/dns/dnsparser.c: doxygen
+
+2012-12-14 10:54 wachs
+
+ * [r25479] src/hello/hello.c: doxyen
+
+2012-12-14 10:54 wachs
+
+ * [r25478] src/sysmon/gnunet-service-sysmon.c: doxygen
+
+2012-12-14 10:51 wachs
+
+ * [r25477] src/fs/Makefile.am: fixes for make dist
+
+2012-12-14 10:43 wachs
+
+ * [r25476] doc/man/gnunet-ats.1: updated man page
+
+2012-12-14 10:02 wachs
+
+ * [r25475] src/include/gnunet_ats_service.h: docu
+
+2012-12-14 10:01 wachs
+
+ * [r25474] src/ats/ats.conf.in,
+ src/ats/gnunet-service-ats_addresses.c,
+ src/include/gnunet_ats_service.h: improved quota loading
+
+2012-12-14 09:28 wachs
+
+ * [r25473] src/ats-tool/gnunet-ats.c: new switch -q to print
+ configured quotas
+
+2012-12-13 19:31 grothoff
+
+ * [r25465] src/regex/regex.c, src/regex/regex_internal.h: reduce
+ reallocing to improve performance
+
+2012-12-13 16:13 wachs
+
+ * [r25459] src/ats/gnunet-service-ats_addresses_simplistic.c:
+ statistics for solver
+
+2012-12-13 13:46 wachs
+
+ * [r25449] src/ats/Makefile.am,
+ src/ats/gnunet-service-ats_addresses_simplistic.c,
+ src/ats/test_ats_api_scheduling_switch_network.c,
+ src/ats/test_ats_simplistic_switch_networks.c: simplistic solver
+ supports moving addresses between networks, test renamed
+
+2012-12-13 13:01 wachs
+
+ * [r25445] src/ats/test_ats_api_scheduling_switch_network.c: test:
+ check network type
+
+2012-12-13 12:41 wachs
+
+ * [r25444] src/ats/test_ats_api_scheduling_switch_network.c:
+ changes
+
+2012-12-12 21:45 grothoff
+
+ * [r25434] src/nat/Makefile.am, src/nat/nat_auto.c: nat auto code
+ from gnunet-gtk now compiles as part of libgnunetnat
+
+2012-12-12 21:44 grothoff
+
+ * [r25433] src/include/gnunet_configuration_lib.h,
+ src/util/configuration.c: adding function to compute
+ configuration differences in memory
+
+2012-12-12 21:22 cfuchs
+
+ * [r25432] src/vpn/gnunet-helper-vpn-windows.c: Added basic
+ functionality for setting IPv4/V6 addresses in win32 using
+ netsh.
+ Added wrapper for launching programs in a windows shell.
+ Added define for _tpopen
+
+2012-12-12 16:51 bartpolot
+
+ * [r25429] src/testbed/gnunet-testbed-profiler.c,
+ src/testbed/testbed_api.c: Run testbed-helper in a sh interactive
+ session to make sure the env is set up properly
+
+2012-12-12 16:15 wachs
+
+ * [r25427] src/ats/Makefile.am,
+ src/ats/gnunet-service-ats_addresses_simplistic.c,
+ src/ats/test_ats_api_scheduling_switch_network.c: changes and
+ test
+
+2012-12-12 15:32 wachs
+
+ * [r25424] src/ats/Makefile.am,
+ src/ats/gnunet-service-ats_addresses.c,
+ src/ats/gnunet-service-ats_addresses.h,
+ src/ats/gnunet-service-ats_addresses_mlp.c,
+ src/ats/gnunet-service-ats_addresses_mlp.h,
+ src/ats/gnunet-service-ats_addresses_simplistic.c,
+ src/ats/gnunet-service-ats_addresses_simplistic.h: updating
+ addresses support changing networks
+
+2012-12-12 13:48 wachs
+
+ * [r25423] src/transport/plugin_transport_tcp.c: fix: tcp did not
+ return network type
+
+2012-12-12 13:28 wachs
+
+ * [r25422] src/ats/gnunet-service-ats.c,
+ src/ats/gnunet-service-ats_addresses.c,
+ src/ats/gnunet-service-ats_addresses.h,
+ src/ats/gnunet-service-ats_addresses_mlp.c,
+ src/ats/gnunet-service-ats_addresses_mlp.h,
+ src/ats/gnunet-service-ats_addresses_simplistic.c,
+ src/ats/gnunet-service-ats_addresses_simplistic.h,
+ src/ats/gnunet-service-ats_performance.c,
+ src/ats/gnunet-service-ats_performance.h,
+ src/ats/gnunet-service-ats_scheduling.c, src/sysmon/Makefile.am,
+ src/sysmon/gnunet-daemon-sysmon.c,
+ src/sysmon/gnunet-service-sysmon.c, src/sysmon/sysmon.conf.in:
+ changes
+
+2012-12-12 11:25 bartpolot
+
+ * [r25420] src/mesh/gnunet-