aboutsummaryrefslogtreecommitdiff
path: root/src/statistics/Makefile.am
diff options
context:
space:
mode:
authorDavid Barksdale <amatus.amongus@gmail.com>2013-07-22 08:26:16 -0500
committerDavid Barksdale <amatus.amongus@gmail.com>2013-08-01 08:12:45 -0500
commit000ad0090a0b4eb9889f4c45d35d4d7af2dbbe27 (patch)
treedda00bef19b649c154ba6a2b37f0f73fa1697c30 /src/statistics/Makefile.am
parent0f8d8bc0c5c09246d647d233767cf3437c6e8bcd (diff)
Imported Upstream version 0.9.5a
Diffstat (limited to 'src/statistics/Makefile.am')
-rw-r--r--src/statistics/Makefile.am23
1 files changed, 18 insertions, 5 deletions
diff --git a/src/statistics/Makefile.am b/src/statistics/Makefile.am
index ddf5fda..fe79212 100644
--- a/src/statistics/Makefile.am
+++ b/src/statistics/Makefile.am
@@ -11,6 +11,8 @@ endif
pkgcfgdir= $(pkgdatadir)/config.d/
+libexecdir= $(pkglibdir)/libexec/
+
pkgcfg_DATA = \
statistics.conf
@@ -23,12 +25,13 @@ libgnunetstatistics_la_LIBADD = \
$(GN_LIBINTL) $(XLIB)
libgnunetstatistics_la_LDFLAGS = \
$(GN_LIB_LDFLAGS) $(WINFLAGS) \
- -version-info 1:1:1
+ -version-info 1:2:1
+libexec_PROGRAMS = \
+ gnunet-service-statistics
bin_PROGRAMS = \
- gnunet-statistics \
- gnunet-service-statistics
+ gnunet-statistics
gnunet_statistics_SOURCES = \
gnunet-statistics.c
@@ -83,10 +86,20 @@ test_statistics_api_watch_zero_value_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la
check_SCRIPTS = \
- test_gnunet_statistics.sh
+ test_gnunet_statistics.py
+
+do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
+
+%.py: %.py.in Makefile
+ $(do_subst) < $(srcdir)/$< > $@
+ chmod +x $@
+
+test_gnunet_statistics.py: test_gnunet_statistics.py.in Makefile
+ $(do_subst) < $(srcdir)/test_gnunet_statistics.py.in > test_gnunet_statistics.py
+ chmod +x test_gnunet_statistics.py
EXTRA_DIST = \
test_statistics_api_data.conf \
- $(check_SCRIPTS)
+ test_gnunet_statistics.py.in