aboutsummaryrefslogtreecommitdiff
path: root/src/include
diff options
context:
space:
mode:
authorDavid Barksdale <amatus.amongus@gmail.com>2013-07-22 08:26:16 -0500
committerDavid Barksdale <amatus.amongus@gmail.com>2013-07-22 08:26:16 -0500
commit7450bd0b6c6c05ee6425e2c63e9b79beb94bfbfa (patch)
treedfde89b41437def7ce23af24db53a11a9b5f1075 /src/include
parent740b30688bd745a527f96f9116c19acb3480971a (diff)
Imported Upstream version 0.9.5aupstream
Diffstat (limited to 'src/include')
-rw-r--r--src/include/Makefile.am19
-rw-r--r--src/include/Makefile.in160
-rw-r--r--src/include/block_dns.h2
-rw-r--r--src/include/block_fs.h4
-rw-r--r--src/include/block_gns.h30
-rw-r--r--src/include/block_mesh.h64
-rw-r--r--src/include/block_regex.h120
-rw-r--r--src/include/gauger.h45
-rw-r--r--src/include/gns_protocol.h161
-rw-r--r--src/include/gnunet_applications.h15
-rw-r--r--src/include/gnunet_arm_service.h3
-rw-r--r--src/include/gnunet_ats_service.h136
-rw-r--r--src/include/gnunet_block_lib.h43
-rw-r--r--src/include/gnunet_block_plugin.h4
-rw-r--r--src/include/gnunet_chat_service.h6
-rw-r--r--src/include/gnunet_common.h131
-rw-r--r--src/include/gnunet_configuration_lib.h47
-rw-r--r--src/include/gnunet_constants.h33
-rw-r--r--src/include/gnunet_container_lib.h192
-rw-r--r--src/include/gnunet_core_service.h53
-rw-r--r--src/include/gnunet_crypto_lib.h449
-rw-r--r--src/include/gnunet_datacache_lib.h24
-rw-r--r--src/include/gnunet_datacache_plugin.h16
-rw-r--r--src/include/gnunet_datastore_plugin.h13
-rw-r--r--src/include/gnunet_datastore_service.h8
-rw-r--r--src/include/gnunet_dht_service.h40
-rw-r--r--src/include/gnunet_disk_lib.h248
-rw-r--r--src/include/gnunet_dnsparser_lib.h196
-rw-r--r--src/include/gnunet_dnsstub_lib.h124
-rw-r--r--src/include/gnunet_fragmentation_lib.h19
-rw-r--r--src/include/gnunet_fs_service.h102
-rw-r--r--src/include/gnunet_getopt_lib.h24
-rw-r--r--src/include/gnunet_gns_service.h172
-rw-r--r--src/include/gnunet_hello_lib.h45
-rw-r--r--src/include/gnunet_helper_lib.h28
-rw-r--r--src/include/gnunet_lockmanager_service.h7
-rw-r--r--src/include/gnunet_mesh_service.h194
-rw-r--r--src/include/gnunet_namestore_plugin.h2
-rw-r--r--src/include/gnunet_namestore_service.h127
-rw-r--r--src/include/gnunet_nat_lib.h42
-rw-r--r--src/include/gnunet_network_lib.h39
-rw-r--r--src/include/gnunet_os_lib.h72
-rw-r--r--src/include/gnunet_peer_lib.h18
-rw-r--r--src/include/gnunet_protocols.h404
-rw-r--r--src/include/gnunet_pseudonym_lib.h14
-rw-r--r--src/include/gnunet_regex_lib.h234
-rw-r--r--src/include/gnunet_scheduler_lib.h2
-rw-r--r--src/include/gnunet_server_lib.h26
-rw-r--r--src/include/gnunet_stream_lib.h118
-rw-r--r--src/include/gnunet_strings_lib.h171
-rw-r--r--src/include/gnunet_testbed_service.h973
-rw-r--r--src/include/gnunet_testing_lib-new.h299
-rw-r--r--src/include/gnunet_testing_lib.h1315
-rw-r--r--src/include/gnunet_time_lib.h28
-rw-r--r--src/include/gnunet_transport_plugin.h22
-rw-r--r--src/include/gnunet_transport_service.h115
-rw-r--r--src/include/gnunet_vpn_service.h2
-rw-r--r--src/include/platform.h19
-rw-r--r--src/include/winproc.h1
59 files changed, 4601 insertions, 2419 deletions
diff --git a/src/include/Makefile.am b/src/include/Makefile.am
index 34a879f..67cee97 100644
--- a/src/include/Makefile.am
+++ b/src/include/Makefile.am
@@ -3,22 +3,23 @@ SUBDIRS = .
gnunetincludedir = $(includedir)/gnunet
nodist_gnunetinclude_HEADERS = \
- gnunet_directories.h \
- block_fs.h
+ gnunet_directories.h
if MINGW
WINPROC = winproc.h
endif
-gnunetinclude_HEADERS = \
+EXTRA_DIST = \
gauger.h \
- gettext.h \
- platform.h \
- plibc.h \
- $(WINPROC) \
+ block_fs.h \
block_dns.h \
block_gns.h \
- block_fs.h \
+ block_mesh.h \
+ block_regex.h
+
+gnunetinclude_HEADERS = \
+ platform.h plibc.h $(WINPROC) gettext.h \
+ gns_protocol.h \
gnunet_applications.h \
gnunet_arm_service.h \
gnunet_ats_service.h \
@@ -42,6 +43,7 @@ gnunetinclude_HEADERS = \
gnunet_dht_service.h \
gnunet_disk_lib.h \
gnunet_dnsparser_lib.h \
+ gnunet_dnsstub_lib.h \
gnunet_dns_service.h \
gnunet_dv_service.h \
gnunet_fragmentation_lib.h \
@@ -79,7 +81,6 @@ gnunetinclude_HEADERS = \
gnunet_strings_lib.h \
gnunet_testbed_service.h \
gnunet_testing_lib.h \
- gnunet_testing_lib-new.h \
gnunet_time_lib.h \
gnunet_transport_service.h \
gnunet_transport_plugin.h \
diff --git a/src/include/Makefile.in b/src/include/Makefile.in
index ac6b874..8f2880a 100644
--- a/src/include/Makefile.in
+++ b/src/include/Makefile.in
@@ -1,9 +1,9 @@
-# Makefile.in generated by automake 1.11.1 from Makefile.am.
+# Makefile.in generated by automake 1.11.6 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation,
-# Inc.
+# 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free Software
+# Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -16,6 +16,23 @@
@SET_MAKE@
VPATH = @srcdir@
+am__make_dryrun = \
+ { \
+ am__dry=no; \
+ case $$MAKEFLAGS in \
+ *\\[\ \ ]*) \
+ echo 'am--echo: ; @echo "AM" OK' | $(MAKE) -f - 2>/dev/null \
+ | grep '^AM OK$$' >/dev/null || am__dry=yes;; \
+ *) \
+ for am__flg in $$MAKEFLAGS; do \
+ case $$am__flg in \
+ *=*|--*) ;; \
+ *n*) am__dry=yes; break;; \
+ esac; \
+ done;; \
+ esac; \
+ test $$am__dry = yes; \
+ }
pkgdatadir = $(datadir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
@@ -41,14 +58,15 @@ DIST_COMMON = $(am__gnunetinclude_HEADERS_DIST) $(srcdir)/Makefile.am \
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/absolute-header.m4 \
$(top_srcdir)/m4/align.m4 $(top_srcdir)/m4/argz.m4 \
- $(top_srcdir)/m4/gettext.m4 $(top_srcdir)/m4/iconv.m4 \
- $(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
- $(top_srcdir)/m4/lib-prefix.m4 $(top_srcdir)/m4/libcurl.m4 \
- $(top_srcdir)/m4/libgcrypt.m4 $(top_srcdir)/m4/libtool.m4 \
- $(top_srcdir)/m4/libunistring.m4 $(top_srcdir)/m4/ltdl.m4 \
- $(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
- $(top_srcdir)/m4/ltversion.m4 $(top_srcdir)/m4/lt~obsolete.m4 \
- $(top_srcdir)/m4/nls.m4 $(top_srcdir)/m4/po.m4 \
+ $(top_srcdir)/m4/gettext.m4 $(top_srcdir)/m4/glib-2.0.m4 \
+ $(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/lib-ld.m4 \
+ $(top_srcdir)/m4/lib-link.m4 $(top_srcdir)/m4/lib-prefix.m4 \
+ $(top_srcdir)/m4/libcurl.m4 $(top_srcdir)/m4/libgcrypt.m4 \
+ $(top_srcdir)/m4/libtool.m4 $(top_srcdir)/m4/libunistring.m4 \
+ $(top_srcdir)/m4/ltdl.m4 $(top_srcdir)/m4/ltoptions.m4 \
+ $(top_srcdir)/m4/ltsugar.m4 $(top_srcdir)/m4/ltversion.m4 \
+ $(top_srcdir)/m4/lt~obsolete.m4 $(top_srcdir)/m4/nls.m4 \
+ $(top_srcdir)/m4/pkg.m4 $(top_srcdir)/m4/po.m4 \
$(top_srcdir)/m4/progtest.m4 $(top_srcdir)/acinclude.m4 \
$(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
@@ -57,11 +75,11 @@ mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/gnunet_config.h
CONFIG_CLEAN_FILES = gnunet_directories.h
CONFIG_CLEAN_VPATH_FILES =
-AM_V_GEN = $(am__v_GEN_$(V))
-am__v_GEN_ = $(am__v_GEN_$(AM_DEFAULT_VERBOSITY))
+AM_V_GEN = $(am__v_GEN_@AM_V@)
+am__v_GEN_ = $(am__v_GEN_@AM_DEFAULT_V@)
am__v_GEN_0 = @echo " GEN " $@;
-AM_V_at = $(am__v_at_$(V))
-am__v_at_ = $(am__v_at_$(AM_DEFAULT_VERBOSITY))
+AM_V_at = $(am__v_at_@AM_V@)
+am__v_at_ = $(am__v_at_@AM_DEFAULT_V@)
am__v_at_0 = @
SOURCES =
DIST_SOURCES =
@@ -72,21 +90,27 @@ RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
install-pdf-recursive install-ps-recursive install-recursive \
installcheck-recursive installdirs-recursive pdf-recursive \
ps-recursive uninstall-recursive
-am__gnunetinclude_HEADERS_DIST = gauger.h gettext.h platform.h plibc.h \
- winproc.h block_dns.h block_gns.h block_fs.h \
- gnunet_applications.h gnunet_arm_service.h \
- gnunet_ats_service.h gnunet_bandwidth_lib.h gnunet_bio_lib.h \
- gnunet_block_lib.h gnunet_block_plugin.h gnunet_client_lib.h \
+am__can_run_installinfo = \
+ case $$AM_UPDATE_INFO_DIR in \
+ n|no|NO) false;; \
+ *) (install-info --version) >/dev/null 2>&1;; \
+ esac
+am__gnunetinclude_HEADERS_DIST = platform.h plibc.h winproc.h \
+ gettext.h gns_protocol.h gnunet_applications.h \
+ gnunet_arm_service.h gnunet_ats_service.h \
+ gnunet_bandwidth_lib.h gnunet_bio_lib.h gnunet_block_lib.h \
+ gnunet_block_plugin.h gnunet_client_lib.h \
gnunet_chat_service.h gnunet_common.h gnunet_constants.h \
gnunet_configuration_lib.h gnunet_container_lib.h \
gnunet_connection_lib.h gnunet_core_service.h \
gnunet_crypto_lib.h gnunet_datacache_lib.h \
gnunet_datacache_plugin.h gnunet_datastore_service.h \
gnunet_datastore_plugin.h gnunet_dht_service.h \
- gnunet_disk_lib.h gnunet_dnsparser_lib.h gnunet_dns_service.h \
- gnunet_dv_service.h gnunet_fragmentation_lib.h \
- gnunet_fs_service.h gnunet_getopt_lib.h gnunet_gns_service.h \
- gnunet_hello_lib.h gnunet_helper_lib.h gnunet_load_lib.h \
+ gnunet_disk_lib.h gnunet_dnsparser_lib.h gnunet_dnsstub_lib.h \
+ gnunet_dns_service.h gnunet_dv_service.h \
+ gnunet_fragmentation_lib.h gnunet_fs_service.h \
+ gnunet_getopt_lib.h gnunet_gns_service.h gnunet_hello_lib.h \
+ gnunet_helper_lib.h gnunet_load_lib.h \
gnunet_lockmanager_service.h gnunet_mesh_service.h \
gnunet_mysql_lib.h gnunet_namestore_plugin.h \
gnunet_namestore_service.h gnunet_nat_lib.h \
@@ -99,10 +123,9 @@ am__gnunetinclude_HEADERS_DIST = gauger.h gettext.h platform.h plibc.h \
gnunet_service_lib.h gnunet_signal_lib.h gnunet_signatures.h \
gnunet_statistics_service.h gnunet_stream_lib.h \
gnunet_strings_lib.h gnunet_testbed_service.h \
- gnunet_testing_lib.h gnunet_testing_lib-new.h \
- gnunet_time_lib.h gnunet_transport_service.h \
- gnunet_transport_plugin.h gnunet_tun_lib.h gnunet_util_lib.h \
- gnunet_vpn_service.h
+ gnunet_testing_lib.h gnunet_time_lib.h \
+ gnunet_transport_service.h gnunet_transport_plugin.h \
+ gnunet_tun_lib.h gnunet_util_lib.h gnunet_vpn_service.h
am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
am__vpath_adj = case $$p in \
$(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
@@ -124,6 +147,12 @@ am__nobase_list = $(am__nobase_strip_setup); \
am__base_list = \
sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
+am__uninstall_files_from_dir = { \
+ test -z "$$files" \
+ || { test ! -d "$$dir" && test ! -f "$$dir" && test ! -r "$$dir"; } \
+ || { echo " ( cd '$$dir' && rm -f" $$files ")"; \
+ $(am__cd) "$$dir" && rm -f $$files; }; \
+ }
am__installdirs = "$(DESTDIR)$(gnunetincludedir)" \
"$(DESTDIR)$(gnunetincludedir)"
HEADERS = $(gnunetinclude_HEADERS) $(nodist_gnunetinclude_HEADERS)
@@ -196,6 +225,10 @@ EXEEXT = @EXEEXT@
EXT_LIBS = @EXT_LIBS@
EXT_LIB_PATH = @EXT_LIB_PATH@
FGREP = @FGREP@
+GLIB_CFLAGS = @GLIB_CFLAGS@
+GLIB_GENMARSHAL = @GLIB_GENMARSHAL@
+GLIB_LIBS = @GLIB_LIBS@
+GLIB_MKENUMS = @GLIB_MKENUMS@
GMSGFMT = @GMSGFMT@
GMSGFMT_015 = @GMSGFMT_015@
GNUNETDNS_GROUP = @GNUNETDNS_GROUP@
@@ -206,6 +239,7 @@ GN_LIBINTL = @GN_LIBINTL@
GN_LIB_LDFLAGS = @GN_LIB_LDFLAGS@
GN_PLUGIN_LDFLAGS = @GN_PLUGIN_LDFLAGS@
GN_USER_HOME_DIR = @GN_USER_HOME_DIR@
+GOBJECT_QUERY = @GOBJECT_QUERY@
GREP = @GREP@
HAVE_LIBUNISTRING = @HAVE_LIBUNISTRING@
INCLTDL = @INCLTDL@
@@ -228,6 +262,8 @@ LIBCURL_CPPFLAGS = @LIBCURL_CPPFLAGS@
LIBGCRYPT_CFLAGS = @LIBGCRYPT_CFLAGS@
LIBGCRYPT_CONFIG = @LIBGCRYPT_CONFIG@
LIBGCRYPT_LIBS = @LIBGCRYPT_LIBS@
+LIBGTOP_CFLAGS = @LIBGTOP_CFLAGS@
+LIBGTOP_LIBS = @LIBGTOP_LIBS@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
LIBLTDL = @LIBLTDL@
@@ -249,6 +285,7 @@ LT_CONFIG_H = @LT_CONFIG_H@
LT_DLLOADERS = @LT_DLLOADERS@
LT_DLPREOPEN = @LT_DLPREOPEN@
MAKEINFO = @MAKEINFO@
+MANIFEST_TOOL = @MANIFEST_TOOL@
MKDIR_P = @MKDIR_P@
MONKEYPREFIX = @MONKEYPREFIX@
MSGFMT = @MSGFMT@
@@ -258,6 +295,7 @@ MYSQL_CPPFLAGS = @MYSQL_CPPFLAGS@
MYSQL_LDFLAGS = @MYSQL_LDFLAGS@
NM = @NM@
NMEDIT = @NMEDIT@
+NSS_DIR = @NSS_DIR@
OBJC = @OBJC@
OBJCDEPMODE = @OBJCDEPMODE@
OBJCFLAGS = @OBJCFLAGS@
@@ -273,6 +311,7 @@ PACKAGE_TARNAME = @PACKAGE_TARNAME@
PACKAGE_URL = @PACKAGE_URL@
PACKAGE_VERSION = @PACKAGE_VERSION@
PATH_SEPARATOR = @PATH_SEPARATOR@
+PKG_CONFIG = @PKG_CONFIG@
POSTGRES_CPPFLAGS = @POSTGRES_CPPFLAGS@
POSTGRES_LDFLAGS = @POSTGRES_LDFLAGS@
POSUB = @POSUB@
@@ -304,6 +343,7 @@ abs_builddir = @abs_builddir@
abs_srcdir = @abs_srcdir@
abs_top_builddir = @abs_top_builddir@
abs_top_srcdir = @abs_top_srcdir@
+ac_ct_AR = @ac_ct_AR@
ac_ct_CC = @ac_ct_CC@
ac_ct_CXX = @ac_ct_CXX@
ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
@@ -326,6 +366,7 @@ datarootdir = @datarootdir@
docdir = @docdir@
dvidir = @dvidir@
exec_prefix = @exec_prefix@
+gitcommand = @gitcommand@
host = @host@
host_alias = @host_alias@
host_cpu = @host_cpu@
@@ -339,7 +380,6 @@ libdir = @libdir@
libexecdir = @libexecdir@
localedir = @localedir@
localstatedir = @localstatedir@
-lt_ECHO = @lt_ECHO@
ltdl_LIBOBJS = @ltdl_LIBOBJS@
ltdl_LTLIBOBJS = @ltdl_LTLIBOBJS@
mandir = @mandir@
@@ -357,6 +397,7 @@ sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
srcdir = @srcdir@
subdirs = @subdirs@
+svnversioncommand = @svnversioncommand@
sys_symbol_underscore = @sys_symbol_underscore@
sysconfdir = @sysconfdir@
target = @target@
@@ -370,19 +411,20 @@ top_srcdir = @top_srcdir@
SUBDIRS = .
gnunetincludedir = $(includedir)/gnunet
nodist_gnunetinclude_HEADERS = \
- gnunet_directories.h \
- block_fs.h
+ gnunet_directories.h
@MINGW_TRUE@WINPROC = winproc.h
-gnunetinclude_HEADERS = \
+EXTRA_DIST = \
gauger.h \
- gettext.h \
- platform.h \
- plibc.h \
- $(WINPROC) \
+ block_fs.h \
block_dns.h \
block_gns.h \
- block_fs.h \
+ block_mesh.h \
+ block_regex.h
+
+gnunetinclude_HEADERS = \
+ platform.h plibc.h $(WINPROC) gettext.h \
+ gns_protocol.h \
gnunet_applications.h \
gnunet_arm_service.h \
gnunet_ats_service.h \
@@ -406,6 +448,7 @@ gnunetinclude_HEADERS = \
gnunet_dht_service.h \
gnunet_disk_lib.h \
gnunet_dnsparser_lib.h \
+ gnunet_dnsstub_lib.h \
gnunet_dns_service.h \
gnunet_dv_service.h \
gnunet_fragmentation_lib.h \
@@ -443,7 +486,6 @@ gnunetinclude_HEADERS = \
gnunet_strings_lib.h \
gnunet_testbed_service.h \
gnunet_testing_lib.h \
- gnunet_testing_lib-new.h \
gnunet_time_lib.h \
gnunet_transport_service.h \
gnunet_transport_plugin.h \
@@ -494,8 +536,11 @@ clean-libtool:
-rm -rf .libs _libs
install-gnunetincludeHEADERS: $(gnunetinclude_HEADERS)
@$(NORMAL_INSTALL)
- test -z "$(gnunetincludedir)" || $(MKDIR_P) "$(DESTDIR)$(gnunetincludedir)"
@list='$(gnunetinclude_HEADERS)'; test -n "$(gnunetincludedir)" || list=; \
+ if test -n "$$list"; then \
+ echo " $(MKDIR_P) '$(DESTDIR)$(gnunetincludedir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(gnunetincludedir)" || exit 1; \
+ fi; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \
@@ -509,13 +554,14 @@ uninstall-gnunetincludeHEADERS:
@$(NORMAL_UNINSTALL)
@list='$(gnunetinclude_HEADERS)'; test -n "$(gnunetincludedir)" || list=; \
files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
- test -n "$$files" || exit 0; \
- echo " ( cd '$(DESTDIR)$(gnunetincludedir)' && rm -f" $$files ")"; \
- cd "$(DESTDIR)$(gnunetincludedir)" && rm -f $$files
+ dir='$(DESTDIR)$(gnunetincludedir)'; $(am__uninstall_files_from_dir)
install-nodist_gnunetincludeHEADERS: $(nodist_gnunetinclude_HEADERS)
@$(NORMAL_INSTALL)
- test -z "$(gnunetincludedir)" || $(MKDIR_P) "$(DESTDIR)$(gnunetincludedir)"
@list='$(nodist_gnunetinclude_HEADERS)'; test -n "$(gnunetincludedir)" || list=; \
+ if test -n "$$list"; then \
+ echo " $(MKDIR_P) '$(DESTDIR)$(gnunetincludedir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(gnunetincludedir)" || exit 1; \
+ fi; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \
@@ -529,9 +575,7 @@ uninstall-nodist_gnunetincludeHEADERS:
@$(NORMAL_UNINSTALL)
@list='$(nodist_gnunetinclude_HEADERS)'; test -n "$(gnunetincludedir)" || list=; \
files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
- test -n "$$files" || exit 0; \
- echo " ( cd '$(DESTDIR)$(gnunetincludedir)' && rm -f" $$files ")"; \
- cd "$(DESTDIR)$(gnunetincludedir)" && rm -f $$files
+ dir='$(DESTDIR)$(gnunetincludedir)'; $(am__uninstall_files_from_dir)
# This directory's subdirectories are mostly independent; you can cd
# into them and run `make' without going through this Makefile.
@@ -700,13 +744,10 @@ distdir: $(DISTFILES)
done
@list='$(DIST_SUBDIRS)'; for subdir in $$list; do \
if test "$$subdir" = .; then :; else \
- test -d "$(distdir)/$$subdir" \
- || $(MKDIR_P) "$(distdir)/$$subdir" \
- || exit 1; \
- fi; \
- done
- @list='$(DIST_SUBDIRS)'; for subdir in $$list; do \
- if test "$$subdir" = .; then :; else \
+ $(am__make_dryrun) \
+ || test -d "$(distdir)/$$subdir" \
+ || $(MKDIR_P) "$(distdir)/$$subdir" \
+ || exit 1; \
dir1=$$subdir; dir2="$(distdir)/$$subdir"; \
$(am__relativize); \
new_distdir=$$reldir; \
@@ -744,10 +785,15 @@ install-am: all-am
installcheck: installcheck-recursive
install-strip:
- $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
- install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
- `test -z '$(STRIP)' || \
- echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
+ if test -z '$(STRIP)'; then \
+ $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
+ install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
+ install; \
+ else \
+ $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
+ install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
+ "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'" install; \
+ fi
mostlyclean-generic:
clean-generic:
diff --git a/src/include/block_dns.h b/src/include/block_dns.h
index e047779..0ca5a47 100644
--- a/src/include/block_dns.h
+++ b/src/include/block_dns.h
@@ -64,7 +64,7 @@ struct GNUNET_DNS_Record
* The descriptor for the service
* (a peer may provide more than one service)
*/
- GNUNET_HashCode service_descriptor;
+ struct GNUNET_HashCode service_descriptor;
/**
* When does this record expire?
diff --git a/src/include/block_fs.h b/src/include/block_fs.h
index aae741e..0b77adc 100644
--- a/src/include/block_fs.h
+++ b/src/include/block_fs.h
@@ -78,7 +78,7 @@ struct SBlock
* used as the key for decryption; the xor of this identifier
* and the hash of the "keyspace" is the datastore-query hash).
*/
- GNUNET_HashCode identifier;
+ struct GNUNET_HashCode identifier;
/**
* Public key of the namespace.
@@ -153,7 +153,7 @@ struct OnDemandBlock
* file that was indexed (used to uniquely
* identify the plaintext file).
*/
- GNUNET_HashCode file_id;
+ struct GNUNET_HashCode file_id;
/**
* At which offset should we be able to find
diff --git a/src/include/block_gns.h b/src/include/block_gns.h
index ffdb294..7b4ceed 100644
--- a/src/include/block_gns.h
+++ b/src/include/block_gns.h
@@ -31,34 +31,6 @@
GNUNET_NETWORK_STRUCT_BEGIN
/**
- * @brief a simgle record inside a record block
- */
-struct GNSRecordBlock
-{
- /**
- * the record type
- */
- uint32_t type GNUNET_PACKED;
-
- /**
- * expiration time of the record
- */
- struct GNUNET_TIME_AbsoluteNBO expiration;
-
- /**
- * length of the data
- */
- uint32_t data_length GNUNET_PACKED;
-
- /* record flags */
- uint32_t flags GNUNET_PACKED;
-
- //Class of the record?
-
- /* followed by the record data */
-};
-
-/**
* @brief a record block for a given name of a single authority
*/
struct GNSNameRecordBlock
@@ -79,7 +51,7 @@ struct GNSNameRecordBlock
/* 0-terminated name here */
- /* variable-size GNSRecordBlocks follows here */
+ /* variable-size serialized namestore record data */
};
diff --git a/src/include/block_mesh.h b/src/include/block_mesh.h
new file mode 100644
index 0000000..9dfb859
--- /dev/null
+++ b/src/include/block_mesh.h
@@ -0,0 +1,64 @@
+/*
+ This file is part of GNUnet.
+ (C) 2012,2013 Christian Grothoff (and other contributing authors)
+
+ GNUnet is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published
+ by the Free Software Foundation; either version 3, or (at your
+ option) any later version.
+
+ GNUnet is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with GNUnet; see the file COPYING. If not, write to the
+ Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+ Boston, MA 02111-1307, USA.
+*/
+
+/**
+ * @file include/block_mesh.h
+ * @brief Mesh block formats.
+ * @author Bartlomiej Polot
+ */
+#ifndef BLOCK_MESH_H
+#define BLOCK_MESH_H
+
+#ifdef __cplusplus
+extern "C"
+{
+#if 0 /* keep Emacsens' auto-indent happy */
+}
+#endif
+#endif
+
+#include "gnunet_util_lib.h"
+#include "gnunet_mesh_service.h"
+#include <stdint.h>
+
+/**
+ * @brief peer block (announce peer + type)
+ */
+struct PBlock
+{
+ /**
+ * Identity of the peer
+ */
+ struct GNUNET_PeerIdentity id;
+
+ /**
+ * Type of service offered
+ */
+ GNUNET_MESH_ApplicationType type;
+};
+
+#if 0 /* keep Emacsens' auto-indent happy */
+{
+#endif
+#ifdef __cplusplus
+}
+#endif
+
+#endif \ No newline at end of file
diff --git a/src/include/block_regex.h b/src/include/block_regex.h
new file mode 100644
index 0000000..282c626
--- /dev/null
+++ b/src/include/block_regex.h
@@ -0,0 +1,120 @@
+/*
+ This file is part of GNUnet.
+ (C) 2012,2013 Christian Grothoff (and other contributing authors)
+
+ GNUnet is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published
+ by the Free Software Foundation; either version 3, or (at your
+ option) any later version.
+
+ GNUnet is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with GNUnet; see the file COPYING. If not, write to the
+ Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+ Boston, MA 02111-1307, USA.
+*/
+
+/**
+ * @file include/block_regex.h
+ * @brief regex block formats
+ * @author Bartlomiej Polot
+ */
+#ifndef BLOCK_REGEX_H
+#define BLOCK_REGEX_H
+
+#ifdef __cplusplus
+extern "C"
+{
+#if 0
+ /* keep Emacsens' auto-indent happy */
+}
+#endif
+#endif
+
+#include "gnunet_util_lib.h"
+#include <stdint.h>
+
+
+/**
+ * @brief A RegexBlock contains one or more of this struct in the payload.
+ */
+struct RegexEdge
+{
+ /**
+ * Destination of this edge.
+ */
+ struct GNUNET_HashCode key;
+
+ /**
+ * Length of the token towards the new state.
+ */
+ unsigned int n_token;
+
+ /* char token[n_token] */
+};
+
+/**
+ * @brief Block to announce a regex state.
+ */
+struct RegexBlock
+{
+ /**
+ * The key of the state.
+ */
+ struct GNUNET_HashCode key;
+
+ /**
+ * Length of the proof regex string.
+ */
+ unsigned int n_proof;
+
+ /**
+ * Numer of edges parting from this state.
+ */
+ unsigned int n_edges;
+
+ /**
+ * Is this state an accepting state?
+ */
+ int accepting;
+
+ /* char proof[n_proof] */
+ /* struct RegexEdge edges[n_edges] */
+};
+
+/**
+ * @brief Block to announce a pee