summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/autoconf
diff options
context:
space:
mode:
Diffstat (limited to 'org.handhelds.familiar/packages/autoconf')
-rw-r--r--org.handhelds.familiar/packages/autoconf/autoconf-2.59/autoconf-x.patch36
-rw-r--r--org.handhelds.familiar/packages/autoconf/autoconf-2.59/sizeof_types.patch64
-rw-r--r--org.handhelds.familiar/packages/autoconf/autoconf_2.59.bb1
3 files changed, 83 insertions, 18 deletions
diff --git a/org.handhelds.familiar/packages/autoconf/autoconf-2.59/autoconf-x.patch b/org.handhelds.familiar/packages/autoconf/autoconf-2.59/autoconf-x.patch
new file mode 100644
index 0000000..596535b
--- /dev/null
+++ b/org.handhelds.familiar/packages/autoconf/autoconf-2.59/autoconf-x.patch
@@ -0,0 +1,36 @@
+Index: lib/autoconf/libs.m4
+===================================================================
+RCS file: /cvsroot/autoconf/autoconf/lib/autoconf/libs.m4,v
+retrieving revision 1.13
+diff -p -u -r1.13 libs.m4
+--- autoconf-2.59/lib/autoconf/libs.m4 6 Sep 2005 15:34:06 -0000 1.13
++++ autoconf-2.59/lib/autoconf/libs.m4 18 Sep 2005 17:09:58 -0000
+@@ -265,13 +265,13 @@ ac_x_header_dirs='
+ /usr/openwin/share/include'
+
+ if test "$ac_x_includes" = no; then
+- # Guess where to find include files, by looking for Intrinsic.h.
++ # Guess where to find include files, by looking for Xlib.h.
+ # First, try using that file with no special directory specified.
+- AC_PREPROC_IFELSE([AC_LANG_SOURCE([@%:@include <X11/Intrinsic.h>])],
++ AC_PREPROC_IFELSE([AC_LANG_SOURCE([@%:@include <X11/Xlib.h>])],
+ [# We can compile using X headers with no special include directory.
+ ac_x_includes=],
+ [for ac_dir in $ac_x_header_dirs; do
+- if test -r "$ac_dir/X11/Intrinsic.h"; then
++ if test -r "$ac_dir/X11/Xlib.h"; then
+ ac_x_includes=$ac_dir
+ break
+ fi
+@@ -284,9 +284,9 @@ if test "$ac_x_libraries" = no; then
+ # Don't add to $LIBS permanently.
+ ac_save_LIBS=$LIBS
+- LIBS="-lXt $LIBS"
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([@%:@include <X11/Intrinsic.h>],
+- [XtMalloc (0)])],
++ LIBS="-lX11 $LIBS"
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([@%:@include <X11/Xlib.h>],
++ [XrmInitialize ()])],
+ [LIBS=$ac_save_LIBS
+ # We can link X programs with no special library path.
+ ac_x_libraries=],
diff --git a/org.handhelds.familiar/packages/autoconf/autoconf-2.59/sizeof_types.patch b/org.handhelds.familiar/packages/autoconf/autoconf-2.59/sizeof_types.patch
index 9a6e474..30fd5c1 100644
--- a/org.handhelds.familiar/packages/autoconf/autoconf-2.59/sizeof_types.patch
+++ b/org.handhelds.familiar/packages/autoconf/autoconf-2.59/sizeof_types.patch
@@ -3,15 +3,38 @@
# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
#
---- autoconf-2.59/lib/autoconf/types.m4~sizeof_types.patch 2003-05-22 08:05:14.000000000 -0400
-+++ autoconf-2.59/lib/autoconf/types.m4 2004-05-29 01:31:24.828295015 -0400
-@@ -380,32 +380,38 @@
+Index: autoconf-2.59/lib/autoconf/types.m4
+===================================================================
+--- autoconf-2.59.orig/lib/autoconf/types.m4 2003-05-22 14:05:14.000000000 +0200
++++ autoconf-2.59/lib/autoconf/types.m4 2006-08-06 02:05:02.000000000 +0200
+@@ -380,26 +380,66 @@
# Generic checks. #
# ---------------- #
++# Backport of AC_CHECK_TARGET_TOOL from autoconf 2.60
++# AC_CHECK_TARGET_TOOL(VARIABLE, PROG-TO-CHECK-FOR, [VALUE-IF-NOT-FOUND], [PATH )
++# ------------------------------------------------------------------------
++# (Use different variables $1 and ac_ct_$1 so that cache vars don't conflict.)
++AC_DEFUN([AC_CHECK_TARGET_TOOL],
++[AC_BEFORE([$0], [AC_CANONICAL_TARGET])dnl
++AC_CHECK_PROG([$1], [$target_alias-$2], [$target_alias-$2], , [$4])
++if test -z "$ac_cv_prog_$1"; then
++ if test "$build" = "$target"; then
++ ac_ct_$1=$$1
++ AC_CHECK_PROG([ac_ct_$1], [$2], [$2], [$3], [$4])
++ $1=ac_ct_$1
++ else
++ $1="$3"
++ fi
++else
++ $1="$ac_cv_prog_$1"
++fi
++])# AC_CHECK_TARGET_TOOL
++
++
+AC_DEFUN([AC_PROG_SIZE],
+[
-+ AC_CHECK_TOOL(SIZE, size, :)
++ AC_CHECK_TARGET_TOOL([SIZE], [size], [size], [$PATH])
+])
# AC_CHECK_SIZEOF(TYPE, [IGNORED], [INCLUDES = DEFAULT-INCLUDES])
@@ -35,14 +58,25 @@
- [AC_MSG_FAILURE([cannot compute sizeof ($1), 77])])
+[
+if test "$AS_TR_SH([ac_cv_type_$1])" = yes; then
-+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([AC_INCLUDES_DEFAULT([$3])],
-+ [static const $1 x[[256]];])],
-+ [
-+ AS_TR_SH([ac_cv_sizeof_$1])=`$SIZE conftest.$ac_objext | tail -n 1 | $AWK '{print [$]3/256}'`
-+ ],
-+ [
-+ AS_TR_SH([ac_cv_sizeof_$1])=0
-+ ])
++ if test "$cross_compiling" = yes; then
++ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([AC_INCLUDES_DEFAULT([$3])],
++ [extern void dummy($1); static const $1 x[[256]]; dummy(x);])],
++ [
++ AS_TR_SH([ac_cv_sizeof_$1])=`$SIZE conftest.$ac_objext | tail -n 1 | $AWK '{print [$]3/256}'`
++ ],
++ [
++ AS_TR_SH([ac_cv_sizeof_$1])=0
++ ])
++ else
++ # The cast to unsigned long works around a bug in the HP C Compiler
++ # version HP92453-01 B.11.11.23709.GP, which incorrectly rejects
++ # declarations like `int a3[[(sizeof (unsigned char)) >= 0]];'.
++ # This bug is HP SR number 8606223364.
++ _AC_COMPUTE_INT([(long) (sizeof ($1))],
++ [AS_TR_SH([ac_cv_sizeof_$1])],
++ [AC_INCLUDES_DEFAULT([$3])],
++ [AC_MSG_FAILURE([cannot compute sizeof ($1), 77])])
++ fi
else
AS_TR_SH([ac_cv_sizeof_$1])=0
-fi])dnl
@@ -51,9 +85,3 @@
AC_DEFINE_UNQUOTED(AS_TR_CPP(sizeof_$1), $AS_TR_SH([ac_cv_sizeof_$1]),
[The size of a `$1', as computed by sizeof.])
])# AC_CHECK_SIZEOF
-
--
--
- # ---------------- #
- # Generic checks. #
- # ---------------- #
diff --git a/org.handhelds.familiar/packages/autoconf/autoconf_2.59.bb b/org.handhelds.familiar/packages/autoconf/autoconf_2.59.bb
index 8636a77..f1eb275 100644
--- a/org.handhelds.familiar/packages/autoconf/autoconf_2.59.bb
+++ b/org.handhelds.familiar/packages/autoconf/autoconf_2.59.bb
@@ -17,5 +17,6 @@ SRC_URI = "${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.bz2 \
file://autoconf259-update-configscripts.patch;patch=1 \
file://autoheader-nonfatal-warnings.patch;patch=1 \
file://sizeof_types.patch;patch=1 \
+ file://autoconf-x.patch;patch=1 \
${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
inherit autotools