summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/mipl-mipv6
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
committerRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
commit5a5346dfbec459c10d9e61e16e125b83975a1ef1 (patch)
tree342e16f3fe790d03b93294344e6154459888939f /org.handhelds.familiar/packages/mipl-mipv6
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e35772d79306d1d9de19c12b23681618532d.
Diffstat (limited to 'org.handhelds.familiar/packages/mipl-mipv6')
-rw-r--r--org.handhelds.familiar/packages/mipl-mipv6/files/outputfix.patch25
-rw-r--r--org.handhelds.familiar/packages/mipl-mipv6/files/sbindir.patch13
-rw-r--r--org.handhelds.familiar/packages/mipl-mipv6/mipv6_1.1-v2.4.26.bb23
3 files changed, 61 insertions, 0 deletions
diff --git a/org.handhelds.familiar/packages/mipl-mipv6/files/outputfix.patch b/org.handhelds.familiar/packages/mipl-mipv6/files/outputfix.patch
new file mode 100644
index 0000000..a2036b9
--- /dev/null
+++ b/org.handhelds.familiar/packages/mipl-mipv6/files/outputfix.patch
@@ -0,0 +1,25 @@
+--- mobile-ip6.in 2005-02-04 15:17:25.134699880 +0100
++++ mobile-ip6.in.new 2005-02-04 16:32:12.274550936 +0100
+@@ -77,7 +77,7 @@
+
+ case "$1" in
+ start)
+- $LSMOD | grep $MIPV6_MODULE &>/dev/null && \
++ $LSMOD | grep $MIPV6_MODULE >/dev/null && \
+ echo "$MIPV6_MODULE already installed" && exit 1
+
+ INSMOD_ARGS=
+@@ -86,11 +86,11 @@
+ INSMOD_ARGS="$INSMOD_ARGS mipv6_debug=$DEBUGLEVEL"
+ fi
+
+- $MODPROBE $MIPV6_BASE_MODULE $INSMOD_ARGS &> /dev/null
++ $MODPROBE $MIPV6_BASE_MODULE $INSMOD_ARGS > /dev/null
+ status=$?
+
+ if [ "$FUNCTIONALITY" = "mn" -o "$FUNCTIONALITY" = "ha" ] ; then
+- $MODPROBE $MIPV6_MODULE &> /dev/null
++ $MODPROBE $MIPV6_MODULE > /dev/null
+ fi
+
+ action "Starting Mobile IPv6:" [ $status -eq 0 ] || exit 1
diff --git a/org.handhelds.familiar/packages/mipl-mipv6/files/sbindir.patch b/org.handhelds.familiar/packages/mipl-mipv6/files/sbindir.patch
new file mode 100644
index 0000000..931d0f7
--- /dev/null
+++ b/org.handhelds.familiar/packages/mipl-mipv6/files/sbindir.patch
@@ -0,0 +1,13 @@
+--- mobile-ip6.in 2005-02-04 15:12:08.225877344 +0100
++++ mobile-ip6.in.new 2005-02-04 15:12:57.588373104 +0100
+@@ -24,8 +24,8 @@
+ SUBSYS=$1
+ LOCKDIR=@LOCKDIR@
+
+-MODPROBE=@sbindir@/modprobe
+-LSMOD=@sbindir@/lsmod
++MODPROBE=`which modprobe`
++LSMOD=`which lsmod`
+
+ # Test if 'functions' exists. If not, define our own 'action'
+ if test -x /etc/rc.d/init.d/functions ; then
diff --git a/org.handhelds.familiar/packages/mipl-mipv6/mipv6_1.1-v2.4.26.bb b/org.handhelds.familiar/packages/mipl-mipv6/mipv6_1.1-v2.4.26.bb
new file mode 100644
index 0000000..6edcc9e
--- /dev/null
+++ b/org.handhelds.familiar/packages/mipl-mipv6/mipv6_1.1-v2.4.26.bb
@@ -0,0 +1,23 @@
+SECTION = "unknown"
+SRC_URI = "http://www.mobile-ipv6.org/software/download/mipv6-${PV}.tar.gz \
+ patch://sbindir.patch;pnum=0;patch=1 \
+ patch://outputfix.patch;pnum=0;patch=1"
+DEPENDS = "virtual/kernel"
+LICENSE = "GPL"
+CFLAGS =+ "-I${S}/include -I${STAGING_KERNEL_DIR}/include"
+
+PACKAGE_ARCH_${PN} = "${MACHINE_ARCH}"
+
+PR="r3"
+
+inherit autotools module-base
+
+do_compile() {
+ oe_runmake CFLAGS="${CFLAGS}"
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}${sysconfdir}/init.d
+ oe_runmake sbindir="${D}${sbindir}" initdir="${D}${sysconfdir}/init.d" mandir="${D}${mandir}" docdir="${D}${docdir}/mobile-ip6" NETWORK_MIP6_CONF="${D}${sysconfdir}" install
+}