summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/grep
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
committerRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
commit5a5346dfbec459c10d9e61e16e125b83975a1ef1 (patch)
tree342e16f3fe790d03b93294344e6154459888939f /org.handhelds.familiar/packages/grep
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e35772d79306d1d9de19c12b23681618532d.
Diffstat (limited to 'org.handhelds.familiar/packages/grep')
-rw-r--r--org.handhelds.familiar/packages/grep/grep-2.5/install.patch15
-rw-r--r--org.handhelds.familiar/packages/grep/grep_2.5.1.bb37
-rw-r--r--org.handhelds.familiar/packages/grep/grep_2.5.bb16
3 files changed, 68 insertions, 0 deletions
diff --git a/org.handhelds.familiar/packages/grep/grep-2.5/install.patch b/org.handhelds.familiar/packages/grep/grep-2.5/install.patch
new file mode 100644
index 0000000..cbb9229
--- /dev/null
+++ b/org.handhelds.familiar/packages/grep/grep-2.5/install.patch
@@ -0,0 +1,15 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- grep-2.5/src/Makefile.am~install
++++ grep-2.5/src/Makefile.am
+@@ -18,5 +18,5 @@
+ vms_fab.c vms_fab.h
+
+ install-exec-local:
+- @SYMLINK@ @SYMLINKFROM@ $(bindir)/egrep
+- @SYMLINK@ @SYMLINKFROM@ $(bindir)/fgrep
++ @SYMLINK@ @SYMLINKFROM@ $(DESTDIR)$(bindir)/egrep
++ @SYMLINK@ @SYMLINKFROM@ $(DESTDIR)$(bindir)/fgrep
diff --git a/org.handhelds.familiar/packages/grep/grep_2.5.1.bb b/org.handhelds.familiar/packages/grep/grep_2.5.1.bb
new file mode 100644
index 0000000..8f6b9b3
--- /dev/null
+++ b/org.handhelds.familiar/packages/grep/grep_2.5.1.bb
@@ -0,0 +1,37 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+DESCRIPTION = "grep GNU utility"
+MAINTAINER = "Pawel Osiczko <p.osiczko@tetrapyloctomy.org>"
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.bz2"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-perl-regexp --disable-ncurses"
+
+do_configure () {
+ rm -f ${S}/m4/init.m4
+ autotools_do_configure
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/grep ${D}${base_bindir}/grep.${PN}
+ mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep.${PN}
+ mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep.${PN}
+}
+
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_bindir}/grep grep grep.${PN} 100
+ update-alternatives --install ${base_bindir}/egrep egrep egrep.${PN} 100
+ update-alternatives --install ${base_bindir}/fgrep fgrep fgrep.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove grep grep.${PN}
+ update-alternatives --remove egrep egrep.${PN}
+ update-alternatives --remove fgrep fgrep.${PN}
+}
diff --git a/org.handhelds.familiar/packages/grep/grep_2.5.bb b/org.handhelds.familiar/packages/grep/grep_2.5.bb
new file mode 100644
index 0000000..c71dbb0
--- /dev/null
+++ b/org.handhelds.familiar/packages/grep/grep_2.5.bb
@@ -0,0 +1,16 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+DESCRIPTION = "grep GNU utility"
+MAINTAINER = "Pawel Osiczko <p.osiczko@tetrapyloctomy.org>"
+
+SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.bz2 \
+ file://install.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-perl-regexp --disable-ncurses"
+
+do_configure () {
+ rm -f ${S}/m4/init.m4
+ autotools_do_configure
+}