summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/fget
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
committerRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
commit5a5346dfbec459c10d9e61e16e125b83975a1ef1 (patch)
tree342e16f3fe790d03b93294344e6154459888939f /org.handhelds.familiar/packages/fget
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e35772d79306d1d9de19c12b23681618532d.
Diffstat (limited to 'org.handhelds.familiar/packages/fget')
-rw-r--r--org.handhelds.familiar/packages/fget/fget_1.3.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/org.handhelds.familiar/packages/fget/fget_1.3.3.bb b/org.handhelds.familiar/packages/fget/fget_1.3.3.bb
new file mode 100644
index 0000000..fe1f71c
--- /dev/null
+++ b/org.handhelds.familiar/packages/fget/fget_1.3.3.bb
@@ -0,0 +1,22 @@
+LICENSE = "BSD"
+DESCRIPTION = "fget is a commandline tool for mirroring \
+remote files via FTP. It was designed as an analog to the \
+GNU wget utility. The fget package includes an FTP client \
+library, so that others can make use of FTP from within \
+their own C programs."
+SECTION = "libs"
+PRIORITY = "optional"
+
+SRC_URI = "ftp://ftp.feep.net/pub/software/fget/fget-${PV}.tar.gz"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -a -C lib libfget ${STAGING_LIBDIR}
+ install -m 0755 lib/libfget.h ${STAGING_INCDIR}/
+}
+