summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/dbus/dbus-native_1.0.1.bb
diff options
context:
space:
mode:
authorMika Laitio <lamikr@cc.jyu.fi>2006-11-22 00:48:43 +0200
committerlamikr <lamikr@localhost.(none)>2006-11-22 00:48:43 +0200
commitfafa7b07c068663a1219526d3d42374dc458fe62 (patch)
tree475302853d10e5b4520d9c43a7608e037438fed9 /org.handhelds.familiar/packages/dbus/dbus-native_1.0.1.bb
parent14103bf1e4e6b43ea9f21a18ee0f67214e910342 (diff)
dbus-1.0.1: big update due to changes in DBUS API. Affected packages are: bluez-libs, bluez-utils, dbus, dbus-native, dbus-glib, dbus-glib-native, gnome-vfs-dbus, gomunicator, gpe-autostarter, gpe-beam, gpe-bluetooth.familiar_dev_lamikr
Diffstat (limited to 'org.handhelds.familiar/packages/dbus/dbus-native_1.0.1.bb')
-rw-r--r--org.handhelds.familiar/packages/dbus/dbus-native_1.0.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/org.handhelds.familiar/packages/dbus/dbus-native_1.0.1.bb b/org.handhelds.familiar/packages/dbus/dbus-native_1.0.1.bb
new file mode 100644
index 0000000..a897ae5
--- /dev/null
+++ b/org.handhelds.familiar/packages/dbus/dbus-native_1.0.1.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "message bus system for applications to talk to one another"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "GPL"
+SECTION = "base"
+
+PR = "r0"
+
+DEPENDS = "glib-2.0-native libxml2-native expat-native"
+
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-1.0.1"
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ "
+
+inherit autotools pkgconfig gettext native
+
+S = "${WORKDIR}/dbus-${PV}"
+
+EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
+ --disable-checks --disable-xml-docs --disable-doxygen-docs \
+ --with-xml=expat --without-x"
+
+do_stage () {
+ oe_runmake install
+ autotools_stage_all
+
+ # for dbus-glib-native introspection generation
+ install -d ${STAGING_DATADIR}/dbus
+ install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
+}