summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/bluez/bluez-libs_3.4.bb
diff options
context:
space:
mode:
authorMika Laitio <lamikr@cc.jyu.fi>2006-11-22 00:48:43 +0200
committerlamikr <lamikr@localhost.(none)>2006-11-22 00:48:43 +0200
commitfafa7b07c068663a1219526d3d42374dc458fe62 (patch)
tree475302853d10e5b4520d9c43a7608e037438fed9 /org.handhelds.familiar/packages/bluez/bluez-libs_3.4.bb
parent14103bf1e4e6b43ea9f21a18ee0f67214e910342 (diff)
dbus-1.0.1: big update due to changes in DBUS API. Affected packages are: bluez-libs, bluez-utils, dbus, dbus-native, dbus-glib, dbus-glib-native, gnome-vfs-dbus, gomunicator, gpe-autostarter, gpe-beam, gpe-bluetooth.familiar_dev_lamikr
Diffstat (limited to 'org.handhelds.familiar/packages/bluez/bluez-libs_3.4.bb')
-rw-r--r--org.handhelds.familiar/packages/bluez/bluez-libs_3.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/org.handhelds.familiar/packages/bluez/bluez-libs_3.4.bb b/org.handhelds.familiar/packages/bluez/bluez-libs_3.4.bb
new file mode 100644
index 0000000..d740bd8
--- /dev/null
+++ b/org.handhelds.familiar/packages/bluez/bluez-libs_3.4.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland Libaries."
+SECTION = "libs"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.bluez.org"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://bluez.sourceforge.net/download/bluez-libs-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+HEADERS = "bluetooth.h bnep.h cmtp.h hci.h hci_lib.h hidp.h l2cap.h rfcomm.h sco.h sdp.h sdp_lib.h"
+
+do_stage() {
+ oe_libinstall -a -so -C src libbluetooth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/bluetooth/
+ for f in ${HEADERS}
+ do
+ install -m 0644 include/$f ${STAGING_INCDIR}/bluetooth/$f
+ done
+}