aboutsummaryrefslogtreecommitdiff
path: root/third_party/CppHeaderParser/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/CppHeaderParser/setup.py')
-rw-r--r--third_party/CppHeaderParser/setup.py43
1 files changed, 43 insertions, 0 deletions
diff --git a/third_party/CppHeaderParser/setup.py b/third_party/CppHeaderParser/setup.py
new file mode 100644
index 00000000..3c254a03
--- /dev/null
+++ b/third_party/CppHeaderParser/setup.py
@@ -0,0 +1,43 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+import sys, glob
+from distutils.core import setup
+
+DESCRIPTION = (
+ 'Parse C++ header files and generate a data structure '
+ 'representing the class'
+ )
+
+
+CLASSIFIERS = [
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: C++',
+ 'License :: OSI Approved :: BSD License',
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'Topic :: Software Development',
+ 'Topic :: Software Development :: Code Generators',
+ 'Topic :: Software Development :: Compilers',
+ 'Topic :: Software Development :: Disassemblers'
+ ]
+
+setup(
+ name = 'CppHeaderParser',
+ version = '1.9',
+ author = 'Jashua Cloutier',
+ author_email = 'jashuac@bellsouth.net',
+ url = 'http://sourceforge.net/projects/cppheaderparser/',
+ description = DESCRIPTION,
+ long_description = open('README.txt').read(),
+ license = 'BSD',
+ platforms = 'Platform Independent',
+ packages = ['CppHeaderParser'],
+ keywords = 'c++ header parser ply',
+ classifiers = CLASSIFIERS,
+ requires = ['ply'],
+ package_data = { 'CppHeaderParser': ['README', 'README.html', 'doc/*.*', 'examples/*.*'], },
+ )