aboutsummaryrefslogtreecommitdiff
path: root/tests/openjpeg/doc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/openjpeg/doc/CMakeLists.txt')
-rw-r--r--tests/openjpeg/doc/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/openjpeg/doc/CMakeLists.txt b/tests/openjpeg/doc/CMakeLists.txt
new file mode 100644
index 00000000..aadbadba
--- /dev/null
+++ b/tests/openjpeg/doc/CMakeLists.txt
@@ -0,0 +1,15 @@
+FIND_PACKAGE(Doxygen)
+#
+IF(DOXYGEN_EXECUTABLE)
+# The Doxyfile.dox is poorly defined and produce output
+# in the source dir
+ADD_CUSTOM_TARGET(doxygen
+# By default doxygen target is added to the 'all' target. Project is small
+# thus running doxygen is not too time consuming
+ ALL
+ ${DOXYGEN}
+ ${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.dox
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+)
+ENDIF(DOXYGEN_EXECUTABLE)
+