Age | Commit message (Expand) | Author |
2008-07-13 | Fix mishandling of the infinite loop case when merging two blocks. This | Chris Lattner |
2008-07-13 | more refactoring. Use early exits instead of really complex logic. | Chris Lattner |
2008-07-13 | improve comments. | Chris Lattner |
2008-07-13 | factor another large hunk of code out into its own function. | Chris Lattner |
2008-07-13 | Final bit of simplification for FoldBranchToCommonDest. | Chris Lattner |
2008-07-13 | simplify logic a bit | Chris Lattner |
2008-07-13 | Refactor some code out into its own helper function, getting rid of crazy mul... | Chris Lattner |
2008-06-25 | - Use O(1) check of basic block size limit. | Evan Cheng |
2008-06-12 | Do not speculatively execute an instruction by hoisting it to its predecessor... | Evan Cheng |
2008-06-11 | For now, avoid generating FP select instructions in order to speculatively ex... | Evan Cheng |
2008-06-10 | op_iterator-ify loops | Gabor Greif |
2008-06-07 | Speculatively execute a block when the the block is the then part of a triang... | Evan Cheng |
2008-05-23 | Tidy up BasicBlock::getFirstNonPHI, and change a bunch of places to | Dan Gohman |
2008-05-23 | Restucture a part of the SimplifyCFG pass and include a testcase. | Matthijs Kooijman |
2008-05-16 | API change for {BinaryOperator|CmpInst|CastInst}::create*() --> Create. Legac... | Gabor Greif |
2008-05-15 | Fix a bunch of 80col violations that arose from the Create API change. Tweak ... | Gabor Greif |
2008-04-28 | Fix PR2256, yet another miscompilation in simplifycfg of i | Chris Lattner |
2008-04-25 | Remove 'unwinds to' support from mainline. This patch undoes r47802 r47989 | Nick Lewycky |
2008-04-24 | Split some code out of the main SimplifyCFG loop into its own function. | Chris Lattner |
2008-04-06 | API changes for class Use size reduction, wave 1. | Gabor Greif |
2008-03-11 | Check to see if a two-entry PHI block can be simplified | Dan Gohman |
2008-03-10 | Turn unwind_to into "unwinds to". | Nick Lewycky |
2008-03-09 | Firstly, having a BranchInst isn't exclusive with having an unwind_to. | Nick Lewycky |
2008-03-09 | A BB that unwind_to an "unwind" inst is that same as one that doesn't unwind_to | Nick Lewycky |
2008-03-09 | Update the inliner and simplifycfg to handle unwind_to. | Nick Lewycky |
2008-02-20 | Make Transforms to be 4.3 warnings-clean | Anton Korobeynikov |
2008-02-18 | switch simplifycfg from using vectors for most things to smallvectors, | Chris Lattner |
2008-01-03 | don't hoist FP additions into unconditional adds + selects. This | Chris Lattner |
2007-12-29 | Remove attribution from file headers, per discussion on llvmdev. | Chris Lattner |
2007-12-22 | If succ has succ itself as one of the predecessors then do | Devang Patel |
2007-11-27 | Fix PR1146: parameter attributes are longer part of | Duncan Sands |
2007-08-01 | New CallInst interface to address GLIBCXX_DEBUG errors caused by | David Greene |
2007-05-24 | Minor comment cleanups. | Dan Gohman |
2007-04-17 | remove use of Instruction::getNext | Chris Lattner |
2007-04-02 | reduce use of std::set | Chris Lattner |
2007-03-22 | Change uses of Function::front to Function::getEntryBlock for readability. | Dan Gohman |
2007-03-02 | Make sorting of ConstantInt be APInt clean through use of ult function. | Reid Spencer |
2007-02-13 | Eliminate use of ctors that take vectors. | Chris Lattner |
2007-02-11 | simplify code by using Value::takeName | Chris Lattner |
2007-01-30 | Adjust #includes to match movement of constant folding code from transformuti... | Chris Lattner |
2007-01-19 | For PR1043: | Reid Spencer |
2007-01-15 | rename Type::isIntegral to Type::isInteger, eliminating the old Type::isInteger. | Chris Lattner |
2007-01-15 | Eliminate calls to isInteger, generalizing code and tightening checks as needed. | Chris Lattner |
2007-01-12 | Implement review feedback for the ConstantBool->ConstantInt merge. Chris | Reid Spencer |
2007-01-11 | Rename BoolTy as Int1Ty. Patch by Sheng Zhou. | Reid Spencer |
2007-01-11 | For PR1043: | Zhou Sheng |
2006-12-23 | For PR950: | Reid Spencer |
2006-11-27 | For PR950: | Reid Spencer |
2006-11-26 | Remove #include <iostream> and use llvm_* streams instead. | Bill Wendling |
2006-11-18 | Do not convert massive blocks on phi nodes into select statements. Instead | Chris Lattner |