Age | Commit message (Expand) | Author |
2009-08-22 | move the MCAsmInfo .cpp/.h files into the right | Chris Lattner |
2009-08-22 | Rename TargetAsmInfo (and its subclasses) to MCAsmInfo. | Chris Lattner |
2009-08-13 | Revert 78892 and 78895, these break generating working executables on | Daniel Dunbar |
2009-08-13 | fix typo, add 10.6 version of test for my previous patch. | Chris Lattner |
2009-08-13 | fix a minor fixme. When building with SL and later tools, the ".eh" symbols | Chris Lattner |
2009-08-11 | Change the asmprinter to print the comment character before the | Chris Lattner |
2009-08-11 | factorize more darwin TAI stuff. Note that this gives | Chris Lattner |
2009-08-11 | factorize darwin ProtectedDirective and SetDirective. | Chris Lattner |
2009-08-11 | all darwin targets have .space and .zerofill, pull up. | Chris Lattner |
2009-08-11 | move LCOMMDirective = "\t.lcomm\t" up to DarwinTAI, eliminate | Chris Lattner |
2009-08-02 | move dwarf debug info section selection stuff from TAI to | Chris Lattner |
2009-08-02 | I need Triple information, 10.6 shouldn't set this, it bloats | Chris Lattner |
2009-08-02 | remove TargetAsmInfo::TM, which is now dead. The basic TAI class now | Chris Lattner |
2009-08-02 | convert ctors/dtors section to be in TLOF instead of | Chris Lattner |
2009-08-01 | Remove "JumpTableDataSection" from TAI, instead, have AsmPrinter | Chris Lattner |
2009-08-01 | REmove dead fields of TAI. | Chris Lattner |
2009-07-31 | move emitUsedDirectiveFor to TargetLoweringObjectFile and rename it to | Chris Lattner |
2009-07-28 | Rip all of the global variable lowering logic out of TargetAsmInfo. Since | Chris Lattner |
2009-07-27 | sink text/data section creation down into the target-specific places that | Chris Lattner |
2009-07-27 | 32-bit darwin targets support .literal16 too. | Chris Lattner |
2009-07-27 | Eliminate getNamed/getUnnamedSection, adding a new and unified getOrCreateSec... | Chris Lattner |
2009-07-27 | Eliminate SectionFlags, just embed a SectionKind into Section | Chris Lattner |
2009-07-26 | simplify this code now that SectionKind knows if a global is weak or not. | Chris Lattner |
2009-07-26 | rename Mergable -> Mergeable and Writable -> Writeable | Chris Lattner |
2009-07-26 | simplify getSectionForMergableConstant to take a SectionKind. | Chris Lattner |
2009-07-26 | introduce specialized mergable const sectionkinds for elements of size 4/8/16 to | Chris Lattner |
2009-07-26 | Rearrange all the SectionKinds and structure them into a hierarchical | Chris Lattner |
2009-07-26 | finish simplifying DarwinTargetAsmInfo::SelectSectionForGlobal | Chris Lattner |
2009-07-26 | simplify DarwinTargetAsmInfo::SelectSectionForGlobal a bit | Chris Lattner |
2009-07-25 | make SectionKind be a first-class pod struct instead of just | Chris Lattner |
2009-07-25 | this is (unfortunately) several changes mixed together: | Chris Lattner |
2009-07-24 | make SectionKindForGlobal target independent, and therefore non-virtual. | Chris Lattner |
2009-07-24 | we already know the sectionkind when invoking SelectSectionForGlobal, | Chris Lattner |
2009-07-24 | hoist section name uniquing logic up to the top-level SectionForGlobal | Chris Lattner |
2009-07-24 | Replace UniqueSectionForGlobal with getSectionPrefixForUniqueGlobal. | Chris Lattner |
2009-07-22 | inline the two MergeableConstSection implementations into their | Chris Lattner |
2009-07-22 | remove the SelectSectionForMachineConst hook, replacing it with | Chris Lattner |
2009-07-21 | simplify based on the fact that darwin always uses L/l. | Chris Lattner |
2009-07-21 | make some stuff private. | Chris Lattner |
2009-07-21 | Rename LessPrivateGlobalPrefix -> LinkerPrivateGlobalPrefix to match the | Chris Lattner |
2009-07-20 | Simplify the code in DarwinTargetAsmInfo::emitUsedDirectiveFor so that humans... | Bill Wendling |
2009-07-17 | Untangle a snarl that I discovered when updating the mangler, | Chris Lattner |
2009-07-15 | Remove StringConstantPrefix now that the only user | Duncan Sands |
2009-07-14 | Reapply my previous asmprinter changes now with more testing and two | Chris Lattner |
2009-07-14 | llvm_unreachable->llvm_unreachable(0), LLVM_UNREACHABLE->llvm_unreachable. | Torok Edwin |
2009-07-14 | Revert r7561{9,8,7,6}, which depend on r75610. | Daniel Dunbar |
2009-07-14 | rename getValueName -> getMangledName. These two files have very | Chris Lattner |
2009-07-11 | assert(0) -> LLVM_UNREACHABLE. | Torok Edwin |
2009-06-19 | merge the common darwin settings from the X86/PPC/ARM targets | Chris Lattner |
2009-05-09 | Rename PaddedSize to AllocSize, in the hope that this | Duncan Sands |