Age | Commit message (Expand) | Author |
2010-02-01 | Kill the Mach-O writer, and temporarily make filetype=obj an error. | Nate Begeman |
2010-01-17 | Add a note for the macho streamer and remove a used of the mangler from the s... | Nate Begeman |
2010-01-16 | move the mangler into libtarget from vmcore. | Chris Lattner |
2010-01-16 | reapply the mangler gutting patch. | Chris Lattner |
2010-01-16 | Revert 93648. | Rafael Espindola |
2010-01-16 | Mangler::getMangledName is now dead, remove it and all the other stuff in Man... | Chris Lattner |
2010-01-15 | Hook up llc's -filetype=obj to use MCStreamer if an MCCodeEmitter is available. | Nate Begeman |
2010-01-04 | Change errs() to dbgs(). | David Greene |
2009-08-23 | eliminate the "Value" printing methods that print to a std::ostream. | Chris Lattner |
2009-08-22 | rename TAI -> MAI, being careful not to make MAILJMP instructions :) | Chris Lattner |
2009-08-22 | Rename TargetAsmInfo (and its subclasses) to MCAsmInfo. | Chris Lattner |
2009-07-21 | Rename LessPrivateGlobalPrefix -> LinkerPrivateGlobalPrefix to match the | Chris Lattner |
2009-07-20 | Simplify the code in DarwinTargetAsmInfo::emitUsedDirectiveFor so that humans... | Bill Wendling |
2009-07-20 | Add plumbing for the `linker_private' linkage type. This type is meant for | Bill Wendling |
2009-07-14 | Reapply my previous asmprinter changes now with more testing and two | Chris Lattner |
2009-07-14 | llvm_unreachable->llvm_unreachable(0), LLVM_UNREACHABLE->llvm_unreachable. | Torok Edwin |
2009-07-14 | Revert r7561{9,8,7,6}, which depend on r75610. | Daniel Dunbar |
2009-07-14 | Rename getValueName -> getMangledName | Chris Lattner |
2009-07-13 | As Chris pointed out, this doesn't actually need an LLVMContext to operate. | Owen Anderson |
2009-07-13 | Begin the painful process of tearing apart the rat'ss nest that is Constants.... | Owen Anderson |
2009-07-11 | assert(0) -> LLVM_UNREACHABLE. | Torok Edwin |
2009-07-11 | Convert more assert(0)+abort() -> LLVM_UNREACHABLE, | Torok Edwin |
2009-07-06 | Cleanup MachO writer and code emitter. Fix 80 cols problems, remove extra spa... | Bruno Cardoso Lopes |
2009-07-06 | Add the Object Code Emitter class. Original patch by Aaron Gray, I did some | Bruno Cardoso Lopes |
2009-06-03 | Move structures and classes into header files, providing two new headers and | Bruno Cardoso Lopes |
2009-05-30 | Use uint8_t and int32_t in {JIT,Machine}CodeEmiters | Bruno Cardoso Lopes |
2009-05-09 | Rename PaddedSize to AllocSize, in the hope that this | Duncan Sands |
2009-03-11 | It makes no sense to have a ODR version of common | Duncan Sands |
2009-03-07 | Introduce new linkage types linkonce_odr, weak_odr, common_odr | Duncan Sands |
2009-02-18 | Add support to the JIT for true non-lazy operation. When a call to a function | Nate Begeman |
2009-01-15 | Add the private linkage. | Rafael Espindola |
2009-01-12 | Rename getABITypeSize to getTypePaddedSize, as | Duncan Sands |
2008-12-19 | Fix some release-assert warnings | Chris Lattner |
2008-12-10 | Fix MachineCodeEmitter to use uintptr_t instead of intptr_t. This avoids some... | Evan Cheng |
2008-11-08 | Rename startFunctionStub to startGVStub since it's also used for GV non-lazy ... | Evan Cheng |
2008-10-09 | Rename APFloat::convertToAPInt to bitcastToAPInt to | Dale Johannesen |
2008-09-04 | Tidy up several unbeseeming casts from pointer to intptr_t. | Dan Gohman |
2008-08-21 | Use raw_ostream throughout the AsmPrinter. | Owen Anderson |
2008-05-23 | Use isSingleValueType instead of isFirstClassType to | Dan Gohman |
2008-05-14 | Add CommonLinkage; currently tentative definitions | Dale Johannesen |
2008-04-16 | Correlate stubs with functions in JIT: when emitting a stub, the JIT tells th... | Nicolas Geoffray |
2008-03-11 | Use PassManagerBase instead of FunctionPassManager for functions | Dan Gohman |
2008-02-20 | Unbreak build with gcc 4.3: provide missed includes and silence most annoying... | Anton Korobeynikov |
2008-02-13 | Enable exception handling int JIT | Nicolas Geoffray |
2008-01-29 | Use getPreferredAlignmentLog or getPreferredAlignment | Duncan Sands |
2007-12-29 | Remove attribution from file headers, per discussion on llvmdev. | Chris Lattner |
2007-11-05 | Eliminate the remaining uses of getTypeSize. This | Duncan Sands |
2007-09-12 | Revise previous patch per review comments. | Dale Johannesen |
2007-09-11 | Add APInt interfaces to APFloat (allows directly | Dale Johannesen |
2007-09-06 | Next round of APFloat changes. | Dale Johannesen |