aboutsummaryrefslogtreecommitdiff
path: root/tools/opt/CMakeLists.txt
diff options
context:
space:
mode:
authorKarl Schimpf <kschimpf@google.com>2013-05-24 12:04:22 -0700
committerKarl Schimpf <kschimpf@google.com>2013-05-24 12:04:22 -0700
commitfde18fe06ae70f60e0f184a9d384055c4f08cbbb (patch)
tree96a77030079d2d53a706131a39e606db31bd19dc /tools/opt/CMakeLists.txt
parent80b7ba7480724c773b96da24999d817b6b46ef29 (diff)
Allow generation of pnacl bitcode files in several llvm commnads.
Adds command line option '-pnacl-freeze' to generate a pnacl bit code file instead of an llvm bitcode file. BUG= https://code.google.com/p/nativeclient/issues/detail?id=3405 R=dschuff@chromium.org Review URL: https://codereview.chromium.org/15178005
Diffstat (limited to 'tools/opt/CMakeLists.txt')
-rw-r--r--tools/opt/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/opt/CMakeLists.txt b/tools/opt/CMakeLists.txt
index 3b268a4205..9d41db9dda 100644
--- a/tools/opt/CMakeLists.txt
+++ b/tools/opt/CMakeLists.txt
@@ -1,4 +1,4 @@
-set(LLVM_LINK_COMPONENTS ${LLVM_TARGETS_TO_BUILD} bitreader asmparser bitwriter instrumentation naclanalysis nacltransforms scalaropts objcarcopts ipo vectorize)
+set(LLVM_LINK_COMPONENTS ${LLVM_TARGETS_TO_BUILD} bitreader asmparser bitwriter naclbitwriter instrumentation naclanalysis nacltransforms scalaropts objcarcopts ipo vectorize)
add_llvm_tool(opt
AnalysisWrappers.cpp