Age | Commit message (Expand) | Author |
2010-01-25 | Split libAnalysis into two libraries: libAnalysis and libChecker. | Ted Kremenek |
2009-12-23 | move a few more symbols to .rodata/.data.rel.ro | Nuno Lopes |
2009-11-29 | Kill some unnecessary calls to c_str(). | Benjamin Kramer |
2009-11-28 | lib/Analysis: Remove VISIBILITY_HIDDEN from definitions in anonymous namespace | Kovarththanan Rajaratnam |
2009-11-23 | Clean up the Checker API a little more, resolving some hidden bugs | Ted Kremenek |
2009-11-20 | Fix typo GCC 4.3 warned about. | Benjamin Kramer |
2009-11-20 | Add simple static analyzer checker to check for sending 'release', 'retain', ... | Ted Kremenek |
2009-11-10 | Rename: StripCasts describes what it does better. | Zhongxing Xu |
2009-11-03 | Implement: <rdar://problem/6250216> Warn against using -[NSAutoreleasePool re... | Ted Kremenek |
2009-10-18 | PR5218: Replace IdentifierInfo::getName with StringRef version, now that clients | Daniel Dunbar |
2009-10-18 | Move clients to use IdentifierInfo::getNameStart() instead of getName() | Daniel Dunbar |
2009-10-17 | Simplify. | Daniel Dunbar |
2009-09-21 | Change all the Type::getAsFoo() methods to specializations of Type::getAs(). | John McCall |
2009-09-09 | Remove tabs, and whitespace cleanups. | Mike Stump |
2009-08-21 | Tie the local check NSErrorCheck to a Decl to pave the way | Zhongxing Xu |
2009-08-06 | Last step of template cleanup: merge *BuilderImpl to *Builder. | Zhongxing Xu |
2009-08-06 | As GRState seems general enough, it is time to merge some template classes | Zhongxing Xu |
2009-07-29 | Remove some uses of TypedViewRegion, and use getBaseRegion() in a context where | Ted Kremenek |
2009-07-22 | Refactor 'PostStmt' and 'PreStmt' to subclass a common parent 'StmtPoint'. | Ted Kremenek |
2009-07-14 | Add basic checking for passing NULL to CFRetain/CFRelease, since those functions | Ted Kremenek |
2009-07-10 | This patch includes a conceptually simple, but very intrusive/pervasive change. | Steve Naroff |
2009-06-18 | Move clients over from using GRStateManager::BindXXX and friends to | Ted Kremenek |
2009-05-09 | As discussed with Ted, rename TypedRegion::getObjectType() to | Zhongxing Xu |
2009-05-09 | rename: MemRegion: | Zhongxing Xu |
2009-04-20 | get a CodeTextRegion when visiting FunctionDecl reference. | Zhongxing Xu |
2009-03-01 | Rename AnonTypedRegion to TypedViewRegion. | Ted Kremenek |
2009-02-04 | Overhaul BugReporter interface and implementation. The new interface cleans up | Ted Kremenek |
2008-12-13 | MemRegion: | Ted Kremenek |
2008-11-24 | Rename Selector::getName() to Selector::getAsString(), and add | Chris Lattner |
2008-10-24 | Added method "getSelfRegion" to Store. This method returns the region associ... | Ted Kremenek |
2008-10-17 | - constify some uses of MemRegion* (MemRegion should be immutable). | Ted Kremenek |
2008-10-17 | This patch did the following renaming. There should be no functional changes. | Zhongxing Xu |
2008-10-04 | This is a big patch, but the functionality change is small and the rest of th... | Ted Kremenek |
2008-09-21 | The checks in BasicObjCFoundationChecks now have a category: "API Misuse (App... | Ted Kremenek |
2008-09-18 | Change implementation of NSError** coding-style check to be invoked at the en... | Ted Kremenek |
2008-08-29 | Remove dead method. | Ted Kremenek |
2008-08-13 | Rename ValueState -> GRState. | Ted Kremenek |
2008-08-11 | More #include cleaning | Daniel Dunbar |
2008-07-26 | change more instances of QualType::getCanonicalType to call | Chris Lattner |
2008-07-22 | Moved registration of basic path-sensitive checks from GRSimpleVals.cpp to GR... | Ted Kremenek |
2008-07-22 | Added path-sensitive checking for null pointer values passed to function argu... | Ted Kremenek |
2008-07-10 | Refactored most of the "Store" piece of ValueState into a Store type. The | Ted Kremenek |
2008-06-26 | Added a simple static analysis check to look for improper uses of CFCreateNum... | Ted Kremenek |
2008-05-29 | - Move ObjC Expresssion AST's from Expr.h => ExprObjC.h | Steve Naroff |
2008-05-20 | fix warning with gcc 4.1 (ptr to bool convertion) | Nuno Lopes |
2008-05-01 | Do not highlight bogus ranges for leaks. | Ted Kremenek |
2008-04-30 | More cleanups with ObjCQualifiedIdType in the static analyzer. | Ted Kremenek |
2008-04-30 | Teach more of the static analyzer about ObjCQualifiedIdType. | Ted Kremenek |
2008-04-19 | Gracefully handle when the receiver of a message expression is not a pointer ... | Ted Kremenek |
2008-04-18 | Generalize caching mechanism for bugs reports. Now individual BugTypes | Ted Kremenek |