aboutsummaryrefslogtreecommitdiff
path: root/lib/Serialization/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2011-12-09 01:55:54 +0000
committerChandler Carruth <chandlerc@gmail.com>2011-12-09 01:55:54 +0000
commit71088d1af241ad114294ec3fe03cd9baea39ee08 (patch)
treedb55119af79835e5f0ad0abfaa2292971d564fd7 /lib/Serialization/CMakeLists.txt
parent8bd25b421f728cb7c33a3bcc21a4fc60e835c5e8 (diff)
Move ChainedIncludesSource into the Frontend library. This never really
belonged in the Serialization library, it's setting up a compilation, not just deserializing. This should fix PR11512, making Serialization actually be layered below Frontend, a long standing layering violation in Clang. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@146233 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Serialization/CMakeLists.txt')
-rw-r--r--lib/Serialization/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/Serialization/CMakeLists.txt b/lib/Serialization/CMakeLists.txt
index 62991a9f55..71f28ff587 100644
--- a/lib/Serialization/CMakeLists.txt
+++ b/lib/Serialization/CMakeLists.txt
@@ -11,7 +11,6 @@ add_clang_library(clangSerialization
ASTWriter.cpp
ASTWriterDecl.cpp
ASTWriterStmt.cpp
- ChainedIncludesSource.cpp
GeneratePCH.cpp
Module.cpp
ModuleManager.cpp